Loading ...
Sorry, an error occurred while loading the content.

Re: XIM Input Method for Motif Gvim

Expand Messages
  • Chris Jones
    ... Do you have an IME set up..? Doesn t sound rational, but perhaps you need one installed.. in order to turn it off..? CJ -- Hi! My name is bobby... -- You
    Message 1 of 7 , Jun 2 9:36 AM
    • 0 Attachment
      On Sat, Jun 02, 2012 at 08:08:04AM EDT, Christian Brabandt wrote:

      > I have recently been working on the Motif GUI and noticed, that my
      > gvim always show XIM INSERT, when in insert mode. I keep reading :h
      > xim and mbyte-XIM, but I seem to be missing something. So my questions
      > are:

      > 1) Why is XIM enabled by default?
      > 2) How do I use it?
      > 3) And most importantly: How do I turn if off?

      Do you have an IME set up..? Doesn't sound rational, but perhaps you
      need one installed.. in order to turn it off..?

      CJ

      --
      Hi! My name is bobby...

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Christian Brabandt
      Hi Chris! ... Not that I know of. How would I set it up? regards, Christian -- -- You received this message from the vim_use maillist. Do not top-post! Type
      Message 2 of 7 , Jun 2 12:01 PM
      • 0 Attachment
        Hi Chris!

        On Sa, 02 Jun 2012, Chris Jones wrote:

        > On Sat, Jun 02, 2012 at 08:08:04AM EDT, Christian Brabandt wrote:
        >
        > > I have recently been working on the Motif GUI and noticed, that my
        > > gvim always show XIM INSERT, when in insert mode. I keep reading :h
        > > xim and mbyte-XIM, but I seem to be missing something. So my questions
        > > are:
        >
        > > 1) Why is XIM enabled by default?
        > > 2) How do I use it?
        > > 3) And most importantly: How do I turn if off?
        >
        > Do you have an IME set up..? Doesn't sound rational, but perhaps you

        Not that I know of. How would I set it up?

        regards,
        Christian
        --

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Chris Jones
        ... Hi Christian, My undestanding is that you need to install an input server that covers your particular data entry needs. I could be 100% wrong about that,
        Message 3 of 7 , Jun 2 2:42 PM
        • 0 Attachment
          On Sat, Jun 02, 2012 at 03:01:12PM EDT, Christian Brabandt wrote:
          > Hi Chris!
          >
          > On Sa, 02 Jun 2012, Chris Jones wrote:
          > > On Sat, Jun 02, 2012 at 08:08:04AM EDT, Christian Brabandt wrote:

          > > > I have recently been working on the Motif GUI and noticed, that my
          > > > gvim always show XIM INSERT, when in insert mode. I keep reading
          > > > :h xim and mbyte-XIM, but I seem to be missing something. So my
          > > > questions are:

          > > > 1) Why is XIM enabled by default?
          > > > 2) How do I use it?
          > > > 3) And most importantly: How do I turn if off?

          > > Do you have an IME set up..? Doesn't sound rational, but perhaps you
          >
          > Not that I know of. How would I set it up?

          Hi Christian,

          My undestanding is that you need to install an input server that covers
          your particular data entry needs. I could be 100% wrong about that, but
          that might explain the different web links on the help page. They point
          to stuff that's not part of the Vim offering.

          This was meant more as a general remark, though.. mostly to the effect
          that it's much easier to figure out IME documentation when you have an
          IME installed to play with.

          Here's an ancient thread that may be of some interest:

          | http://tech.groups.yahoo.com/group/vim-multibyte/message/351

          Again, I may be sending you altogether down the wrong path..

          Thanks,

          CJ

          --
          Oh My God!!! Larry is back!

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Chris Jones
          On Sat, Jun 02, 2012 at 03:01:12PM EDT, Christian Brabandt wrote: [..] ... Regarding (3) above, I forgot to mention that there is an imdisable/noimdisable
          Message 4 of 7 , Jun 2 5:51 PM
          • 0 Attachment
            On Sat, Jun 02, 2012 at 03:01:12PM EDT, Christian Brabandt wrote:

            [..]

            > > > 1) Why is XIM enabled by default?
            > > > 2) How do I use it?
            > > > 3) And most importantly: How do I turn if off?

            Regarding (3) above, I forgot to mention that there is an
            imdisable/noimdisable boolean option.

            But I guess you have already tried that..?

            CJ

            --
            SOMEBODY SET UP US THE BOMB

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Tony Mechelynck
            ... Best regards, Tony. -- It is Texas law that when two trains meet each other at a railroad crossing, each shall come to a full stop, and neither shall
            Message 5 of 7 , Jun 2 8:23 PM
            • 0 Attachment
              On 03/06/12 02:51, Chris Jones wrote:
              > On Sat, Jun 02, 2012 at 03:01:12PM EDT, Christian Brabandt wrote:
              >
              > [..]
              >
              >>>> 1) Why is XIM enabled by default?
              >>>> 2) How do I use it?
              >>>> 3) And most importantly: How do I turn if off?
              >
              > Regarding (3) above, I forgot to mention that there is an
              > imdisable/noimdisable boolean option.
              >
              > But I guess you have already tried that..?
              >
              > CJ
              >

              Yes, see also:
              :help 'imdisable'
              :help 'iminsert'
              :help CTRL-^

              Best regards,
              Tony.
              --
              It is Texas law that when two trains meet each other at a railroad
              crossing, each shall come to a full stop, and neither shall proceed
              until the other has gone.

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Christian Brabandt
              Hi Tony! ... I guess, you meant :h i_CTRL-^ and thanks, that works. Bram, I suggest to put a link to these help topics below :h xim I am still wondering, why
              Message 6 of 7 , Jun 3 4:30 AM
              • 0 Attachment
                Hi Tony!

                On So, 03 Jun 2012, Tony Mechelynck wrote:

                > On 03/06/12 02:51, Chris Jones wrote:
                > >On Sat, Jun 02, 2012 at 03:01:12PM EDT, Christian Brabandt wrote:
                > >
                > >[..]
                > >
                > >>>> 1) Why is XIM enabled by default?
                > >>>> 2) How do I use it?
                > >>>> 3) And most importantly: How do I turn if off?
                > >
                > >Regarding (3) above, I forgot to mention that there is an
                > >imdisable/noimdisable boolean option.
                > >
                > >But I guess you have already tried that..?
                >
                > Yes, see also:
                > :help 'imdisable'
                > :help 'iminsert'
                > :help CTRL-^

                I guess, you meant :h i_CTRL-^ and thanks, that works. Bram, I suggest
                to put a link to these help topics below :h xim

                I am still wondering, why the Motif GUI enables the X Input Method.
                Although IME and Multibyte feature seem to be independent of each other,
                it doesn't sound to be reasonable to enable the first, while the latter
                is completely unsupported.

                regards,
                Christian

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              Your message has been successfully submitted and would be delivered to recipients shortly.