Loading ...
Sorry, an error occurred while loading the content.

Jump to tag command doesn't work in gvim under Windows 7

Expand Messages
  • Väinö Leppänen
    The mouse version of this command actually work (g and ), but the keyboard version CTRL-] doesn t for some reason. Any ideas? -- You
    Message 1 of 6 , May 31 12:28 AM
    • 0 Attachment
      The mouse version of this command actually work (g<LeftMouse> and <C-LeftMouse>), but the keyboard version CTRL-] doesn't for some reason.

      Any ideas?

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Jürgen Krämer
      Hi, ... on Windows the behaviour of Ctrl plus a non-letter is independent of the actual keyboard layout (at least inside Vim). As far as I know for those
      Message 2 of 6 , May 31 12:44 AM
      • 0 Attachment
        Hi,

        Väinö Leppänen wrote:
        >
        > The mouse version of this command actually work (g<LeftMouse> and
        > <C-LeftMouse>), but the keyboard version CTRL-] doesn't for some
        > reason.
        >
        > Any ideas?

        on Windows the behaviour of Ctrl plus a non-letter is independent of the
        actual keyboard layout (at least inside Vim). As far as I know for those
        combinations to work you have to press Ctrl and the same key that would
        generate the non-letter if you had installed the US-American keyboard
        driver. For "[" and "]" this would be the keys between "P" and the
        Return key.

        Regards,
        Jürgen

        --
        Sometimes I think the surest sign that intelligent life exists elsewhere
        in the universe is that none of it has tried to contact us. (Calvin)

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Väinö Leppänen
        ... And that solved the problem. Thanks! -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are
        Message 3 of 6 , May 31 12:50 AM
        • 0 Attachment
          On Thursday, May 31, 2012 10:44:25 AM UTC+3, Jürgen Krämer wrote:
          > Hi,
          >
          > V�in� Lepp�nen wrote:
          > >
          > > The mouse version of this command actually work (g<LeftMouse> and
          > > <C-LeftMouse>), but the keyboard version CTRL-] doesn't for some
          > > reason.
          > >
          > > Any ideas?
          >
          > on Windows the behaviour of Ctrl plus a non-letter is independent of the
          > actual keyboard layout (at least inside Vim). As far as I know for those
          > combinations to work you have to press Ctrl and the same key that would
          > generate the non-letter if you had installed the US-American keyboard
          > driver. For "[" and "]" this would be the keys between "P" and the
          > Return key.
          >
          > Regards,
          > J�rgen
          >
          > --
          > Sometimes I think the surest sign that intelligent life exists elsewhere
          > in the universe is that none of it has tried to contact us. (Calvin)

          And that solved the problem.
          Thanks!

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Ben Fritz
          ... Huh? I ve got my keyboard (a standard QWERTY keyboard) mapped to US-Dvorak in Windows XP, and to get CTRL-] I press CTRL and the key labelled =/+, not the
          Message 4 of 6 , May 31 7:57 AM
          • 0 Attachment
            On Thursday, May 31, 2012 2:44:25 AM UTC-5, Jürgen Krämer wrote:

            >
            > on Windows the behaviour of Ctrl plus a non-letter is independent of the
            > actual keyboard layout (at least inside Vim). As far as I know for those
            > combinations to work you have to press Ctrl and the same key that would
            > generate the non-letter if you had installed the US-American keyboard
            > driver. For "[" and "]" this would be the keys between "P" and the
            > Return key.
            >

            Huh? I've got my keyboard (a standard QWERTY keyboard) mapped to US-Dvorak in Windows XP, and to get CTRL-] I press CTRL and the key labelled =/+, not the key labelled ]/}.

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Christian Brabandt
            ... Isn t that what Jürgen said? On a German keyboard (at least for Windows) you need to press Ctrl-ü rather then the key labeld ] to produce an actual
            Message 5 of 6 , May 31 8:02 AM
            • 0 Attachment
              On Thu, May 31, 2012 16:57, Ben Fritz wrote:
              > On Thursday, May 31, 2012 2:44:25 AM UTC-5, Jürgen Krämer wrote:
              >
              >>
              >> on Windows the behaviour of Ctrl plus a non-letter is independent of the
              >> actual keyboard layout (at least inside Vim). As far as I know for those
              >> combinations to work you have to press Ctrl and the same key that would
              >> generate the non-letter if you had installed the US-American keyboard
              >> driver. For "[" and "]" this would be the keys between "P" and the
              >> Return key.
              >>
              >
              > Huh? I've got my keyboard (a standard QWERTY keyboard) mapped to US-Dvorak
              > in Windows XP, and to get CTRL-] I press CTRL and the key labelled =/+,
              > not the key labelled ]/}.

              Isn't that what Jürgen said? On a German keyboard (at least for Windows)
              you need to press Ctrl-ü rather then the key labeld ] to produce an
              actual keycode of <C-]>.

              On linux on the other side, I need to press the key labeld ].

              regards,
              Christian

              regards,
              Christian

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Ben Fritz
              ... We may be talking about different ways of getting a non-standard keyboard. I think I understand now, that you and Jürgen are talking about a keyboard
              Message 6 of 6 , May 31 10:54 AM
              • 0 Attachment
                On Thursday, May 31, 2012 10:02:36 AM UTC-5, Christian Brabandt wrote:
                > On Thu, May 31, 2012 16:57, Ben Fritz wrote:
                > > On Thursday, May 31, 2012 2:44:25 AM UTC-5, J�rgen Kr�mer wrote:
                > >
                > >>
                > >> on Windows the behaviour of Ctrl plus a non-letter is independent of the
                > >> actual keyboard layout (at least inside Vim). As far as I know for those
                > >> combinations to work you have to press Ctrl and the same key that would
                > >> generate the non-letter if you had installed the US-American keyboard
                > >> driver. For "[" and "]" this would be the keys between "P" and the
                > >> Return key.
                > >>
                > >
                > > Huh? I've got my keyboard (a standard QWERTY keyboard) mapped to US-Dvorak
                > > in Windows XP, and to get CTRL-] I press CTRL and the key labelled =/+,
                > > not the key labelled ]/}.
                >
                > Isn't that what J�rgen said? On a German keyboard (at least for Windows)
                > you need to press Ctrl-� rather then the key labeld ] to produce an
                > actual keycode of <C-]>.
                >
                > On linux on the other side, I need to press the key labeld ].
                >

                We may be talking about different ways of getting a non-standard keyboard.

                I think I understand now, that you and Jürgen are talking about a keyboard whose keys are physically labelled different than a standard US QWERTY keyboard, and pressing CTRL+] on that keyboard does not send Vim a CTRL+] keystroke.

                I am saying that I have a physical US QWERTY keyboard, and I've applied a US Dvorak keyboard layout, by going into Control Panel→Regional and Language Options→Languages→Details...

                On my physical QWERTY keyboard mapped to Dvorak, I press CTRL and the key which in Dvorak yields a ], and Vim gets CTRL+] as I expect.

                I think you're saying if I had a physical Dvorak keyboard with no software mapping, pressing CTRL and the key which yields a ], will NOT send Vim a CTRL+], but something else.

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              Your message has been successfully submitted and would be delivered to recipients shortly.