Loading ...
Sorry, an error occurred while loading the content.

set guifont=*

Expand Messages
  • qfwfq
    Hi, I installed vim on my unix system but when i try to run gvim it gives me the warning: Warning: Missing charsets in String to FontSet conversion I tried:
    Message 1 of 9 , May 28, 2012
    • 0 Attachment
      Hi,

      I installed vim on my unix system but when i try to run gvim it gives me the
      warning:

      Warning: Missing charsets in String to FontSet conversion

      I tried:

      set guifont=*

      but no font can be used apart from the ugly one that is loaded by default.
      I installed vim with the --enable-gui option on but nothing changes.

      Thanks for the answers.

      --
      View this message in context: http://vim.1045645.n5.nabble.com/set-guifont-tp5708608.html
      Sent from the Vim - General mailing list archive at Nabble.com.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... Well, maybe Vim cannot find the installed fonts, or maybe (for GUI flavours other than GTK2) your ugly default font is the only one whose Properties
      Message 2 of 9 , May 28, 2012
      • 0 Attachment
        On 28/05/12 14:16, qfwfq wrote:
        > Hi,
        >
        > I installed vim on my unix system but when i try to run gvim it gives me the
        > warning:
        >
        > Warning: Missing charsets in String to FontSet conversion
        >
        > I tried:
        >
        > set guifont=*
        >
        > but no font can be used apart from the ugly one that is loaded by default.
        > I installed vim with the --enable-gui option on but nothing changes.
        >
        > Thanks for the answers.
        >
        > --
        > View this message in context: http://vim.1045645.n5.nabble.com/set-guifont-tp5708608.html
        > Sent from the Vim - General mailing list archive at Nabble.com.
        >


        Well, maybe Vim cannot find the installed fonts, or maybe (for GUI
        flavours other than GTK2) your "ugly default" font is the only one whose
        Properties include monospace.

        Which GUI flavour you got can be found from somewhere near the top of
        the :version output: for instance, in gvim I see

        [...]
        Huge version with GTK2-GNOME GUI. Features included (+) or not (-):
        [...]

        Of course, the :set guifont= command will only change the font if you
        are running in GUI mode (gvim, or vim -g, or after issuing the :gui
        command successfully). In console mode, a GUI-enabled Vim will accept
        the command and remember the operand, but the console font can only be
        changed by the console terminal (xterm etc.), or, for some consoles, not
        at all.


        Best regards,
        Tony.
        --
        Back up my hard drive? I can't find the reverse switch!

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • qfwfq
        Thank for your reply! ... at all. In fact I can change the font only after I open gvim. I tried to set the font in the .gvimrc but it didn t work. I ll dig
        Message 3 of 9 , May 29, 2012
        • 0 Attachment
          Thank for your reply!

          >>> Which GUI flavour you got can be found from somewhere near the top of
          >>> the :version output: for instance, in gvim I see:

          Normal version with X11-Motif GUI. Features included (+) or not (-):

          >>> the console font can only be changed by the console terminal (xterm
          >>> etc.), or, for some consoles, not
          at all.

          In fact I can change the font only after I open gvim. I tried to set the
          font in the .gvimrc but it didn't work.
          I'll dig into X11-Motif GUI documentation to try to find a solution.
          Thanks!

          --
          View this message in context: http://vim.1045645.n5.nabble.com/set-guifont-tp5708608p5708622.html
          Sent from the Vim - General mailing list archive at Nabble.com.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Ben Fritz
          ... Yes, this is the only way :set guifont=* will ever work. Did you try that in your .vimrc? ... What did you try to set it to? The easy way to figure out
          Message 4 of 9 , May 29, 2012
          • 0 Attachment
            On Tuesday, May 29, 2012 2:29:34 AM UTC-5, qfwfq wrote:
            >
            > In fact I can change the font only after I open gvim.

            Yes, this is the only way :set guifont=* will ever work. Did you try that in your .vimrc?

            > I tried to set the
            > font in the .gvimrc but it didn't work.

            What did you try to set it to? The easy way to figure out what will work is to first use :set guifont=*, select the desired font, then :set guifont? to see what it actually got set to.

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Ben Fritz
            ... Also see http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI -- You received this message from the vim_use maillist. Do not top-post! Type your reply
            Message 5 of 9 , May 29, 2012
            • 0 Attachment
              On Tuesday, May 29, 2012 10:03:57 PM UTC-5, Ben Fritz wrote:
              > On Tuesday, May 29, 2012 2:29:34 AM UTC-5, qfwfq wrote:
              > >
              > > In fact I can change the font only after I open gvim.
              >
              > Yes, this is the only way :set guifont=* will ever work. Did you try that in your .vimrc?
              >
              > > I tried to set the
              > > font in the .gvimrc but it didn't work.
              >
              > What did you try to set it to? The easy way to figure out what will work is to first use :set guifont=*, select the desired font, then :set guifont? to see what it actually got set to.

              Also see http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Dominique Pell√©
              ... Did you pick a font which is listed by xlsfonts ? Anyway, using the gtk2 GUI is preferable if you can. The X11-Motif GUI does not support Unicode among
              Message 6 of 9 , May 29, 2012
              • 0 Attachment
                qfwfq <veranda.marco@...> wrote:

                >
                > Thank for your reply!
                >
                > >>> Which GUI flavour you got can be found from somewhere near the top of
                > >>> the :version output: for instance, in gvim I see:
                >
                > Normal version with X11-Motif GUI.  Features included (+) or not (-):
                >
                > >>> the console font can only be changed by the console terminal (xterm
                > >>> etc.), or, for some consoles, not
                > at all.
                >
                > In fact I can change the font only after I open gvim. I tried to set the
                > font in the .gvimrc but it didn't work.
                > I'll dig into X11-Motif GUI documentation to try to find a solution.
                > Thanks!

                Did you pick a font which is listed by "xlsfonts"?

                Anyway, using the gtk2 GUI is preferable if you can.
                The X11-Motif GUI does not support Unicode among other things.

                Regards
                -- Dominique

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • qfwfq
                Ben Fritz wrote ... It was a mistake in how I was setting the guifont in my .gvimrc: Now I say: set
                Message 7 of 9 , May 30, 2012
                • 0 Attachment
                  Ben Fritz wrote
                  >
                  >
                  > What did you try to set it to? The easy way to figure out what will work
                  > is to first use :set guifont=*, select the desired font, then :set
                  > guifont? to see what it actually got set to.
                  >
                  >

                  It was a mistake in how I was setting the guifont in my .gvimrc:
                  Now I say:

                  set guifont=-adobe-courier-medium-r-normal--17-120-100-100-m-100-iso8859-1

                  and everything works; when i :set guifont? and I get what it is supposed to
                  be.

                  Thank you.

                  --
                  View this message in context: http://vim.1045645.n5.nabble.com/set-guifont-tp5708608p5708651.html
                  Sent from the Vim - General mailing list archive at Nabble.com.

                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Tony Mechelynck
                  ... The above works, yet it is still too restrictive. ... might work even better (find the same base font, possibly also the corresponding italic and/or bold
                  Message 8 of 9 , May 31, 2012
                  • 0 Attachment
                    On 30/05/12 10:57, qfwfq wrote:
                    >
                    > Ben Fritz wrote
                    >>
                    >>
                    >> What did you try to set it to? The easy way to figure out what will work
                    >> is to first use :set guifont=*, select the desired font, then :set
                    >> guifont? to see what it actually got set to.
                    >>
                    >>
                    >
                    > It was a mistake in how I was setting the guifont in my .gvimrc:
                    > Now I say:
                    >
                    > set guifont=-adobe-courier-medium-r-normal--17-120-100-100-m-100-iso8859-1
                    >
                    > and everything works; when i :set guifont? and I get what it is supposed to
                    > be.
                    >
                    > Thank you.
                    >
                    > --
                    > View this message in context: http://vim.1045645.n5.nabble.com/set-guifont-tp5708608p5708651.html
                    > Sent from the Vim - General mailing list archive at Nabble.com.
                    >


                    The above works, yet it is still too restrictive.

                    :set guifont=-*-courier-medium-r-normal-*-*-120-*-*-m-*-*

                    might work even better (find the same base font, possibly also the
                    corresponding italic and/or bold fonts if defined, and also any variants
                    of the same font, if they exist, for other charsets than Latin1).


                    Best regards,
                    Tony.
                    --
                    Here is the problem: for many years, the Supreme Court wrestled with
                    the issue of pornography, until finally Associate Justice John Paul
                    Stevens came up with the famous quotation about how he couldn't define
                    pornography, but he knew it when he saw it. So for a while, the
                    court's policy was to have all the suspected pornography trucked to
                    Justice Stevens' house, where he would look it over. "Nope, this isn't
                    it," he'd say. "Bring some more." This went on until one morning when
                    his housekeeper found him trapped in the recreation room under an
                    enormous mound of rubberized implements, and the court had to issue a
                    ruling stating that it didn't know what the hell pornography was except
                    that it was illegal and everybody should stop badgering the court about
                    it because the court was going to take a nap.
                    -- Dave Barry, "Pornography"

                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • qfwfq
                    Yep, thank Tony, it works the same and it is more general. Bye! -- View this message in context:
                    Message 9 of 9 , Jun 1, 2012
                    • 0 Attachment
                      Yep,

                      thank Tony, it works the same and it is more general.
                      Bye!

                      --
                      View this message in context: http://vim.1045645.n5.nabble.com/set-guifont-tp5708608p5708703.html
                      Sent from the Vim - General mailing list archive at Nabble.com.

                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    Your message has been successfully submitted and would be delivered to recipients shortly.