Loading ...
Sorry, an error occurred while loading the content.

Re: vim and doxygen (c-style) block comment problems

Expand Messages
  • jrrandall@gmail.com
    ... Thanks so much for your help! Just to let you know, it was Vim version 7.0 that was causing the problems. I upgraded to 7.3 and the block indenting is
    Message 1 of 6 , May 1, 2012
    • 0 Attachment
      On Fri, Apr 27, 2012 at 12:16 PM, Ben Fritz <fritzophrenic@...> wrote:
      > On Friday, April 27, 2012 10:02:11 AM UTC-5, Justin wrote:
      >> Running ":verbose set ft? autoindent? smartindent? cindent? cino?"
      >> from my Vim it says:
      >>
      >>   filetype=cpp
      >>         Last set from /usr/local/share/vim/vim70/filetype.vim
      >>   autoindent
      >>         Last set from ~/.vimrc
      >>   smartindent
      >>         Last set from ~/.vimrc
      >>   cindent
      >>         Last set from /usr/local/share/vim/vim70/indent/cpp.vim
      >>   cinoptions=(0
      >>         Last set from ~/.vimrc
      >>
      >> I tried adding W2s to my cinoptions like you have, as well as setting
      >> noautoindent and nosmartindent, but I still have the problem.
      >> Hmm... maybe the cindent and cinoptions get set differently between
      >> vim 7.0 and 7.3?
      >>
      >>
      >
      > Maybe. Checking the help, I think I understand:
      >
      > autoindent has no effect if smartindent, cindent, or indentexpr is set
      > smartindent has no effect if cindent or indentexpr is set
      > cindent has no effect if indentexpr is set
      >
      > So, also check the value of indentexpr. If that doesn't fix your issue, try upgrading your Vim version. You don't mention your system, but it is quite likely there's a more recent version available through your normal download means, or you can always build from source.
      >
      > http://vim.wikia.com/wiki/Download
      >
      > --
      > You received this message from the "vim_use" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.php

      Thanks so much for your help! Just to let you know, it was Vim
      version 7.0 that was causing the problems. I upgraded to 7.3 and the
      block indenting is working like a champ now with the exact same config
      and plugins I was running earlier! Thanks again!

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.