Loading ...
Sorry, an error occurred while loading the content.

gtk-config not even tried

Expand Messages
  • Arno Valentin
    I have two HP-UX machines say A and B with HP-UX 11.11 and 11.31 respectively. I have compiled gvim 7.3 from source an B, and gvim 7.0 on A, both with same
    Message 1 of 11 , Apr 27, 2012
    • 0 Attachment
      I have two HP-UX machines say A and B with HP-UX 11.11 and 11.31
      respectively. I'have compiled gvim 7.3 from source an B, and gvim 7.0
      on A, both with same options for configure..

      On A, gvim uses "version with GTK GUI", Compilation with gcc (...) -
      DFEAT_GUI_GTK and all works fine.

      On B, gvim looks different and uses "version with X11-Motif GUI",
      compilation with -DFEAT_GUI_MOTIF.

      Here ssh -X does not copy paste on selection:

      - copy/paste via select works on a GVim window on A, but not on B.
      - When I select some text in the GVim window, I can paste it via
      right-click within that window, but I cannot paste it into another
      window in X. When I select something on another X-Window, I can paste
      it within X but when I paste into the GVim window, it pastes the last
      thing selected in the GVim window, not the last thing selected an X.

      This problem is described elsewhere and the solution was to build gvim
      using gtk2.

      The Problem is: I cannot rebuild gvim with gtk. Although I have
      installed GTK+ on the machine via HP depot (GTK 2.6) and using gtk+ is
      called default in the Makefile configure ends up with compiler option
      "gcc (...) -DFEAT_GUI_MOTIF".

      to be more specific:
      configure gives:

      checking --enable-gui argument... yes/auto - automatic GUI support
      checking whether or not to look for GTK+ 2... yes

      but doesn't search for gtk Libraries. It only looks for Motif:

      checking for location of Motif GUI libs... /usr/lib/Motif1.1

      It doesn't tell me that it is missing anything I can provide!
      In the directory "auto" the file configure.log shows no failure in
      searching for GTk, it just doesnt look for!

      configure:7577: result: yes/auto - automatic GUI support
      configure:7609: checking whether or not to look for GTK+ 2
      configure:7618: result: yes
      configure:7627: checking whether or not to look for GNOME
      configure:7636: result: no
      configure:7644: checking whether or not to look for Motif
      configure:7653: result: yes
      configure:7661: checking whether or not to look for Athena
      configure:7670: result: yes
      configure:7678: checking whether or not to look for neXtaw
      configure:7687: result: yes
      configure:7695: checking whether or not to look for Carbon
      configure:7704: result: yes
      configure:7752: checking --disable-gtktest argument
      configure:7762: result: gtk test enabled
      configure:7772: checking for pkg-config
      configure:7803: result: no
      configure:8035: checking for location of Motif GUI includes
      configure:8047: result: in default path
      configure:8062: checking --with-motif-lib argument
      configure:8076: result: no
      configure:8081: checking for location of Motif GUI libs
      configure:8099: result: /usr/lib/Motif1.1
      configure:8202: checking for XShapeQueryExtension in -lXext


      And make starts with OPTION Motif:

      avalenti@ncc1n:/usr/local/src/vim/vim73/src >make | tee make-
      minimal.results
      mkdir objects
      CC="gcc -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MOTIF -I/usr/local/
      include " srcdir=. sh ./osdef.sh
      gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MOTIF -I/usr/local/
      include -g -O2 -D_FORTIFY_SOURCE=1 -o objects/buffer.o buffer.c
      (...)

      If I force usings gtk with

      configure --enable-gui=gtk2

      make ends up with no error but gvim says:

      "E25: GUI cannot be used: Not enabled at compile time"

      In another thread here in vim_use I saw configure mention using gtk-
      config.
      I don't get any message from configure, that it tries or searches for
      gtk-config.

      It's in my search-path, but it is not used by gvim build procedure.

      avalenti@ncc1n:/opt/gtk2.6/lib >type gtk-config
      gtk-config is /usr/local/bin/gtk-config

      How can I force gvim to compile using gtk2?



      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... The first thing is to check your configure listing for possible missing software packages. Maybe gtk2-devel (or gtk2-dev or similar depending on
      Message 2 of 11 , Apr 27, 2012
      • 0 Attachment
        On 27/04/12 17:03, Arno Valentin wrote:
        > I have two HP-UX machines say A and B with HP-UX 11.11 and 11.31
        > respectively. I'have compiled gvim 7.3 from source an B, and gvim 7.0
        > on A, both with same options for configure..
        >
        > On A, gvim uses "version with GTK GUI", Compilation with gcc (...) -
        > DFEAT_GUI_GTK and all works fine.
        >
        > On B, gvim looks different and uses "version with X11-Motif GUI",
        > compilation with -DFEAT_GUI_MOTIF.
        >
        > Here ssh -X does not copy paste on selection:
        >
        > - copy/paste via select works on a GVim window on A, but not on B.
        > - When I select some text in the GVim window, I can paste it via
        > right-click within that window, but I cannot paste it into another
        > window in X. When I select something on another X-Window, I can paste
        > it within X but when I paste into the GVim window, it pastes the last
        > thing selected in the GVim window, not the last thing selected an X.
        >
        > This problem is described elsewhere and the solution was to build gvim
        > using gtk2.
        >
        > The Problem is: I cannot rebuild gvim with gtk. Although I have
        > installed GTK+ on the machine via HP depot (GTK 2.6) and using gtk+ is
        > called default in the Makefile configure ends up with compiler option
        > "gcc (...) -DFEAT_GUI_MOTIF".
        >
        > to be more specific:
        > configure gives:
        >
        > checking --enable-gui argument... yes/auto - automatic GUI support
        > checking whether or not to look for GTK+ 2... yes
        >
        > but doesn't search for gtk Libraries. It only looks for Motif:
        >
        > checking for location of Motif GUI libs... /usr/lib/Motif1.1
        >
        > It doesn't tell me that it is missing anything I can provide!
        > In the directory "auto" the file configure.log shows no failure in
        > searching for GTk, it just doesnt look for!
        >
        > configure:7577: result: yes/auto - automatic GUI support
        > configure:7609: checking whether or not to look for GTK+ 2
        > configure:7618: result: yes
        > configure:7627: checking whether or not to look for GNOME
        > configure:7636: result: no
        > configure:7644: checking whether or not to look for Motif
        > configure:7653: result: yes
        > configure:7661: checking whether or not to look for Athena
        > configure:7670: result: yes
        > configure:7678: checking whether or not to look for neXtaw
        > configure:7687: result: yes
        > configure:7695: checking whether or not to look for Carbon
        > configure:7704: result: yes
        > configure:7752: checking --disable-gtktest argument
        > configure:7762: result: gtk test enabled
        > configure:7772: checking for pkg-config
        > configure:7803: result: no
        > configure:8035: checking for location of Motif GUI includes
        > configure:8047: result: in default path
        > configure:8062: checking --with-motif-lib argument
        > configure:8076: result: no
        > configure:8081: checking for location of Motif GUI libs
        > configure:8099: result: /usr/lib/Motif1.1
        > configure:8202: checking for XShapeQueryExtension in -lXext
        >
        >
        > And make starts with OPTION Motif:
        >
        > avalenti@ncc1n:/usr/local/src/vim/vim73/src >make | tee make-
        > minimal.results
        > mkdir objects
        > CC="gcc -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MOTIF -I/usr/local/
        > include " srcdir=. sh ./osdef.sh
        > gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MOTIF -I/usr/local/
        > include -g -O2 -D_FORTIFY_SOURCE=1 -o objects/buffer.o buffer.c
        > (...)
        >
        > If I force usings gtk with
        >
        > configure --enable-gui=gtk2
        >
        > make ends up with no error but gvim says:
        >
        > "E25: GUI cannot be used: Not enabled at compile time"
        >
        > In another thread here in vim_use I saw configure mention using gtk-
        > config.
        > I don't get any message from configure, that it tries or searches for
        > gtk-config.
        >
        > It's in my search-path, but it is not used by gvim build procedure.
        >
        > avalenti@ncc1n:/opt/gtk2.6/lib >type gtk-config
        > gtk-config is /usr/local/bin/gtk-config
        >
        > How can I force gvim to compile using gtk2?
        >
        >
        >


        The first thing is to check your configure listing for possible missing
        software packages. Maybe gtk2-devel (or gtk2-dev or similar depending on
        distribution), but there might be others. In all cases you need
        *development* packages for every single bit of software that will be
        compiled into your application.

        If the stdout/stderr log from configure doesn't give you enough clues,
        check src/auto/config.log which is more detailed (but also contains more
        information which you *won't* need).

        If you find possible missing packages and install them, run "make
        reconfig" to reconfigure and recompile.

        See also:
        http://vim.wikia.com/wiki/Getting_the_Vim_source_with_Mercurial
        http://users.skynet.be/antoine.mechelynck/vim/compunix.htm


        Best regards,
        Tony.
        --
        DINGO: And after the spanking ... the oral sex.
        GALAHAD: Oh, dear! Well, I...
        GIRLS: The oral sex ... The oral sex.
        GALAHAD: Well, I suppose I could stay a BIT longer.
        "Monty Python and the Holy Grail" PYTHON (MONTY)
        PICTURES LTD

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Arno Valentin
        ... (...) Well, the problem is: I m not using Linux, but HP-UX and I don t know how to get gtk-devel. I m offered gtk+-1.2.10 , gtk+2-2.24.10 , gtk+3-3.2.4
        Message 3 of 11 , Apr 30, 2012
        • 0 Attachment
          > (...) In all cases you need
          > *development* packages for every single bit of software that will be
          > compiled into your application.
          >
          (...)

          Well, the problem is: I'm not using Linux, but HP-UX and I don't know how to get gtk-devel. I'm offered "gtk+-1.2.10", "gtk+2-2.24.10", "gtk+3-3.2.4" and all are described as "Gimp Toolkit for creating graphical user interfaces" but nothing beginning with gtk and ending with something like "dev" or "devel".

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • John Little
          ... IIUC, gtk+2-2.24.10 is the one you want, being gtk 2. In my config.log, configure tries to see what version of gtk is installed by compiling and running a
          Message 4 of 11 , Apr 30, 2012
          • 0 Attachment
            On Tuesday, May 1, 2012 2:32:51 AM UTC+12, Arno Valentin wrote:
            > ... I'm offered "gtk+-1.2.10", "gtk+2-2.24.10", "gtk+3-3.2.4" ...

            IIUC, gtk+2-2.24.10 is the one you want, being gtk 2.

            In my config.log, configure tries to see what version of gtk is installed by compiling and running a gtk test programme:

            configure:7987: checking for GTK - version >= 2.2.0
            configure:8054: gcc -o conftest -Wall -Wshadow -Wmissing-prototypes -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/local/include -L/usr/local/lib conftest.c -lnsl -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 >&5
            configure:8054: $? = 0
            configure:8054: ./conftest
            configure:8054: $? = 0
            configure:8069: result: yes; found version 2.24.6

            If I was missing needed libraries, IIUC I'd see errors about what was missing. However, my config has used pkg-config; IIUC that's part of autotools which you seem to have. It needs to work for configure to decide you've got gtk.

            HTH, and regards, John

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Arno Valentin
            ... I don t know, what pkg-config is, but after gtk test comes 551 configure:7772: checking for pkg-config 552 configure:7803: result: no ... yes I tried
            Message 5 of 11 , May 2, 2012
            • 0 Attachment
              Am Dienstag, 1. Mai 2012 03:29:01 UTC+2 schrieb John Little:
              > On Tuesday, May 1, 2012 2:32:51 AM UTC+12, Arno Valentin wrote:
              > > ... I'm offered "gtk+-1.2.10", "gtk+2-2.24.10", "gtk+3-3.2.4" ...
              >
              > IIUC, gtk+2-2.24.10 is the one you want, being gtk 2.
              >
              > In my config.log, configure tries to see what version of gtk is installed by compiling and running a gtk test programme:
              >
              > configure:7987: checking for GTK - version >= 2.2.0
              > configure:8054: gcc -o conftest -Wall -Wshadow -Wmissing-prototypes -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/local/include -L/usr/local/lib conftest.c -lnsl -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 >&5
              > configure:8054: $? = 0
              > configure:8054: ./conftest
              > configure:8054: $? = 0
              > configure:8069: result: yes; found version 2.24.6
              >
              > If I was missing needed libraries, IIUC I'd see errors about what was missing. However, my config has used pkg-config; IIUC that's part of autotools which you seem to have. It needs to work for configure to decide you've got gtk.
              >
              > HTH, and regards, John

              I don't know, what pkg-config is, but after gtk test comes

              551 configure:7772: checking for pkg-config
              552 configure:7803: result: no






              Am Dienstag, 1. Mai 2012 03:29:01 UTC+2 schrieb John Little:
              > On Tuesday, May 1, 2012 2:32:51 AM UTC+12, Arno Valentin wrote:
              > > ... I'm offered "gtk+-1.2.10", "gtk+2-2.24.10", "gtk+3-3.2.4" ...
              >
              > IIUC, gtk+2-2.24.10 is the one you want, being gtk 2.
              >
              > In my config.log, configure tries to see what version of gtk is installed by compiling and running a gtk test programme:
              >
              > configure:7987: checking for GTK - version >= 2.2.0
              > configure:8054: gcc -o conftest -Wall -Wshadow -Wmissing-prototypes -pthread -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0/ -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/local/include -L/usr/local/lib conftest.c -lnsl -pthread -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lrt -lglib-2.0 >&5
              > configure:8054: $? = 0
              > configure:8054: ./conftest
              > configure:8054: $? = 0
              > configure:8069: result: yes; found version 2.24.6
              >
              > If I was missing needed libraries, IIUC I'd see errors about what was missing. However, my config has used pkg-config; IIUC that's part of autotools which you seem to have. It needs to work for configure to decide you've got gtk.
              >
              > HTH, and regards, John

              yes I tried gtk+2-2.24.10 and I'm looking for any message that he is missing any library which he would tell me. And I'm looking for configure using gtk-config to get the parameters it needs. But there is nothing:

              avalenti@ncc1n:/usr/local/src/vim/vim73/src/auto >grep gtk config.log
              $ auto/configure --enable-gui=gtk2 --with-tclsh=tclsh8.4 --with-compiledby=Arno, no nls, gtk2 --srcdir=. --cache-file=auto/config.cache
              configure:4540: result: Arno, no nls, gtk2
              configure:7752: checking --disable-gtktest argument
              configure:7762: result: gtk test enabled
              compiledby='Arno, no nls, gtk2'

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • John Little
              ... My reading of the configure script indicates that pkg-config is needed to compile vim-gtk. There s a package for it at the HP porting centre. Regards,
              Message 6 of 11 , May 2, 2012
              • 0 Attachment
                On Thursday, May 3, 2012 1:42:56 AM UTC+12, Arno Valentin wrote:
                >
                > I don't know, what pkg-config is, but after gtk test comes
                >
                > 551 configure:7772: checking for pkg-config
                > 552 configure:7803: result: no

                My reading of the configure script indicates that pkg-config is needed to compile vim-gtk. There's a package for it at the HP porting centre.

                Regards, John

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • John Little
                ... My sympathies, how were you supposed to know that? I ve just checked that the gtk+2-2.24.10 tarball from the porting centre has the .pc files that
                Message 7 of 11 , May 2, 2012
                • 0 Attachment
                  On Thursday, May 3, 2012 11:29:46 AM UTC+12, I wrote:

                  > My reading of the configure script indicates that pkg-config is needed to compile vim-gtk. There's a package for it at the HP porting centre.

                  My sympathies, how were you supposed to know that?

                  I've just checked that the "gtk+2-2.24.10" tarball from the porting centre has the .pc files that pkg-config uses. (It occurred to me that would be your next hurdle.)

                  Regards, John

                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Arno Valentin
                  ... Thank you for that advice. I got the depot of pkg-config, installed it, started the installation of vim from scratch (remove directory vim73, tar -xvf
                  Message 8 of 11 , May 3, 2012
                  • 0 Attachment
                    Am Donnerstag, 3. Mai 2012 05:41:02 UTC+2 schrieb John Little:
                    > On Thursday, May 3, 2012 11:29:46 AM UTC+12, I wrote:
                    >
                    > > My reading of the configure script indicates that pkg-config is needed to compile vim-gtk. There's a package for it at the HP porting centre.
                    >
                    > My sympathies, how were you supposed to know that?
                    >
                    > I've just checked that the "gtk+2-2.24.10" tarball from the porting centre has the .pc files that pkg-config uses. (It occurred to me that would be your next hurdle.)
                    >
                    > Regards, John

                    Thank you for that advice.

                    I got the depot of pkg-config, installed it, started the installation of vim from scratch (remove directory vim73, tar -xvf ...), and now I get another anomalie:

                    configure says:

                    checking for pkg-config... /usr/local/bin/pkg-config
                    checking for GTK - version >= 2.2.0... no
                    checking for location of Motif GUI includes... in default path

                    In System Management Homepage (SMH, successor of SAM) I can see, GTK has version 2.6.8.00.01, that is GTK+ 2.6, this should be greater than 2.2.0.

                    On the other hand, I've got a gtk-config, which say's differently:

                    avalenti@ncc1n:/home/avalenti >type gtk-config
                    gtk-config is /usr/local/bin/gtk-config

                    avalenti@ncc1n:/home/avalenti >gtk-config --version
                    1.2.10

                    I guess, that is why configure doesn't recognize it as version 2.6.
                    But how to get rid of the wrong gtk-config? According to SMH gtk2.6 resides in /opt/gtk2.6, not in /usr/local/bin. But there I don't find a gtk-config:

                    # pwd
                    /opt/gtk2.6
                    # find . -name gtk-config
                    #

                    How to get rid of this inkonsistencies?

                    Another strangeness - configure mentions pkg-config without telling about errors. But if i manually start pkg-config, I get an error.

                    # type pkg-config
                    pkg-config is /usr/local/bin/pkg-config
                    # pkg-config -h
                    /usr/lib/hpux32/dld.so: Unable to find library 'libglib-2.0.so'.
                    Killed

                    I'm driving mad it's getting worse and worse. It's installed from a depot! So there should be included all dependencies, shouldn't they?

                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • Arno Valentin
                    ... now i deinstalled gtk+ and gtk+2.6, reinstalled gtk as before with the result, that SMH now shows gtk+2 Revision 2.24.10, gtk+2. Maybe, the former gtk2.6
                    Message 9 of 11 , May 3, 2012
                    • 0 Attachment
                      Am Donnerstag, 3. Mai 2012 15:27:48 UTC+2 schrieb Arno Valentin:
                      > Am Donnerstag, 3. Mai 2012 05:41:02 UTC+2 schrieb John Little:
                      > > On Thursday, May 3, 2012 11:29:46 AM UTC+12, I wrote:
                      > >
                      > > > My reading of the configure script indicates that pkg-config is needed to compile vim-gtk. There's a package for it at the HP porting centre.
                      > >
                      > > My sympathies, how were you supposed to know that?
                      > >
                      > > I've just checked that the "gtk+2-2.24.10" tarball from the porting centre has the .pc files that pkg-config uses. (It occurred to me that would be your next hurdle.)
                      > >
                      > > Regards, John
                      >
                      > Thank you for that advice.
                      >
                      > I got the depot of pkg-config, installed it, started the installation of vim from scratch (remove directory vim73, tar -xvf ...), and now I get another anomalie:
                      >
                      > configure says:
                      >
                      > checking for pkg-config... /usr/local/bin/pkg-config
                      > checking for GTK - version >= 2.2.0... no
                      > checking for location of Motif GUI includes... in default path
                      >
                      > In System Management Homepage (SMH, successor of SAM) I can see, GTK has version 2.6.8.00.01, that is GTK+ 2.6, this should be greater than 2.2.0.
                      >
                      > On the other hand, I've got a gtk-config, which say's differently:
                      >
                      > avalenti@ncc1n:/home/avalenti >type gtk-config
                      > gtk-config is /usr/local/bin/gtk-config
                      >
                      > avalenti@ncc1n:/home/avalenti >gtk-config --version
                      > 1.2.10
                      >
                      > I guess, that is why configure doesn't recognize it as version 2.6.
                      > But how to get rid of the wrong gtk-config? According to SMH gtk2.6 resides in /opt/gtk2.6, not in /usr/local/bin. But there I don't find a gtk-config:
                      >
                      > # pwd
                      > /opt/gtk2.6
                      > # find . -name gtk-config
                      > #
                      >
                      > How to get rid of this inkonsistencies?
                      >
                      > Another strangeness - configure mentions pkg-config without telling about errors. But if i manually start pkg-config, I get an error.
                      >
                      > # type pkg-config
                      > pkg-config is /usr/local/bin/pkg-config
                      > # pkg-config -h
                      > /usr/lib/hpux32/dld.so: Unable to find library 'libglib-2.0.so'.
                      > Killed
                      >
                      > I'm driving mad it's getting worse and worse. It's installed from a depot! So there should be included all dependencies, shouldn't they?

                      now i deinstalled gtk+ and gtk+2.6, reinstalled gtk as before with the result, that SMH now shows "gtk+2 Revision 2.24.10, gtk+2.

                      Maybe, the former gtk2.6 was gtk Version 1, Revision 2.6.

                      But gtk-config still says "1.2.10", although it changes: now it lives in /opt/gnome:

                      avalenti@ncc1n:/home/avalenti >type gtk-config
                      gtk-config is /opt/gnome/bin/gtk-config
                      avalenti@ncc1n:/home/avalenti >gtk-config --version
                      1.2.10

                      And of course configure acts as before.

                      checking for GTK - version >= 2.2.0... no

                      and pkg-config has failures too.

                      # /usr/local/bin/pkg-config
                      /usr/lib/hpux32/dld.so: Unable to find library 'libglib-2.0.so'.

                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    • Arno Valentin
                      ... I can understand that, I don t find libglib-2.0 either and something similar neither: # find . -name libglib-2.0* # pwd / But where do I get it from? --
                      Message 10 of 11 , May 3, 2012
                      • 0 Attachment
                        Am Donnerstag, 3. Mai 2012 16:26:53 UTC+2 schrieb Arno Valentin:
                        > Am Donnerstag, 3. Mai 2012 15:27:48 UTC+2 schrieb Arno Valentin:
                        > > Am Donnerstag, 3. Mai 2012 05:41:02 UTC+2 schrieb John Little:
                        > > > On Thursday, May 3, 2012 11:29:46 AM UTC+12, I wrote:
                        > > >
                        > > > > My reading of the configure script indicates that pkg-config is needed to compile vim-gtk. There's a package for it at the HP porting centre.
                        > > >
                        > > > My sympathies, how were you supposed to know that?
                        > > >
                        > > > I've just checked that the "gtk+2-2.24.10" tarball from the porting centre has the .pc files that pkg-config uses. (It occurred to me that would be your next hurdle.)
                        > > >
                        > > > Regards, John
                        > >
                        > > Thank you for that advice.
                        > >
                        > > I got the depot of pkg-config, installed it, started the installation of vim from scratch (remove directory vim73, tar -xvf ...), and now I get another anomalie:
                        > >
                        > > configure says:
                        > >
                        > > checking for pkg-config... /usr/local/bin/pkg-config
                        > > checking for GTK - version >= 2.2.0... no
                        > > checking for location of Motif GUI includes... in default path
                        > >
                        > > In System Management Homepage (SMH, successor of SAM) I can see, GTK has version 2.6.8.00.01, that is GTK+ 2.6, this should be greater than 2.2.0.
                        > >
                        > > On the other hand, I've got a gtk-config, which say's differently:
                        > >
                        > > avalenti@ncc1n:/home/avalenti >type gtk-config
                        > > gtk-config is /usr/local/bin/gtk-config
                        > >
                        > > avalenti@ncc1n:/home/avalenti >gtk-config --version
                        > > 1.2.10
                        > >
                        > > I guess, that is why configure doesn't recognize it as version 2.6.
                        > > But how to get rid of the wrong gtk-config? According to SMH gtk2.6 resides in /opt/gtk2.6, not in /usr/local/bin. But there I don't find a gtk-config:
                        > >
                        > > # pwd
                        > > /opt/gtk2.6
                        > > # find . -name gtk-config
                        > > #
                        > >
                        > > How to get rid of this inkonsistencies?
                        > >
                        > > Another strangeness - configure mentions pkg-config without telling about errors. But if i manually start pkg-config, I get an error.
                        > >
                        > > # type pkg-config
                        > > pkg-config is /usr/local/bin/pkg-config
                        > > # pkg-config -h
                        > > /usr/lib/hpux32/dld.so: Unable to find library 'libglib-2.0.so'.
                        > > Killed
                        > >
                        > > I'm driving mad it's getting worse and worse. It's installed from a depot! So there should be included all dependencies, shouldn't they?
                        >
                        > now i deinstalled gtk+ and gtk+2.6, reinstalled gtk as before with the result, that SMH now shows "gtk+2 Revision 2.24.10, gtk+2.
                        >
                        > Maybe, the former gtk2.6 was gtk Version 1, Revision 2.6.
                        >
                        > But gtk-config still says "1.2.10", although it changes: now it lives in /opt/gnome:
                        >
                        > avalenti@ncc1n:/home/avalenti >type gtk-config
                        > gtk-config is /opt/gnome/bin/gtk-config
                        > avalenti@ncc1n:/home/avalenti >gtk-config --version
                        > 1.2.10
                        >
                        > And of course configure acts as before.
                        >
                        > checking for GTK - version >= 2.2.0... no
                        >
                        > and pkg-config has failures too.
                        >
                        > # /usr/local/bin/pkg-config
                        > /usr/lib/hpux32/dld.so: Unable to find library 'libglib-2.0.so'

                        Am Donnerstag, 3. Mai 2012 16:26:53 UTC+2 schrieb Arno Valentin:
                        > Am Donnerstag, 3. Mai 2012 15:27:48 UTC+2 schrieb Arno Valentin:
                        > > Am Donnerstag, 3. Mai 2012 05:41:02 UTC+2 schrieb John Little:
                        > > > On Thursday, May 3, 2012 11:29:46 AM UTC+12, I wrote:
                        > > >
                        > > > > My reading of the configure script indicates that pkg-config is needed to compile vim-gtk. There's a package for it at the HP porting centre.
                        > > >
                        > > > My sympathies, how were you supposed to know that?
                        > > >
                        > > > I've just checked that the "gtk+2-2.24.10" tarball from the porting centre has the .pc files that pkg-config uses. (It occurred to me that would be your next hurdle.)
                        > > >
                        > > > Regards, John
                        > >
                        > > Thank you for that advice.
                        > >
                        > > I got the depot of pkg-config, installed it, started the installation of vim from scratch (remove directory vim73, tar -xvf ...), and now I get another anomalie:
                        > >
                        > > configure says:
                        > >
                        > > checking for pkg-config... /usr/local/bin/pkg-config
                        > > checking for GTK - version >= 2.2.0... no
                        > > checking for location of Motif GUI includes... in default path
                        > >
                        > > In System Management Homepage (SMH, successor of SAM) I can see, GTK has version 2.6.8.00.01, that is GTK+ 2.6, this should be greater than 2.2.0.
                        > >
                        > > On the other hand, I've got a gtk-config, which say's differently:
                        > >
                        > > avalenti@ncc1n:/home/avalenti >type gtk-config
                        > > gtk-config is /usr/local/bin/gtk-config
                        > >
                        > > avalenti@ncc1n:/home/avalenti >gtk-config --version
                        > > 1.2.10
                        > >
                        > > I guess, that is why configure doesn't recognize it as version 2.6.
                        > > But how to get rid of the wrong gtk-config? According to SMH gtk2.6 resides in /opt/gtk2.6, not in /usr/local/bin. But there I don't find a gtk-config:
                        > >
                        > > # pwd
                        > > /opt/gtk2.6
                        > > # find . -name gtk-config
                        > > #
                        > >
                        > > How to get rid of this inkonsistencies?
                        > >
                        > > Another strangeness - configure mentions pkg-config without telling about errors. But if i manually start pkg-config, I get an error.
                        > >
                        > > # type pkg-config
                        > > pkg-config is /usr/local/bin/pkg-config
                        > > # pkg-config -h
                        > > /usr/lib/hpux32/dld.so: Unable to find library 'libglib-2.0.so'.
                        > > Killed
                        > >
                        > > I'm driving mad it's getting worse and worse. It's installed from a depot! So there should be included all dependencies, shouldn't they?
                        >
                        > now i deinstalled gtk+ and gtk+2.6, reinstalled gtk as before with the result, that SMH now shows "gtk+2 Revision 2.24.10, gtk+2.
                        >
                        > Maybe, the former gtk2.6 was gtk Version 1, Revision 2.6.
                        >
                        > But gtk-config still says "1.2.10", although it changes: now it lives in /opt/gnome:
                        >
                        > avalenti@ncc1n:/home/avalenti >type gtk-config
                        > gtk-config is /opt/gnome/bin/gtk-config
                        > avalenti@ncc1n:/home/avalenti >gtk-config --version
                        > 1.2.10
                        >
                        > And of course configure acts as before.
                        >
                        > checking for GTK - version >= 2.2.0... no
                        >
                        > and pkg-config has failures too.
                        >
                        > # /usr/local/bin/pkg-config
                        > /usr/lib/hpux32/dld.so: Unable to find library 'libglib-2.0.so'.

                        I can understand that, I don't find libglib-2.0 either and something similar neither:

                        # find . -name libglib-2.0*
                        # pwd
                        /

                        But where do I get it from?

                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                      • John Little
                        ... FWICS, you re in a variety of dependency hell (http://en.wikipedia.org/wiki/Dependency_hell); surely there s a way for HP-UXers to resolve this? Perhaps
                        Message 11 of 11 , May 3, 2012
                        • 0 Attachment
                          On Friday, May 4, 2012 2:51:44 AM UTC+12, Arno Valentin wrote:

                          > > # /usr/local/bin/pkg-config
                          > > /usr/lib/hpux32/dld.so: Unable to find library 'libglib-2.0.so'.

                          FWICS, you're in a variety of dependency hell (http://en.wikipedia.org/wiki/Dependency_hell); surely there's a way for HP-UXers to resolve this? Perhaps an actual HP-UX person would be better help.

                          Anyway,
                          >... I don't find libglib-2.0...
                          > But where do I get it from?

                          Presumably from:
                          http://hpux.connect.org.uk/hppd/hpux/Gtk/Development/glib2-2.32.1/

                          I got that from looking on
                          http://hpux.connect.org.uk/hppd/hpux/Development/Tools/pkgconfig-0.26/
                          at the Run-time dependencies: section. Interestingly, pkgconfig is dependent on glib2, which has a build-time dependency on pkgconfig!

                          Regards, John

                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                        Your message has been successfully submitted and would be delivered to recipients shortly.