Loading ...
Sorry, an error occurred while loading the content.

Re: E365 hardcopy

Expand Messages
  • Phil Dobbin
    ... Hash: SHA1 ... I solved the hardcopy problem by commenting out the `pdev` line in my vimrc. Why Vim decided it was no longer correct is a mystery. It
    Message 1 of 4 , Mar 31 4:45 PM
    • 0 Attachment
      -----BEGIN PGP SIGNED MESSAGE-----
      Hash: SHA1

      On 31/03/2012 17:03, Phil Dobbin wrote:

      > On 31/03/2012 14:23, Tony Mechelynck wrote:
      >
      >> On 31/03/12 13:38, Phil Dobbin wrote:
      >
      >>> Out of the blue this morning my Debian Squeeze Vim (7.2.445
      >>> console=huge GUI=gtk2+huge) has started throwing the hardcopy
      >>> error:
      >>>
      >>> `E365: Failed to print Postscript file`
      >>>
      >>> this is on both the GUI & console Debian supplied Vims.
      >>>
      >>> Apt hasn't downloaded & installed any print updates recently &
      >>> I can print the same test files from gedit, etc.
      >>>
      >>> Last time I had this on setting up Vim on Fedora it was a
      >>> print preferences error (different name for the printer than
      >>> specified in my vimrc) but this is not the case in this
      >>> instance.
      >>>
      >>> I printed from this Vim on this machine a couple of days ago no
      >>> problem & I haven't altered my runtime or machine settings in
      >>> the meantime.
      >
      >> - Any recent changes in the PostScript / groff / other related…
      >> packages on your system? - See also ":help print.txt" and in
      >> particular: - :help print-intro - :help print-options

      > No, nothing has changed on the system (only nagios has been
      > installed & that came without the print monitor option) & I've read
      > & re-read the above help files several times but nothing in there
      > seems to be relevant.
      >
      > `h: E365` isn't much help either I find, so I'm stumped. I have
      > exactly the same runtime files on my Vim in OS X & that's OK so
      > that probably excludes a plugin problem.
      >
      > I'll have to run `dpkg -l` & sift through that to see if I can
      > spot anything blindingly obvious but I'd've thought if that was the
      > case all the other apps that I can print from would suffer too (lpr
      > can print from the command line too).


      I solved the hardcopy problem by commenting out the `pdev` line in my
      vimrc. Why Vim decided it was no longer correct is a mystery. It
      hadn't changed for months. I can only surmise that a fractional change
      in something somewhere caused this but I haven't been able to trace it.

      Before, Vim wouldn't print without it, now it won't print with it.

      Cheers,

      Phil...

      - --
      But masters, remember that I am an ass.
      Though it be not written down,
      yet forget not that I am an ass.

      Wm. Shakespeare - Much Ado About Nothing


      -----BEGIN PGP SIGNATURE-----
      Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
      Comment: §auto-key-locate cert pka ldap hkp://keys.gnupg.net
      Comment: GPGTools - http://gpgtools.org
      Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

      iQEcBAEBAgAGBQJPd5b5AAoJEKpMeDHWT5ADxO4IAIRf2K1GfTxl/xdKbD2Sklml
      /wqZjzv0Hz2mOQzGKzyEQ438aB5nDH3TfgjW9T5bTlIkOepvkjA/B7F8++1twGr1
      GliU35r+3KzazkqkZW3comHDbwct9t9XTXyRVKkZ0z4GZLOq3m1R8xDpemiKwojn
      jAPxjuZPTaX2VQw9dUUyDDLIyO4+ilYWrrYKK93LHqMusU7zhmWrUa7e+HC41Qr/
      MOsNjrne02msXY5Kf6SMvO9LDcWSfa3O4aaJ5OdnrC4+1xgGF27A7ibGSbMjkK93
      oN5nK2Q7rcoNnujclJXHhXzkYJnLglRUd4LQL9Nbiua7g7XZQ9Pofb5/6ULC1nk=
      =eup8
      -----END PGP SIGNATURE-----

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.