Loading ...
Sorry, an error occurred while loading the content.

Bash's vi command line editing mode

Expand Messages
  • Ven Tadipatri
    Hi, This may sound like a real newbie question, but when I do the set -o vi in the bash command line shell, if I hit and v on the command line, it goes
    Message 1 of 31 , Mar 23, 2012
    View Source
    • 0 Attachment
      Hi,
         This may sound like a real newbie question, but when I do the "set -o vi" 
      in the bash command line shell, if I hit <Esc> and v on the command line,
      it goes into vi editing mode. This is kind of cool, as I can exercise
      the full editing power of vi, and when I exit the editor it runs the command.
        Unfortunately, sometimes I may have a really powerful/dangerous/unnecessary
      command that I've typed, and all I want to do is just cancel, not execute the
      command. How do I do this?
        :q! doesn't seem to work, as the command still runs. :wq , well, I don't want
      to save anything, I just want to get out of the editor and return to the plain
      old bash prompt.
         Is this possible? Of course I can always kill the terminal that I'm running
      in to avoid running the command as soon as vi exits. Or I can try to press
      ctrl+C as fast as possible.
         I was hoping for a better alternative.

      Please help.
      Thanks,
      Ven

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • LuKreme
      ... -- Sign sign, everywhere a sign -- -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you
      Message 31 of 31 , Nov 13, 2013
      View Source
      • 0 Attachment
        On Nov 11, 2013, at 3:50, LCD 47 <lcd047@...> wrote:
        > I believe the preferred way to run pathogen these days is to replace
        > all that with a single line:
        >
        > execute pathogen#infect()

        <giggle>

        --
        Sign sign, everywhere a sign

        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.