Loading ...
Sorry, an error occurred while loading the content.

Fortran indenting and preprocessor directives

Expand Messages
  • fabioaffinito
    Hi all, I m using VIM to indent a Fortran code. My problem is that VIM indent the proprecessor directives too. This causes errors in compilation. Do you know
    Message 1 of 2 , Feb 13, 2012
    • 0 Attachment
      Hi all,
      I'm using VIM to indent a Fortran code. My problem is that VIM indent the
      proprecessor directives too. This causes errors in compilation.
      Do you know how can avoid to indent the lines starting with # ?
      The following is my .vimrc file:


      set nocompatible
      set mouse=a
      set hidden
      set viminfo+=:50
      set viminfo+=/50
      set nomodeline
      set makeprg=gmake
      set textwidth=82
      inoremap () ()<Left>
      nnoremap <silent> <F8> :TlistToggle<CR>
      set number
      set cinkeys+="1#"
      set autoindent
      set smartindent
      let fortran_free_source=1
      let fortran_more_precise=1
      let fortran_do_enddo=1
      syntax enable

      Thanks in advance.

      Fabio


      --
      View this message in context: http://vim.1045645.n5.nabble.com/Fortran-indenting-and-preprocessor-directives-tp5478921p5478921.html
      Sent from the Vim - General mailing list archive at Nabble.com.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Fabio Affinito
      Hi all, I m using VIM to indent a Fortran code. My problem is that VIM indent the proprecessor directives too. This causes errors in compilation. Do you know
      Message 2 of 2 , Feb 13, 2012
      • 0 Attachment
        Hi all,
        I'm using VIM to indent a Fortran code. My problem is that VIM indent the
        proprecessor directives too. This causes errors in compilation.
        Do you know how can avoid to indent the lines starting with # ?
        The following is my .vimrc file:


        set nocompatible
        set mouse=a
        set hidden
        set viminfo+=:50
        set viminfo+=/50
        set nomodeline
        set makeprg=gmake
        set textwidth=82
        inoremap () ()<Left>
        nnoremap <silent> <F8> :TlistToggle<CR>
        set number
        set cinkeys+="1#"
        set autoindent
        set smartindent
        let fortran_free_source=1
        let fortran_more_precise=1
        let fortran_do_enddo=1
        syntax enable

        Thanks in advance.

        Fabio

        --
        Fabio Affinito, PhD

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.