Loading ...
Sorry, an error occurred while loading the content.
 

Re: Colors on mac

Expand Messages
  • Zvezdan Petkovic
    ... - Make a duplicate of the Pro terminal theme (use gear action menu). - Name it, e.g., Personal. - Change font to Menlo 14 pt (a full Unicode anti-aliased
    Message 1 of 3 , Feb 7, 2012
      On Feb 6, 2012, at 10:53 PM, Ven Tadipatri wrote:

      > I'm sure this question has been asked several times --but I'm using
      > the terminal for the Mac OS X, and I would like to have a dark
      > background with well, light colors on the foreground. But I would also
      > like the colors on the foreground to be easy to read (not dark blue on
      > dark black or light yellow on white). How do I do this?


      - Make a duplicate of the Pro terminal theme (use gear action menu).
      - Name it, e.g., Personal.
      - Change font to Menlo 14 pt (a full Unicode anti-aliased font)
      - Switch OFF "Use bold fonts"
      - Switch ON "Use bright colors for bold text"
      - Adjust any other settings and make this your default theme.
      - Make sure xterm-color is set in advanced options
      (it's on by default for Pro theme, so its duplicate should have it).


      > Do you change the LSCOLORS variable on your terminal?


      Yes. My settings are:

      CLICOLOR=1
      LSCOLORS=ExFxCxDxBxegedabagacad
      export CLICOLOR LSCOLORS


      > Do you redefine what RGB values correspond to yellow and blue are in the terminal?


      No. I only change the text color in terminal preferences to light grey (75% brightness) so that it's different from the bold text color (white). I also switch off transparency (i.e., set opacity to 100%) for sharper text.


      > Or do you add a new color to ~/.vim/colors and somehow tweak the colors to look right?


      Only for GUI (i.e., MacVim) in my ~/.vim/colors/personal.vim theme.
      Make sure to set background=dark in your vim settings or color theme.


      > These are types of files I would like to have proper colors: *.cpp,
      > *.h, .bashrc and .vimrc files.


      The "bold off/bright colors on" setting I described above works well for me with all sorts of files. I think that's all, but I might be forgetting something. Try it and I hope it helps.

      Best regards,

      Zvezdan Petkovic



      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.