Loading ...
Sorry, an error occurred while loading the content.

Re: vim-orgmode

Expand Messages
  • Jan Christoph Ebersbach
    Hi Eric, Do you know Emacs Orgmode? - I assume you don t know it. In the words of the original developers it s your life in plain text (http://
    Message 1 of 14 , Feb 2, 2012
    • 0 Attachment
      Hi Eric,

      Do you know Emacs' Orgmode? - I assume you don't know it. In the words
      of the original developers it's "your life in plain text" (http://
      orgmode.org/).

      Basically Orgmode organizes everything around headings and subheadings
      and sub*headings. To create a new heading in vim-orgmode press <S-
      CR>. One big strength of Orgmode is it's ability to hide unwanted
      content and display only the parts you really need. That's it. A more
      detailed explanation can be found here: http://www.youtube.com/watch?v=oJTwQvgfgMM

      vim-orgmode doesn't have all the features Emacs' Orgmode has but it
      has a good coverage of the basic features. The help file gives a good
      overview.

      Cheers,

      Jan Christoph


      On 2 Feb., 11:44, Eric Weir <eew...@...> wrote:
      > I installed vim-orgmode about a month or so ago. I've perused the manual and for the life of me--and here I recognize I'm displaying my technological ineptitude--I cannot figure out how to get started using it. Usually I find some way, and then I can start asking half-way intelligent questions. With vim-orgmode all I can do is confess my ignorance: Anybody out there who could help me get started?
      >
      > FWIW, I have not installed any of the recommended plugins, partly because they're recommended and partly because at this point there is no point.
      >
      > Thanks,
      > ------------------------------------------------------------------------------------------
      > Eric Weir
      >
      > "With an ounce of willingness, everything can change."
      >
      > - Kim

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Eric Weir
      ... I know about it from VimOrganizer. I ve viewed some of the VimOrganizer videos and I believe a video or videos referenced by VimOrgnizer. ... I am really
      Message 2 of 14 , Feb 2, 2012
      • 0 Attachment
        On Feb 2, 2012, at 12:38 PM, Jan Christoph Ebersbach wrote:

        > Do you know Emacs' Orgmode? - I assume you don't know it. In the words
        > of the original developers it's "your life in plain text" (http://
        > orgmode.org/).

        I know about it from VimOrganizer. I've viewed some of the VimOrganizer videos and I believe a video or videos referenced by VimOrgnizer.

        > Basically Orgmode organizes everything around headings and subheadings
        > and sub*headings. To create a new heading in vim-orgmode press <S-
        > CR>.

        I am really naive, Jan Christoph. <S-CR> is shift-CR? If so, it does nothing for me. I've tried manually creating an outline using stars but I don't seem to be able to do anything on them, either.

        Do I need anything in my .vimrc other than "filetype plugin indent on"? Do I need to be in a file with a particular extent?

        Thanks,
        ------------------------------------------------------------------------------------------
        Eric Weir
        Program and Resource Development ~ Evaluation ~ Writing
        Education ~ The Environment ~ Community Development
        1111 Clairemont Avenue J3 ~ Decatur, GA 30030
        404-636-6142 ~ eeweir@...




        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • AK
        ... I haven t used it, but it seems ext should be .org. How I found out: in ftdetect dir, there is a file org.vim. The name should correspond to the extension
        Message 3 of 14 , Feb 2, 2012
        • 0 Attachment
          On 02/02/2012 03:33 PM, Eric Weir wrote:
          >
          > On Feb 2, 2012, at 12:38 PM, Jan Christoph Ebersbach wrote:
          >
          >> Do you know Emacs' Orgmode? - I assume you don't know it. In the words
          >> of the original developers it's "your life in plain text" (http://
          >> orgmode.org/).
          >
          > I know about it from VimOrganizer. I've viewed some of the VimOrganizer videos and I believe a video or videos referenced by VimOrgnizer.
          >
          >> Basically Orgmode organizes everything around headings and subheadings
          >> and sub*headings. To create a new heading in vim-orgmode press<S-
          >> CR>.
          >
          > I am really naive, Jan Christoph.<S-CR> is shift-CR? If so, it does nothing for me. I've tried manually creating an outline using stars but I don't seem to be able to do anything on them, either.
          >
          > Do I need anything in my .vimrc other than "filetype plugin indent on"? Do I need to be in a file with a particular extent?


          I haven't used it, but it seems ext should be .org.

          How I found out: in ftdetect dir, there is a file org.vim. The name
          should correspond to the extension it applies to.

          Also: readme included is README.org.


          HTH, -ak

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Eric Weir
          ... Thanks. Gave it a superficial try in a file with that extent. I think you re write about the extent, but I m still not able to get the plugin to do
          Message 4 of 14 , Feb 3, 2012
          • 0 Attachment
            On Feb 2, 2012, at 5:31 PM, AK wrote:

            > On 02/02/2012 03:33 PM, Eric Weir wrote:
            >
            >> Do I need anything in my .vimrc other than "filetype plugin indent on"? Do I need to be in a file with a particular extent?
            >
            > I haven't used it, but it seems ext should be .org.
            >
            > How I found out: in ftdetect dir, there is a file org.vim. The name should correspond to the extension it applies to.
            >
            > Also: readme included is README.org.

            Thanks. Gave it a superficial try in a file with that extent. I think you're write about the extent, but I'm still not able to get the plugin to do anything for me. Pretty sure also the problem is me. Something simple I'm overlooking.

            ------------------------------------------------------------------------------------------
            Eric Weir
            Decatur, GA
            eeweir@...

            "A man should be in the world as though he were not in it
            so that it will be no worse because of his life."

            - Wendell Berry

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Stephan Weller
            Hi Eric, ... since I have also unsuccessfully tried to use orgmode in the past, I installed it now and I get exactly the same behaviour as you, i.e. the plugin
            Message 5 of 14 , Feb 3, 2012
            • 0 Attachment
              Hi Eric,

              > ... but I'm still not able to get the
              > plugin to do anything for me. Pretty sure also the problem is me.
              > Something simple I'm overlooking.

              since I have also unsuccessfully tried to use orgmode in the past, I installed
              it now and I get exactly the same behaviour as you, i.e. the plugin does
              nothing. However, this is only true for console vim, in gvim the mappings
              work. I don't know whether the author tests with gvim only...

              Best,

              Stephan
            • Eric Weir
              ... Thanks, Stephan. I m having the problem with MacVim. ... Eric Weir eeweir@bellsouth.net Any assurance economists pretend to with regard to cause and
              Message 6 of 14 , Feb 3, 2012
              • 0 Attachment
                On Feb 3, 2012, at 5:54 AM, Stephan Weller wrote:

                > Hi Eric,
                >
                >> ... but I'm still not able to get the
                >> plugin to do anything for me. Pretty sure also the problem is me.
                >> Something simple I'm overlooking.
                >
                > since I have also unsuccessfully tried to use orgmode in the past, I installed
                > it now and I get exactly the same behaviour as you, i.e. the plugin does
                > nothing. However, this is only true for console vim, in gvim the mappings
                > work. I don't know whether the author tests with gvim only...

                Thanks, Stephan. I'm having the problem with MacVim.

                ------------------------------------------------------------------------------------------
                Eric Weir
                eeweir@...

                "Any assurance economists pretend to with
                regard to cause and effect is merely a pose."

                - Emanuel Derman






                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Stephan Weller
                ... OK, what I found out is this (maybe someone else on the list can confirm this): - Mappings like do not work in the console version of vim. - I do
                Message 7 of 14 , Feb 3, 2012
                • 0 Attachment
                  > >> ... but I'm still not able to get the
                  > >> plugin to do anything for me. Pretty sure also the problem is me.
                  > >> Something simple I'm overlooking.
                  > >
                  > > since I have also unsuccessfully tried to use orgmode in the past,
                  > > I installed it now and I get exactly the same behaviour as you,
                  > > i.e. the plugin does nothing. However, this is only true for
                  > > console vim, in gvim the mappings work. I don't know whether the
                  > > author tests with gvim only...
                  >
                  > Thanks, Stephan. I'm having the problem with MacVim.

                  OK, what I found out is this (maybe someone else on the list can
                  confirm this):

                  - Mappings like <S-CR> do not work in the console version of vim.
                  - I do not know about Macvim, but you can test this yourself. In my
                  gvim, I can do e.g.
                  :map <S-CR> echo('Hi')<CR>
                  and every time I press Shift-CR, `Hi' is printed. In my console
                  vim this does nothing.

                  So I suspect that the orgmode plugin is working normally, but many of
                  the mappings (all that use Shift-something or Control-something) do not
                  work. In theory you could fix this yourself, the keybindings are
                  contained in the .py-Files in the .vim/ftplugin/orgmode/plugins folder
                  (maybe the folder layout differs for MacVim). However, as long as you
                  do not exactly know what the functions you are mapping are actually
                  good for, you will probably not be able to come up with a sensible
                  mapping.

                  The other course of action would be to complain to the orgmode-author
                  that his mappings are not compatible with all vim versions. Also,
                  mappings that use the shift and control key a lot are really not
                  something you should use in vim. Actually it reminds me more of this...
                  other... editor.

                  I think the author is also on this list, so maybe he reads this and
                  wants to defend himself ;)

                  Best,

                  Stephan


                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Eric Weir
                  ... Thanks, Stephan. It does nothing for me in MacVim. ... This is beyond me and at this point and at this point not something I want to put effort into
                  Message 8 of 14 , Feb 4, 2012
                  • 0 Attachment
                    On Feb 3, 2012, at 2:57 PM, Stephan Weller wrote:

                    > - Mappings like <S-CR> do not work in the console version of vim.
                    > - I do not know about Macvim, but you can test this yourself. In my
                    > gvim, I can do e.g.
                    > :map <S-CR> echo('Hi')<CR>
                    > and every time I press Shift-CR, `Hi' is printed. In my console
                    > vim this does nothing.

                    Thanks, Stephan. It does nothing for me in MacVim.

                    > So I suspect that the orgmode plugin is working normally, but many of
                    > the mappings (all that use Shift-something or Control-something) do not
                    > work. In theory you could fix this yourself, the keybindings are
                    > contained in the .py-Files in the .vim/ftplugin/orgmode/plugins folder
                    > (maybe the folder layout differs for MacVim). However, as long as you
                    > do not exactly know what the functions you are mapping are actually
                    > good for, you will probably not be able to come up with a sensible
                    > mapping.

                    This is beyond me and at this point and at this point not something I want to put effort into learning, especially since you say I probably wouldn't be successful even if I could do it.

                    Thanks,
                    ------------------------------------------------------------------------------------------
                    Eric Weir
                    Decatur, GA USA
                    eeweir@...




                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • Jan Christoph Ebersbach
                    Hi Stephan, ... It s true, can not be used in the command-line version of vim. I haven t found a good replacement for it, yet. If you need to use vim on
                    Message 9 of 14 , Feb 6, 2012
                    • 0 Attachment
                      Hi Stephan,

                      > The other course of action would be to complain to the orgmode-author
                      > that his mappings are not compatible with all vim versions. Also,
                      > mappings that use the shift and control key a lot are really not
                      > something you should use in vim. Actually it reminds me more of this...
                      > other... editor.

                      It's true, <S-CR> can not be used in the command-line version of vim.
                      I haven't found a good replacement for it, yet. If you need to use vim
                      on the command-line I recommend mapping the functionality to another
                      key.

                      Cheers,

                      Jan Christoph

                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    • Chris Jones
                      ... In X11, a simple workaround (regardless of the terminal emulator) is to map to a character that is not bound to a Vim command by ... You can
                      Message 10 of 14 , Feb 6, 2012
                      • 0 Attachment
                        On Mon, Feb 06, 2012 at 01:40:33PM EST, Jan Christoph Ebersbach wrote:
                        > Hi Stephan,
                        >
                        > > The other course of action would be to complain to the orgmode-author
                        > > that his mappings are not compatible with all vim versions. Also,
                        > > mappings that use the shift and control key a lot are really not
                        > > something you should use in vim. Actually it reminds me more of this...
                        > > other... editor.
                        >
                        > It's true, <S-CR> can not be used in the command-line version of vim.
                        > I haven't found a good replacement for it, yet. If you need to use vim
                        > on the command-line I recommend mapping the functionality to another
                        > key.

                        In X11, a simple workaround (regardless of the terminal emulator) is to
                        map <Shift+Enter> to a character that is not bound to a Vim command by
                        default, via xmodmap:

                        | $ xmodmap -e "keysym Return = Return currency"¹

                        You can check at the bash prompt that hitting <Shift+Enter> now
                        generates ‘¤’, not ‘
                        ’.

                        Then map the ‘currency’ character to <S-CR> in Vim:

                        | :map ¤ <S-CR>²

                        If your plugin's custom mapping is something like,

                        | :map <S-CR> :echo 'Hello Shift Enter'

                        hitting <Shift+Enter> should cause "Hello Shift Enter" to be displayed
                        at the bottom of your Vim screen.

                        I used the '¤' currency symbol for the sake of example, hoping both your
                        locale and font will display the above correctly.

                        Another example:

                        | $ xmodmap -e "keysym Return = Return eacute"
                        | :map é <S-CR>²
                        | :map <S-CR> :echo 'Hello Shift Enter'

                        CJ

                        ¹ or keyboard remapping options of popular desktops?

                        ² CTRL+K Cu -> ¤ .. CTRL+K 'e -> é .. etc.

                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                      • Marcin Szamotulski
                        ... That s cool. Thanks! I ll use it too. Marcin -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you
                        Message 11 of 14 , Feb 7, 2012
                        • 0 Attachment
                          On 00:02 Tue 07 Feb , Chris Jones wrote:
                          > On Mon, Feb 06, 2012 at 01:40:33PM EST, Jan Christoph Ebersbach wrote:
                          > > Hi Stephan,
                          > >
                          > > > The other course of action would be to complain to the orgmode-author
                          > > > that his mappings are not compatible with all vim versions. Also,
                          > > > mappings that use the shift and control key a lot are really not
                          > > > something you should use in vim. Actually it reminds me more of this...
                          > > > other... editor.
                          > >
                          > > It's true, <S-CR> can not be used in the command-line version of vim.
                          > > I haven't found a good replacement for it, yet. If you need to use vim
                          > > on the command-line I recommend mapping the functionality to another
                          > > key.
                          >
                          > In X11, a simple workaround (regardless of the terminal emulator) is to
                          > map <Shift+Enter> to a character that is not bound to a Vim command by
                          > default, via xmodmap:
                          >
                          > | $ xmodmap -e "keysym Return = Return currency"¹
                          >
                          > You can check at the bash prompt that hitting <Shift+Enter> now
                          > generates ‘¤’, not ‘
                          > ’.
                          >
                          > Then map the ‘currency’ character to <S-CR> in Vim:
                          >
                          > | :map ¤ <S-CR>²
                          >
                          > If your plugin's custom mapping is something like,
                          >
                          > | :map <S-CR> :echo 'Hello Shift Enter'
                          >
                          > hitting <Shift+Enter> should cause "Hello Shift Enter" to be displayed
                          > at the bottom of your Vim screen.
                          >
                          > I used the '¤' currency symbol for the sake of example, hoping both your
                          > locale and font will display the above correctly.
                          >
                          > Another example:
                          >
                          > | $ xmodmap -e "keysym Return = Return eacute"
                          > | :map é <S-CR>²
                          > | :map <S-CR> :echo 'Hello Shift Enter'
                          >
                          > CJ
                          >
                          > ¹ or keyboard remapping options of popular desktops?
                          >
                          > ² CTRL+K Cu -> ¤ .. CTRL+K 'e -> é .. etc.
                          >
                          > --
                          > You received this message from the "vim_use" maillist.
                          > Do not top-post! Type your reply below the text you are replying to.
                          > For more information, visit http://www.vim.org/maillist.php

                          That's cool. Thanks! I'll use it too.

                          Marcin

                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                        • Marcin Szamotulski
                          ... Using it I found one problem: Shift+Enter can not be used in web browsers (for example on some google (or in Facebook) pages when you want to break line).
                          Message 12 of 14 , Feb 9, 2012
                          • 0 Attachment
                            On 12:40 Tue 07 Feb , Marcin Szamotulski wrote:
                            > On 00:02 Tue 07 Feb , Chris Jones wrote:
                            > > On Mon, Feb 06, 2012 at 01:40:33PM EST, Jan Christoph Ebersbach wrote:
                            > > > Hi Stephan,
                            > > >
                            > > > > The other course of action would be to complain to the orgmode-author
                            > > > > that his mappings are not compatible with all vim versions. Also,
                            > > > > mappings that use the shift and control key a lot are really not
                            > > > > something you should use in vim. Actually it reminds me more of this...
                            > > > > other... editor.
                            > > >
                            > > > It's true, <S-CR> can not be used in the command-line version of vim.
                            > > > I haven't found a good replacement for it, yet. If you need to use vim
                            > > > on the command-line I recommend mapping the functionality to another
                            > > > key.
                            > >
                            > > In X11, a simple workaround (regardless of the terminal emulator) is to
                            > > map <Shift+Enter> to a character that is not bound to a Vim command by
                            > > default, via xmodmap:
                            > >
                            > > | $ xmodmap -e "keysym Return = Return currency"¹
                            > >
                            > > You can check at the bash prompt that hitting <Shift+Enter> now
                            > > generates ‘¤’, not ‘
                            > > ’.
                            > >
                            > > Then map the ‘currency’ character to <S-CR> in Vim:
                            > >
                            > > | :map ¤ <S-CR>²
                            > >
                            > > If your plugin's custom mapping is something like,
                            > >
                            > > | :map <S-CR> :echo 'Hello Shift Enter'
                            > >
                            > > hitting <Shift+Enter> should cause "Hello Shift Enter" to be displayed
                            > > at the bottom of your Vim screen.
                            > >
                            > > I used the '¤' currency symbol for the sake of example, hoping both your
                            > > locale and font will display the above correctly.
                            > >
                            > > Another example:
                            > >
                            > > | $ xmodmap -e "keysym Return = Return eacute"
                            > > | :map é <S-CR>²
                            > > | :map <S-CR> :echo 'Hello Shift Enter'
                            > >
                            > > CJ
                            > >
                            > > ¹ or keyboard remapping options of popular desktops?
                            > >
                            > > ² CTRL+K Cu -> ¤ .. CTRL+K 'e -> é .. etc.
                            > >
                            > > --
                            > > You received this message from the "vim_use" maillist.
                            > > Do not top-post! Type your reply below the text you are replying to.
                            > > For more information, visit http://www.vim.org/maillist.php
                            >
                            > That's cool. Thanks! I'll use it too.
                            >
                            > Marcin


                            Using it I found one problem: Shift+Enter can not be used in web browsers (for
                            example on some google (or in Facebook) pages when you want to break line).

                            Best,
                            Marcin

                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php
                          • Benjamin R. Haskell
                            ... In general, you should map the keys at the level where they re problematic. So, `xmodmap` is too heavy-handed, since mapping Shift+Enter at that level
                            Message 13 of 14 , Feb 9, 2012
                            • 0 Attachment
                              On Tue, 7 Feb 2012, Chris Jones wrote:

                              > On Mon, Feb 06, 2012 at 01:40:33PM EST, Jan Christoph Ebersbach wrote:
                              >> Hi Stephan,
                              >>
                              >>> The other course of action would be to complain to the
                              >>> orgmode-author that his mappings are not compatible with all vim
                              >>> versions. Also, mappings that use the shift and control key a lot
                              >>> are really not something you should use in vim. Actually it reminds
                              >>> me more of this... other... editor.
                              >>
                              >> It's true, <S-CR> can not be used in the command-line version of vim.
                              >> I haven't found a good replacement for it, yet. If you need to use
                              >> vim on the command-line I recommend mapping the functionality to
                              >> another key.
                              >
                              > In X11, a simple workaround (regardless of the terminal emulator) is
                              > to map <Shift+Enter> to a character that is not bound to a Vim command
                              > by default, via xmodmap:
                              >
                              > | $ xmodmap -e "keysym Return = Return currency"¹
                              >
                              > You can check at the bash prompt that hitting <Shift+Enter> now
                              > generates ‘¤’, not ‘
                              > ’.

                              In general, you should map the keys at the level where they're
                              problematic. So, `xmodmap` is too heavy-handed, since mapping
                              Shift+Enter at that level breaks Shift+Enter for things that can already
                              handle it (e.g. GVim and many other X11 programs).

                              Using XTerm's modifyOtherKeys mode (which isn't supported by most
                              programs, but allows the detection of virtually all keycodes), <Shift> +
                              <Enter> is detected as:

                              \e[27;2;13~

                              I'm pretty sure the '27' means it's an extended keycode. The '2' means
                              it's modified by shift. The 13 is newline. So, you can tell your
                              terminal emulator to send that code for <S-CR>. (The only reason to
                              pick this code is that, in the future, if other terminals adopt this
                              convention, the mapping shouldn't hurt anything.)


                              For uxterm, I would add the following to ~/.Xdefaults or ~/.Xresources:

                              UXTerm*VT100.translations: #override \n\
                              Shift <Key>Return: string(0x1b) string("[27;2;13~")

                              For rxvt-unicode, I would add the following:

                              URxvt.keysym.S-Return: \033[27;2;13~

                              (Tested both of these.)


                              Then, in Vim, do something similar to this:

                              > Then map the ‘currency’ character to <S-CR> in Vim:
                              >
                              > | :map ¤ <S-CR>²

                              :map ^[[27;2;13~ <S-CR>
                              (where the first '^[' is a literal escape character)

                              You can type the first part of this line by doing:

                              i " insert mode
                              :map " normal characters
                              <Space>
                              <C-v> " insert literally See: :help i_CTRL-V
                              <S-CR> " shift + Enter
                              <Space>
                              (rest of line is just regular characters)

                              --
                              Best,
                              Ben

                              --
                              You received this message from the "vim_use" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php
                            Your message has been successfully submitted and would be delivered to recipients shortly.