Loading ...
Sorry, an error occurred while loading the content.

compiling 7.3+ with the conceal option

Expand Messages
  • Jean-Michel Pichavant
    Hi people, This is my first mail in this list, so I would like to thank all of you in advance for the precious support. I ran into some minor issue with the
    Message 1 of 9 , Feb 1 2:00 AM
    • 0 Attachment
      Hi people,

      This is my first mail in this list, so I would like to thank all of you
      in advance for the precious support.

      I ran into some minor issue with the conceal option in vim 7.3 (I'm
      actually using the mercurial repository). Using configure before
      compiling, the conceal option was disabled. I try to enable it using the
      --enable-conceal=yes option, didn't succeed though. I tried aother
      things, some more stupid than others. In the end I succeded by hacking
      the generated mk file and adding myself the -DFEAT_CONCEAL.

      Anyone knows what I should have done right ?

      Cheers,

      Jean-Michel

      PS : shoud I use vim@... or vim_use@... ? The mailing
      list names on www.vim.org quite differ from the reply to of the mails.




      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Taylor Hedberg
      If I m not mistaken, it s just `--enable-conceal`, without the `=yes`. The opposite is `--disable-conceal`, rather than `--enable-conceal=no`.
      Message 2 of 9 , Feb 1 12:10 PM
      • 0 Attachment
        If I'm not mistaken, it's just `--enable-conceal`, without the `=yes`.
        The opposite is `--disable-conceal`, rather than `--enable-conceal=no`.
      • sc
        ... take your pick -- they both go to the same list of ppl -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the
        Message 3 of 9 , Feb 1 12:38 PM
        • 0 Attachment
          On Wed, Feb 01, 2012 at 11:00:10AM +0100, Jean-Michel Pichavant wrote:
          > PS : shoud I use vim@... or vim_use@... ? The
          > mailing list names on www.vim.org quite differ from the reply to of
          > the mails.

          take your pick -- they both go to the same list of ppl

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Jean-Michel Pichavant
          ... I tried this one as well, without success. JM -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you
          Message 4 of 9 , Feb 2 2:41 AM
          • 0 Attachment
            Taylor Hedberg wrote:
            > If I'm not mistaken, it's just `--enable-conceal`, without the `=yes`.
            > The opposite is `--disable-conceal`, rather than `--enable-conceal=no`.
            >
            I tried this one as well, without success.

            JM

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Ben Fritz
            On Feb 1, 4:00 am, Jean-Michel Pichavant ... Unless there s a good reason for you not to do so, how about just compiling with BIG or
            Message 5 of 9 , Feb 2 11:01 AM
            • 0 Attachment
              On Feb 1, 4:00 am, Jean-Michel Pichavant <jeanmic...@...>
              wrote:
              > Hi people,
              >
              > This is my first mail in this list, so I would like to thank all of you
              > in advance for the precious support.
              >
              > I ran into some minor issue with the conceal option in vim 7.3 (I'm
              > actually using the mercurial repository). Using configure before
              > compiling, the conceal option was disabled. I try to enable it using the
              > --enable-conceal=yes option, didn't succeed though. I tried aother
              > things, some more stupid than others. In the end I succeded by hacking
              > the generated mk file and adding myself the -DFEAT_CONCEAL.
              >
              > Anyone knows what I should have done right ?
              >

              Unless there's a good reason for you not to do so, how about just
              compiling with BIG or HUGE features? Then you'll get conceal along
              with all the other "big" features. :he +feature-list

              I think you do this with something like:

              make FEATURES=BIG

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Dominique Pellé
              ... I don t think that works. I build Vim (huge) as follows: $ cd vim $ hg pull $ hg up $ ./configure --with-features=huge --enable-gui=gnome2 $ make According
              Message 6 of 9 , Feb 2 12:03 PM
              • 0 Attachment
                Ben Fritz wrote:

                > On Feb 1, 4:00 am, Jean-Michel Pichavant <jeanmic...@...>
                > wrote:
                >> Hi people,
                >>
                >> This is my first mail in this list, so I would like to thank all of you
                >> in advance for the precious support.
                >>
                >> I ran into some minor issue with the conceal option in vim 7.3 (I'm
                >> actually using the mercurial repository). Using configure before
                >> compiling, the conceal option was disabled. I try to enable it using the
                >> --enable-conceal=yes option, didn't succeed though. I tried aother
                >> things, some more stupid than others. In the end I succeded by hacking
                >> the generated mk file and adding myself the -DFEAT_CONCEAL.
                >>
                >> Anyone knows what I should have done right ?
                >>
                >
                > Unless there's a good reason for you not to do so, how about just
                > compiling with BIG or HUGE features? Then you'll get conceal along
                > with all the other "big" features. :he +feature-list
                >
                > I think you do this with something like:
                >
                > make FEATURES=BIG

                I don't think that works. I build Vim (huge) as follows:

                $ cd vim
                $ hg pull
                $ hg up
                $ ./configure --with-features=huge --enable-gui=gnome2
                $ make

                According to ":help +feature-list", the +conceal feature is
                enabled in Vim big (and thus also in Vim huge).

                -- Dominique

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Jean-Michel Pichavant
                ... Thank you guys. JM -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For more
                Message 7 of 9 , Feb 2 1:42 PM
                • 0 Attachment
                  Dominique Pellé wrote:
                  > Ben Fritz wrote:
                  >
                  >
                  >> On Feb 1, 4:00 am, Jean-Michel Pichavant <jeanmic...@...>
                  >> wrote:
                  >>
                  >>> Hi people,
                  >>>
                  >>> This is my first mail in this list, so I would like to thank all of you
                  >>> in advance for the precious support.
                  >>>
                  >>> I ran into some minor issue with the conceal option in vim 7.3 (I'm
                  >>> actually using the mercurial repository). Using configure before
                  >>> compiling, the conceal option was disabled. I try to enable it using the
                  >>> --enable-conceal=yes option, didn't succeed though. I tried aother
                  >>> things, some more stupid than others. In the end I succeded by hacking
                  >>> the generated mk file and adding myself the -DFEAT_CONCEAL.
                  >>>
                  >>> Anyone knows what I should have done right ?
                  >>>
                  >>>
                  >> Unless there's a good reason for you not to do so, how about just
                  >> compiling with BIG or HUGE features? Then you'll get conceal along
                  >> with all the other "big" features. :he +feature-list
                  >>
                  >> I think you do this with something like:
                  >>
                  >> make FEATURES=BIG
                  >>
                  >
                  > I don't think that works. I build Vim (huge) as follows:
                  >
                  > $ cd vim
                  > $ hg pull
                  > $ hg up
                  > $ ./configure --with-features=huge --enable-gui=gnome2
                  > $ make
                  >
                  > According to ":help +feature-list", the +conceal feature is
                  > enabled in Vim big (and thus also in Vim huge).
                  >
                  > -- Dominique
                  >
                  >
                  Thank you guys.

                  JM

                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Phil Dobbin
                  ... Hash: SHA1 On 02/02/2012 20:03, Dominique Pellé wrote: [...] ... Hi, Dominique. On which version of Linux do you build Vim like so (I m speculating as to
                  Message 8 of 9 , Feb 2 2:23 PM
                  • 0 Attachment
                    -----BEGIN PGP SIGNED MESSAGE-----
                    Hash: SHA1

                    On 02/02/2012 20:03, Dominique Pellé wrote:

                    [...]

                    > I don't think that works. I build Vim (huge) as follows:
                    >
                    > $ cd vim
                    > $ hg pull
                    > $ hg up
                    > $ ./configure --with-features=huge --enable-gui=gnome2
                    > $ make
                    >
                    > According to ":help +feature-list", the +conceal feature is
                    > enabled in Vim big (and thus also in Vim huge).


                    Hi, Dominique.

                    On which version of Linux do you build Vim like so (I'm speculating as
                    to it being Linux)?

                    Cheers,

                    Phil...

                    - --
                    But masters, remember that I am an ass.
                    Though it be not written down,
                    yet forget not that I am an ass.

                    Wm. Shakespeare - Much Ado About Nothing


                    -----BEGIN PGP SIGNATURE-----
                    Version: GnuPG/MacGPG2 v2.0.17 (Darwin)
                    Comment: Ā§auto-key-locate cert pka ldap hkp://keys.gnupg.net
                    Comment: GPGTools - http://gpgtools.org
                    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

                    iQEcBAEBAgAGBQJPKwzJAAoJEKpMeDHWT5ADoAkH/j1x6XCpNsmoadS5AjzxzvtS
                    KyMZvjADsMmT+xOEPkvrtqI+2AbuUXtRXtJCPiXW0fNlYXBm0TEhWH8ZTcffvgv/
                    PqgknyWgCeG4k3La+R0w6Xlp8aK7p2pq+QgSwb2SPDUG5Dfo3IUy9JVGoMq6t7mQ
                    rTgvsb+N25JwgRb27rUAqt596AXW/QSw4Qxm4Uh5KyEenZbDsGaox8QoHWbx/+Z+
                    Q0wKC9aQmQsmjKVOuQXx5F9y7hVeHZfu/fgFrC6+U4alWz9xVv82Qkv8Outbp9+P
                    4+4E54zUYsvfwfoBjw2skQYeakYWQ84VoUFQS1CopsC+tGVaREZl3ba54stGXHM=
                    =riQ+
                    -----END PGP SIGNATURE-----

                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • Ben Fritz
                    ... Works for me on Windows in MinGW. ... But my Ubuntu machine won t boot at the moment so I can t log in there to look at my notes for building on Linux. ...
                    Message 9 of 9 , Feb 2 5:19 PM
                    • 0 Attachment
                      On Feb 2, 2:03 pm, Dominique Pellé <dominique.pe...@...> wrote:
                      >
                      > > I think you do this with something like:
                      >
                      > > make FEATURES=BIG
                      >
                      > I don't think that works.

                      Works for me on Windows in MinGW.

                      > I build Vim (huge) as follows:
                      >
                      > $ cd vim
                      > $ hg pull
                      > $ hg up
                      > $ ./configure --with-features=huge --enable-gui=gnome2
                      > $ make
                      >

                      But my Ubuntu machine won't boot at the moment so I can't log in there
                      to look at my notes for building on Linux.

                      > According to ":help +feature-list", the +conceal feature is
                      > enabled in Vim big (and thus also in Vim huge).
                      >

                      Yes, I build with huge myself...but I know big also contains it, hence
                      my suggestion.

                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    Your message has been successfully submitted and would be delivered to recipients shortly.