Loading ...
Sorry, an error occurred while loading the content.

RE: The Super Search and Vim Scripts for Python

Expand Messages
  • John Beckett
    ... As already mentioned, one of the scripts active for files of type python is changing your iskeyword setting to include a dot. When editing a Python
    Message 1 of 3 , Jan 31, 2012
    • 0 Attachment
      gberar wrote:
      > I installed some Python specific Vim scripts and found that,
      > when editing python files, the "Super Search" does not behave
      > as it does normally.
      >
      > If I have the cursor over "foo" in the string "foo.bar" and
      > type the character *, vim will search for the string "foo" as
      > long the file is not a python file type.

      As already mentioned, one of the scripts active for files of
      type "python" is changing your 'iskeyword' setting to include a
      dot.

      When editing a Python file, enter the following to determine
      which script is responsible:

      :verbose set iskeyword?

      With the default Python stuff, "." is not part of iskeyword, and
      pressing * does not include any dot.

      John

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.