Loading ...
Sorry, an error occurred while loading the content.
 

getting rid of the underline in folding

Expand Messages
  • josh
    I don t like the dashes and underline that appear on folding. I managed to get rid of the dashes: set fillchars= fold: Now I try to get rid of the underline.
    Message 1 of 3 , Dec 31, 2011
      I don't like the dashes and underline that appear on folding.

      I managed to get rid of the dashes:
      set fillchars="fold: "

      Now I try to get rid of the underline.
      any help would be appreciated!

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Gary Johnson
      ... I don t see underlines on my folds, so I m not sure, but that s probably set by the Folded highlight group. You can see what it s set to with ... See ...
      Message 2 of 3 , Dec 31, 2011
        On 2011-12-31, josh wrote:
        > I don't like the dashes and underline that appear on folding.
        >
        > I managed to get rid of the dashes:
        > set fillchars="fold: "
        >
        > Now I try to get rid of the underline.
        > any help would be appreciated!

        I don't see underlines on my folds, so I'm not sure, but that's
        probably set by the Folded highlight group. You can see what it's
        set to with

        :hi Folded

        The following will probably turn off the underlining:

        :hi Folded term=NONE cterm=NONE gui=NONE

        See

        :help usr_06.txt
        :help :hi

        Regards,
        Gary

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • josh
        Thank you. that what I ended up doing: hi Folded term=NONE cterm=NONE gui=NONE ctermbg=None set foldtext= the second line got rid of the text, so now i see:
        Message 3 of 3 , Dec 31, 2011
          Thank you. that what I ended up doing:
          hi Folded term=NONE cterm=NONE gui=NONE ctermbg=None
          set foldtext=""

          the second line got rid of the text, so now i see:
          +-- 2 lines folded



          On Dec 31, 9:21 am, Gary Johnson <garyj...@...> wrote:
          > On 2011-12-31, josh wrote:
          > > I don't like the dashes and underline that appear on folding.
          >
          > > I managed to get rid of the dashes:
          > > set fillchars="fold: "
          >
          > > Now I try to get rid of the underline.
          > > any help would be appreciated!
          >
          > I don't see underlines on my folds, so I'm not sure, but that's
          > probably set by the Folded highlight group.  You can see what it's
          > set to with
          >
          >     :hi Folded
          >
          > The following will probably turn off the underlining:
          >
          >     :hi Folded term=NONE cterm=NONE gui=NONE
          >
          > See
          >
          >     :help usr_06.txt
          >     :help :hi
          >
          > Regards,
          > Gary

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.