Loading ...
Sorry, an error occurred while loading the content.

Delay on opening new file

Expand Messages
  • Alireza Haghdoost
    Hi I have a problem when I want to open a file with vim, it takes several minutes to open. For example : $ cat cost.txt Hello $vim cost.txt .... It takes about
    Message 1 of 7 , Dec 1, 2011
    • 0 Attachment
      Hi

      I have a problem when I want to open a file with vim, it takes several
      minutes to open. For example :

      $ cat cost.txt
      Hello
      $vim cost.txt
      ....
      It takes about 5min to open , I don't know what it is waiting for
      because cpu usage is 0%. Moreover, vim open perfectly without delay
      when I do not mention cost.txt in the command line.

      Do you know what is the problem ?

      Alireza

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Alireza Haghdoost
      More updates about problem: vim command without mentioning any file in command line takes that much time to open. However, by pressing Ctrl+c it opens
      Message 2 of 7 , Dec 1, 2011
      • 0 Attachment
        More updates about problem: vim command without mentioning any file in
        command line takes that much time to open. However, by pressing Ctrl+c
        it opens immediately...


        On Thu, Dec 1, 2011 at 10:09, Alireza Haghdoost <haghdoost@...> wrote:
        > Hi
        >
        > I have a problem when I want to open a file with vim, it takes several
        > minutes to open. For example :
        >
        > $ cat cost.txt
        > Hello
        > $vim cost.txt
        > ....
        > It takes about 5min to open , I don't know what it is waiting for
        > because cpu usage is 0%. Moreover, vim open perfectly without delay
        > when I do not mention cost.txt in the command line.
        >
        > Do you know what is the problem ?
        >
        > Alireza

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Tim Chase
        ... My first guess is that there s something massive stashed in your viminfo file. You can try renaming your viminfo so that Vim doesn t find it. If that
        Message 3 of 7 , Dec 1, 2011
        • 0 Attachment
          On 12/01/11 10:15, Alireza Haghdoost wrote:
          > More updates about problem: vim command without mentioning any file in
          > command line takes that much time to open. However, by pressing Ctrl+c
          > it opens immediately...

          My first guess is that there's something massive stashed in your
          viminfo file. You can try renaming your viminfo so that Vim
          doesn't find it. If that speeds things up, then you can try
          hand-editing the viminfo so that the big stuff is removed.

          Alternatively, you might be loading some script that is causing
          trouble. Including the output of

          :scriptnames

          might help track down a rogue plugin.

          Other possibilities include Vim attempting to connect to X which
          you can try by launching Vim with the -X command parameter.

          Lastly, if you're pulling down some file (content, script, syntax
          file, etc) over a slow (low-bandwidth or high-latency) network
          link, it might stall out indefinitely.

          -tim



          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Alireza Haghdoost
          Thanks Tim Problem solved by modifying viminfo file Alireza ... -- You received this message from the vim_use maillist. Do not top-post! Type your reply
          Message 4 of 7 , Dec 1, 2011
          • 0 Attachment
            Thanks Tim

            Problem solved by modifying viminfo file

            Alireza

            On Thu, Dec 1, 2011 at 10:44, Tim Chase <vim@...> wrote:
            > On 12/01/11 10:15, Alireza Haghdoost wrote:
            >>
            >> More updates about problem: vim command without mentioning any file in
            >> command line takes that much time to open. However, by pressing Ctrl+c
            >> it opens immediately...
            >
            >
            > My first guess is that there's something massive stashed in your viminfo
            > file.  You can try renaming your viminfo so that Vim doesn't find it.  If
            > that speeds things up, then you can try hand-editing the viminfo so that the
            > big stuff is removed.
            >
            > Alternatively, you might be loading some script that is causing trouble.
            >  Including the output of
            >
            >  :scriptnames
            >
            > might help track down a rogue plugin.
            >
            > Other possibilities include Vim attempting to connect to X which you can try
            > by launching Vim with the -X command parameter.
            >
            > Lastly, if you're pulling down some file (content, script, syntax file, etc)
            > over a slow (low-bandwidth or high-latency) network link, it might stall out
            > indefinitely.
            >
            > -tim
            >
            >
            >

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Alireza Haghdoost
            Hi I have the same problem again. vim opens with huge delay. I need to push Crtl+c after vim command to force execution. I don t know why it has such a delay.
            Message 5 of 7 , Jan 4, 2012
            • 0 Attachment
              Hi

              I have the same problem again. vim opens with huge delay. I need to push Crtl+c after vim command to force execution. I don't know why it has such a delay. Here is the content of my :scriptnames

               1: /usr/share/vim/vimrc
                2: /usr/share/vim/vim71/debian.vim
                3: /usr/share/vim/vim71/filetype.vim
                4: /usr/share/vim/vim71/ftplugin.vim
                5: /usr/share/vim/vim71/plugin/getscriptPlugin.vim
                6: /usr/share/vim/vim71/plugin/gzip.vim
                7: /usr/share/vim/vim71/plugin/matchparen.vim
                8: /usr/share/vim/vim71/plugin/netrwPlugin.vim
                9: /usr/share/vim/vim71/plugin/rrhelper.vim
               10: /usr/share/vim/vim71/plugin/spellfile.vim
               11: /usr/share/vim/vim71/plugin/tarPlugin.vim
               12: /usr/share/vim/vim71/plugin/tohtml.vim
               13: /usr/share/vim/vim71/plugin/vimballPlugin.vim
               14: /usr/share/vim/vim71/plugin/zipPlugin.vim

              I have removed .viminfo file. More over I am using a local network to connect the server and run vim. I am not using X or slow link. Do you have any idea ?



              On Thu, Dec 1, 2011 at 10:44, Tim Chase <vim@...> wrote:
              On 12/01/11 10:15, Alireza Haghdoost wrote:
              More updates about problem: vim command without mentioning any file in
              command line takes that much time to open. However, by pressing Ctrl+c
              it opens immediately...

              My first guess is that there's something massive stashed in your viminfo file.  You can try renaming your viminfo so that Vim doesn't find it.  If that speeds things up, then you can try hand-editing the viminfo so that the big stuff is removed.

              Alternatively, you might be loading some script that is causing trouble.  Including the output of

               :scriptnames

              might help track down a rogue plugin.

              Other possibilities include Vim attempting to connect to X which you can try by launching Vim with the -X command parameter.

              Lastly, if you're pulling down some file (content, script, syntax file, etc) over a slow (low-bandwidth or high-latency) network link, it might stall out indefinitely.

              -tim




              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Charles Campbell
              ... Several thoughts... * try vim -u NONE somenewfile Is this faster? * try vim -X somenewfile Is this faster? * I assume you ve removed .viminfo * may we
              Message 6 of 7 , Jan 4, 2012
              • 0 Attachment
                Alireza Haghdoost wrote:
                > Hi
                >
                > I have the same problem again. vim opens with huge delay. I need to
                > push Crtl+c after vim command to force execution. I don't know why it
                > has such a delay. Here is the content of my :scriptnames
                >
                > 1: /usr/share/vim/vimrc
                > 2: /usr/share/vim/vim71/debian.vim
                > 3: /usr/share/vim/vim71/filetype.vim
                > 4: /usr/share/vim/vim71/ftplugin.vim
                > 5: /usr/share/vim/vim71/plugin/getscriptPlugin.vim
                > 6: /usr/share/vim/vim71/plugin/gzip.vim
                > 7: /usr/share/vim/vim71/plugin/matchparen.vim
                > 8: /usr/share/vim/vim71/plugin/netrwPlugin.vim
                > 9: /usr/share/vim/vim71/plugin/rrhelper.vim
                > 10: /usr/share/vim/vim71/plugin/spellfile.vim
                > 11: /usr/share/vim/vim71/plugin/tarPlugin.vim
                > 12: /usr/share/vim/vim71/plugin/tohtml.vim
                > 13: /usr/share/vim/vim71/plugin/vimballPlugin.vim
                > 14: /usr/share/vim/vim71/plugin/zipPlugin.vim
                >
                > I have removed .viminfo file. More over I am using a local network to
                > connect the server and run vim. I am not using X or slow link. Do you
                > have any idea ?
                >
                >
                >
                > On Thu, Dec 1, 2011 at 10:44, Tim Chase <vim@...
                > <mailto:vim@...>> wrote:
                >
                > On 12/01/11 10:15, Alireza Haghdoost wrote:
                >
                > More updates about problem: vim command without mentioning any
                > file in
                > command line takes that much time to open. However, by
                > pressing Ctrl+c
                > it opens immediately...
                >
                >
                > My first guess is that there's something massive stashed in your
                > viminfo file. You can try renaming your viminfo so that Vim
                > doesn't find it. If that speeds things up, then you can try
                > hand-editing the viminfo so that the big stuff is removed.
                >
                > Alternatively, you might be loading some script that is causing
                > trouble. Including the output of
                >
                > :scriptnames
                >
                > might help track down a rogue plugin.
                >
                > Other possibilities include Vim attempting to connect to X which
                > you can try by launching Vim with the -X command parameter.
                >
                > Lastly, if you're pulling down some file (content, script, syntax
                > file, etc) over a slow (low-bandwidth or high-latency) network
                > link, it might stall out indefinitely.
                >
                Several thoughts...

                * try vim -u NONE somenewfile
                Is this faster?

                * try vim -X somenewfile
                Is this faster?

                * I assume you've removed .viminfo

                * may we see your .vimrc (if its short)? what o/s?

                * what is your backup directory? :echo &bdir (you may or may not have
                one). If you do have one, is it on a "slow link"?

                Regards,
                Chip Campbell

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Alireza Haghdoost
                Thanks Charles I try vim -X and it runs smoothly. I think vim can not connect to my X server in a remote session. Thanks again for your prompt response.
                Message 7 of 7 , Jan 4, 2012
                • 0 Attachment
                  Thanks Charles 

                  I try vim -X and it runs smoothly. I think vim can not connect to my X server in a remote session. Thanks again for your prompt response. 

                  Alireza

                  On Wed, Jan 4, 2012 at 11:36, Charles Campbell <Charles.E.Campbell@...> wrote:

                  Several thoughts...

                  * try  vim -u NONE somenewfile
                    Is this faster?

                  * try  vim -X somenewfile
                    Is this faster?

                  * I assume you've removed .viminfo

                  * may we see your .vimrc (if its short)?   what o/s?

                  * what is your backup directory?  :echo &bdir   (you may or may not have one).  If you do have one, is it on a "slow link"?

                  Regards,
                  Chip Campbell

                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php

                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                Your message has been successfully submitted and would be delivered to recipients shortly.