Loading ...
Sorry, an error occurred while loading the content.

Re: Installing vim 7.3 as a user - can't copy to/from system clipboard

Expand Messages
  • ACR
    Hi All, It started working once I got the latest patch for vim 7.3. Thanks a lot to Tony for suggesting this. Regards, Anith. ... -- You received this message
    Message 1 of 5 , Nov 30, 2011
    • 0 Attachment
      Hi All,

      It started working once I got the latest patch for vim 7.3.

      Thanks a lot to Tony for suggesting this.

      Regards,
      Anith.

      On Nov 30, 8:21 pm, ACR <anith.r...@...> wrote:
      > Hi Thanks for the responses.  A few more points based on the replies.
      >
      > 1)  The server already contains vim 7.2, which works fine.  (i.e if I
      > invoke vim 7.2 which is there in the default path, I am able to cut/
      > paste from/to the clipboard).  The issue occurs when I invoked the
      > gvim binary I created on my own (because I wanted vim 7.3, and the
      > administrator has not yet installed it in the common directory) in my
      > local "bin" directory.
      > 2)  I have vim created in my ~<user>/.local/home/<user>/.local/bin,
      > but moved it to ~<user>/.local/bin manually (along with the share
      > directory).  I hope this is fine.  I always invoke the newly created
      > gvim binary by giving the full path.
      > 3)  I am using a linux "konsole"
      > 4) I had already tried out the Edit-copy-paste and the clipboard
      > registers "*" and "+".  But they didn't work :(
      > 5) I can re-compile and re-generate the vim binaries, if any of the
      > options I used is incorrect.
      > 6) Has this got anything to do with me not having administrator
      > permissions? (I hope not)
      >
      > Regards,
      > Anith.
      >
      > On Nov 30, 5:19 pm, Tony Mechelynck <antoine.mechely...@...>
      > wrote:
      >
      > > On 30/11/11 11:48, ACR wrote:
      >
      > > > Hi,
      >
      > > >    I am trying to install vim 7.3 locally on a red hat machine in which
      > > > I have a user account.  I downloaded the source code from vim.org and
      > > > ran the following commands.
      >
      > > > ./configure --prefix=/home/<username>/.local --enable-gui --with-x --
      > > > with-features=normal
      > > >    make install DESTDIR=/home/<username>/.local
      >
      > > >    Now, I am unable to copy the data to/from the system clipboard.  I
      > > > googled to find out that that this happens when vim is compiled
      > > > without X/gui support.  Hence, I tried the options (given above) while
      > > > compiling, again with the same results.  Can someone help me out?
      >
      > > >    Given below are the version details  (obtained by entering :version
      > > > from vim)
      > > > --------------------------------------------------------------------------------------------------------------------------------
      > > > Normal version with X11-Motif GUI.  Features included (+) or not (-):
      > > > -arabic +autocmd +balloon_eval +browse +builtin_terms +byte_offset
      > > > +cindent
      > > > +clientserver +clipboard +cmdline_compl +cmdline_hist +cmdline_info
      >
      > > ----------------^^^^^^^^^^> +comments
      >
      > > [...]
      >
      > > This Vim version should be able to use the system clipboard, as long as
      > > it is running in a terminal with an X connection. So:
      >
      > > - running Vim in the linux console (Ctrl-Alt-F1 to Ctrl-Alt-F6) or
      > > invoking it with -X on the command-line, prevents communication with the
      > > clipboard.
      >
      > > - In gvim or in Vim-in-xterm you should be able to use the + register
      > > which is what most programs use with Edit → Paste, Edit → Copy, Edit →
      > > Cut, or the * register which is what most programs use for a selection
      > > or for MiddleMouse pasting. Unlike what happens on Windows, on X11
      > > systems these two registers are distinct.
      >
      > > - In gvim, you can also use Edit → Paste, Edit → Copy, Edit → Cut
      >
      > > - The Visual area is normally not automatically copied into "* -- if you
      > > want it (which I don't recommend) you can use
      >
      > >         :set clipboard+=autoselect guioptions+=a
      >
      > > - In gvim, or in terminals where Vim can access both the mouse and the
      > > clipboard, you can use <MiddleMouse> to paste the * register.
      >
      > > - About downloading the source code: you are aware, aren't you, that as
      > > of this writing there have been 356 bugfixes since Vim 7.3 was released?
      > > Seehttp://vim.wikia.com/wiki/Getting_the_Vim_source_with_Mercurial
      > > about how to get the latest sources.
      >
      > > Best regards,
      > > Tony.
      > > --
      > > "Gosh that takes me back ... or forward.  That's the trouble with time
      > > travel, you never can tell."
      > >                 -- Dr. Who

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.