Loading ...
Sorry, an error occurred while loading the content.

Re: How to enable mouse wheel scrolling in non-gui vim.exe?

Expand Messages
  • Toddintr
    I meant to say How can I enable mouse scroll WHEEL in non-gui vim.exe? -- sorry. Todd -- You received this message from the vim_use maillist. Do not
    Message 1 of 6 , Nov 1, 2011
    • 0 Attachment
      I meant to say "How can I enable mouse scroll WHEEL in non-gui
      vim.exe?" -- sorry.

      Todd

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... AFAICT it depends on the terminal; and I have freed myself from Windows some time ago (months? years? Years I think) so I cannot experiment on a Windows
      Message 2 of 6 , Nov 1, 2011
      • 0 Attachment
        On 02/11/11 05:23, Toddintr wrote:
        > I meant to say "How can I enable mouse scroll WHEEL in non-gui
        > vim.exe?" -- sorry.
        >
        > Todd
        >

        AFAICT it depends on the terminal; and I have freed myself from Windows
        some time ago (months? years? Years I think) so I cannot experiment on a
        Windows console.

        Here on Linux, every different terminal emulator reacts differently to
        mouse actions: some don't pass them to Vim at all, some can move the
        cursor and open a "Select" area by dragging but won't react to the mouse
        wheel, some will move the cursor up and down when I roll the wheel but
        won't react to mouse clicks... Apparently I can't get full mouse
        performance in console Vim but only in gvim.

        Maybe you can configure your cmd.exe console, maybe by clicking (left or
        right, I'm not sure) the top left icon of the terminal window when Vim
        is running in it?


        Best regards,
        Tony.
        --
        There was a bluestocking in Florence
        Wrote anti-sex pamphlets in torrents,
        Till a Spanish grandee,
        Got her off with his knee,
        And she burned all her works with abhorrence.

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Toddintr
        No takers for this question? Not even Sven? ;-) ... -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text
        Message 3 of 6 , Nov 3, 2011
        • 0 Attachment
          No takers for this question? Not even Sven? ;-)

          On Nov 2, 11:23 am, Toddintr <amsabu...@...> wrote:
          > I meant to say "How can I enable mouse scroll WHEEL in non-gui
          > vim.exe?" -- sorry.
          >
          > Todd

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Paul
          ... Have you tried :set mouse=a ? See :help mouse -- . -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the
          Message 4 of 6 , Nov 4, 2011
          • 0 Attachment
            On Thursday, 03 November, 2011 at 11:26:04 GMT, Toddintr wrote:
            >No takers for this question? Not even Sven? ;-)
            >
            >On Nov 2, 11:23?am, Toddintr <amsabu...@...> wrote:
            >> I meant to say "How can I enable mouse scroll WHEEL in non-gui
            >> vim.exe?" -- sorry.

            Have you tried ':set mouse=a'? See :help mouse

            --

            .

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Toddintr
            The mouse is already set to a . ... -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are
            Message 5 of 6 , Nov 5, 2011
            • 0 Attachment
              The "mouse" is already set to "a".

              On Nov 5, 1:56 am, Paul <google01...@...> wrote:
              > On Thursday, 03 November, 2011 at 11:26:04 GMT, Toddintr wrote:
              > >No takers for this question?  Not even Sven? ;-)
              >
              > >On Nov 2, 11:23?am, Toddintr <amsabu...@...> wrote:
              > >> I meant to say "How can I enable mouse scroll WHEEL in non-gui
              > >> vim.exe?" -- sorry.
              >
              > Have you tried ':set mouse=a'? See :help mouse
              >
              > --
              >
              > .

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            Your message has been successfully submitted and would be delivered to recipients shortly.