Loading ...
Sorry, an error occurred while loading the content.

Netrw ErrorMsg is undefined

Expand Messages
  • François Ingelrest
    Hi all, After updating my netrw plugin (v143), I now get this error the first time I do :Explore in a Vim session: Error detected while processing
    Message 1 of 3 , Oct 1, 2011
    • 0 Attachment
      Hi all,

      After updating my netrw plugin (v143), I now get this error the first
      time I do :Explore in a Vim session:

      Error detected while processing /home/ingelres/.vim/autoload/netrw.vim:
      line 164:
      E117: Unknown function: netrw#ErrorMsg

      This did not happen with v141d, but I think this happened as well with
      v142. Am I the only one getting this?

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Charles E Campbell Jr
      ... The latest version of netrw is v143, and netrw#ErrorMsg is at line#8056 in autoload/netrw.vim. I can t duplicate the problem; so please look into :help
      Message 2 of 3 , Oct 1, 2011
      • 0 Attachment
        François Ingelrest wrote:
        > Hi all,
        >
        > After updating my netrw plugin (v143), I now get this error the first
        > time I do :Explore in a Vim session:
        >
        > Error detected while processing /home/ingelres/.vim/autoload/netrw.vim:
        > line 164:
        > E117: Unknown function: netrw#ErrorMsg
        >
        > This did not happen with v141d, but I think this happened as well with
        > v142. Am I the only one getting this?
        >
        >
        The latest version of netrw is v143, and netrw#ErrorMsg is at line#8056
        in autoload/netrw.vim. I can't duplicate the problem; so please look
        into :help netrw-debug for a way to proceed.

        Regards,
        Chip Campbell

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • François Ingelrest
        ... After a bit of debugging, I found that this is caused by the following line in my .vimrc: let g:netrw_cursorline=1 If I comment this line, the error
        Message 3 of 3 , Oct 1, 2011
        • 0 Attachment
          On Sat, Oct 1, 2011 at 17:43, Charles E Campbell Jr wrote:
          > The latest version of netrw is v143, and netrw#ErrorMsg is at line#8056 in
          > autoload/netrw.vim.  I can't duplicate the problem; so please look into
          >  :help netrw-debug  for a way to proceed.

          After a bit of debugging, I found that this is caused by the following
          line in my .vimrc:

          let g:netrw_cursorline=1

          If I comment this line, the error disappears.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.