Loading ...
Sorry, an error occurred while loading the content.

Vim as default email (thunderbird) editor

Expand Messages
  • Fernando Basso
    I really want to find a way to use vim as my default email editor. I have been using thunderbird for a reasonable amount of time now, and I stumbled through
    Message 1 of 21 , Sep 28 4:18 AM
    • 0 Attachment
      I really want to find a way to use vim as my default email editor. I
      have been using thunderbird for a reasonable amount of time now, and I
      stumbled through this "external editor" thunderbird plubin. However,
      it seems not to be working with recent versions of thunderbird.

      So, I was pondering, "well, many vim users certainly use vim to write
      emails." If so, do you have any tips regarding this subject. What I
      have done so far is to write the email in vim, and then paste the
      message back into the email client. There must be a better, clever, or
      nicer way of doing this.

      I simply cannot stand any other editor anymore. There is no life after
      vim.

      Any thoughts and ideas are welcome.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Quincy Bowers
      I am using External Editor with Thunderbird 6.02 and everything is working just fine. I would check to see if you have the latest updates for the plugin. --
      Message 2 of 21 , Sep 28 5:45 AM
      • 0 Attachment
        I am using External Editor with Thunderbird 6.02 and everything is working just fine.  I would check to see if you have the latest updates for the plugin.

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Fernando Basso
        ... I got the plugin from here: http://globs.org/download.php?lng=en I never tried this plugin until today. Incidentally, my first try with this plugin was
        Message 3 of 21 , Sep 28 6:42 AM
        • 0 Attachment
          On Sep 28, 9:45 am, Quincy Bowers <qui...@...> wrote:
          > I am using External Editor with Thunderbird 6.02 and everything is working
          > just fine.  I would check to see if you have the latest updates for the
          > plugin.

          I got the plugin from here:

          http://globs.org/download.php?lng=en

          I never tried this plugin until today. Incidentally, my first try
          with this plugin was together with tunderbird 7 upgrade in
          arch linux.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Quincy Bowers
          Make sure you setup External Editor to call gvim --nofork or it won t work properly. Other than that I can t imagine what would be wrong. Quincy ... -- You
          Message 4 of 21 , Sep 28 6:58 AM
          • 0 Attachment
            Make sure you setup External Editor to call 'gvim --nofork' or it won't work properly.  Other than that I can't imagine what would be wrong.

            Quincy

            On Wed, Sep 28, 2011 at 07:42, Fernando Basso <fernandobasso.br@...> wrote:


            On Sep 28, 9:45 am, Quincy Bowers <qui...@...> wrote:
            > I am using External Editor with Thunderbird 6.02 and everything is working
            > just fine.  I would check to see if you have the latest updates for the
            > plugin.

            I got the plugin from here:

                http://globs.org/download.php?lng=en

            I never tried this plugin until today. Incidentally, my first try
            with this plugin was together with tunderbird 7 upgrade in
            arch linux.

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • David Ohlemacher
            Have you seen these? - http://dactyl.sourceforge.net/teledactyl - http://vimperator.org/muttator -- You received this message from the vim_use maillist. Do
            Message 5 of 21 , Sep 28 7:32 AM
            • 0 Attachment
              Have you seen these?
              - http://dactyl.sourceforge.net/teledactyl
              - http://vimperator.org/muttator

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Quincy Bowers
              I have not used either of those before. ... -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are
              Message 6 of 21 , Sep 28 8:33 AM
              • 0 Attachment
                I have not used either of those before.


                On Wed, Sep 28, 2011 at 08:32, David Ohlemacher <dohlemacher@...> wrote:

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Fernando Basso
                ... It still doesn t work. Even using gvim --nofork. -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text
                Message 7 of 21 , Sep 28 8:50 AM
                • 0 Attachment
                  On Sep 28, 10:58 am, Quincy Bowers <qui...@...> wrote:
                  > Make sure you setup External Editor to call 'gvim --nofork' or it won't work
                  > properly.  Other than that I can't imagine what would be wrong.

                  It still doesn't work. Even using gvim --nofork.

                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Fernando Basso
                  ... They seem fine, although I d prefer to edit in real vim. Anyway, thanks for the suggestion. I was aware of vimperator, but not the other. -- You received
                  Message 8 of 21 , Sep 28 9:11 AM
                  • 0 Attachment
                    On Sep 28, 11:32 am, David Ohlemacher <dohlemac...@...> wrote:
                    > Have you seen these?
                    > -http://dactyl.sourceforge.net/teledactyl
                    > -http://vimperator.org/muttator

                    They seem fine, although I'd prefer to edit in 'real' vim. Anyway,
                    thanks
                    for the suggestion. I was aware of vimperator, but not the other.

                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • Marcin Szamotulski
                    ... It should be noted that it is fairly easy to configure mutt to use vim as an external editor, this is a line of my muttrc file: set editor= vim +set
                    Message 9 of 21 , Sep 28 9:18 AM
                    • 0 Attachment
                      On 04:18 Wed 28 Sep , Fernando Basso wrote:
                      > I really want to find a way to use vim as my default email editor. I
                      > have been using thunderbird for a reasonable amount of time now, and I
                      > stumbled through this "external editor" thunderbird plubin. However,
                      > it seems not to be working with recent versions of thunderbird.
                      >
                      > So, I was pondering, "well, many vim users certainly use vim to write
                      > emails." If so, do you have any tips regarding this subject. What I
                      > have done so far is to write the email in vim, and then paste the
                      > message back into the email client. There must be a better, clever, or
                      > nicer way of doing this.
                      >
                      > I simply cannot stand any other editor anymore. There is no life after
                      > vim.
                      >
                      > Any thoughts and ideas are welcome.
                      >
                      > --
                      > You received this message from the "vim_use" maillist.
                      > Do not top-post! Type your reply below the text you are replying to.
                      > For more information, visit http://www.vim.org/maillist.php

                      It should be noted that it is fairly easy to configure mutt to use vim as an
                      external editor, this is a line of my muttrc file:
                      set editor='vim +set\ spell\ spelllang=pl,pt,en_gb'

                      Best,
                      Marcin

                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php
                    • Grahame Blackwood
                      ... Hi Fernando How about trying vmail? Emails from within Vim. The link is: https://rubygems.org/gems/vmail I use it everyday and it s really good. Cheers G
                      Message 10 of 21 , Sep 28 10:28 AM
                      • 0 Attachment
                        On Wed, Sep 28, 2011 at 05:18 PM, Marcin Szamotulski <mszamot@...> wrote:

                        > from: Marcin Szamotulski <mszamot@...>
                        > date: Wed, Sep 28 05:18 PM +01:00 2011
                        > to: vim_use@...
                        > reply-to: vim_use@...
                        > subject: Re: Vim as default email (thunderbird) editor
                        >
                        > On 04:18 Wed 28 Sep , Fernando Basso wrote:
                        >> I really want to find a way to use vim as my default email editor. I
                        >> have been using thunderbird for a reasonable amount of time now, and I
                        >> stumbled through this "external editor" thunderbird plubin. However,
                        >> it seems not to be working with recent versions of thunderbird.
                        >>
                        >> So, I was pondering, "well, many vim users certainly use vim to write
                        >> emails." If so, do you have any tips regarding this subject. What I
                        >> have done so far is to write the email in vim, and then paste the
                        >> message back into the email client. There must be a better, clever, or
                        >> nicer way of doing this.
                        >>
                        >> I simply cannot stand any other editor anymore. There is no life after
                        >> vim.
                        >>
                        >> Any thoughts and ideas are welcome.
                        >>
                        >> --
                        >> You received this message from the "vim_use" maillist.
                        >> Do not top-post! Type your reply below the text you are replying to.
                        >> For more information, visit http://www.vim.org/maillist.php
                        >
                        > It should be noted that it is fairly easy to configure mutt to use vim as an
                        > external editor, this is a line of my muttrc file:
                        > set editor='vim +set\ spell\ spelllang=pl,pt,en_gb'
                        >
                        > Best,
                        > Marcin
                        >
                        > --
                        > You received this message from the "vim_use" maillist.
                        > Do not top-post! Type your reply below the text you are replying to.
                        > For more information, visit http://www.vim.org/maillist.php

                        Hi Fernando

                        How about trying vmail? Emails from within Vim. The link is:

                        https://rubygems.org/gems/vmail

                        I use it everyday and it's really good.

                        Cheers

                        G

                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php
                      • Tony Mechelynck
                        ... Try setting your External Editor preferences to call gvim with not only --nofork (or -f) but also a full path, i.e., not just gvim --nofork but something
                        Message 11 of 21 , Sep 28 11:27 AM
                        • 0 Attachment
                          On 28/09/11 17:50, Fernando Basso wrote:
                          >
                          >
                          > On Sep 28, 10:58 am, Quincy Bowers<qui...@...> wrote:
                          >> Make sure you setup External Editor to call 'gvim --nofork' or it won't work
                          >> properly. Other than that I can't imagine what would be wrong.
                          >
                          > It still doesn't work. Even using gvim --nofork.
                          >

                          Try setting your External Editor preferences to call gvim with not only
                          --nofork (or -f) but also a full path, i.e., not just

                          gvim --nofork

                          but something like

                          /usr/local/bin/gvim -f
                          or
                          C:\PROGRA~1\vim\vim73\gvim.exe -f
                          etc.


                          Best regards,
                          Tony.
                          --
                          "Why isn't there a special name for the tops of your feet?"
                          -- Lily Tomlin

                          --
                          You received this message from the "vim_use" maillist.
                          Do not top-post! Type your reply below the text you are replying to.
                          For more information, visit http://www.vim.org/maillist.php
                        • Fernando Basso
                          On Sep 28, 3:27 pm, Tony Mechelynck ... Still doesn t work. Thanks anyway. -- You received this message from the vim_use
                          Message 12 of 21 , Sep 28 11:31 AM
                          • 0 Attachment
                            On Sep 28, 3:27 pm, Tony Mechelynck <antoine.mechely...@...>
                            wrote:

                            >
                            > Try setting your External Editor preferences to call gvim with not only
                            > --nofork (or -f) but also a full path, i.e., not just
                            >
                            >         gvim --nofork
                            >
                            > but something like
                            >
                            >         /usr/local/bin/gvim -f
                            > or
                            >         C:\PROGRA~1\vim\vim73\gvim.exe -f

                            Still doesn't work. Thanks anyway.

                            --
                            You received this message from the "vim_use" maillist.
                            Do not top-post! Type your reply below the text you are replying to.
                            For more information, visit http://www.vim.org/maillist.php
                          • Reid Thompson
                            ... i didn t catch whether you noted windows or linux -- i can state that windows thunderbird 7.0 does work for me BUT only if the call to gvim uses the -f
                            Message 13 of 21 , Sep 28 4:31 PM
                            • 0 Attachment
                              On 9/28/2011 7:18 AM, Fernando Basso wrote:
                              > I really want to find a way to use vim as my default email editor. I
                              > have been using thunderbird for a reasonable amount of time now, and I
                              > stumbled through this "external editor" thunderbird plubin. However,
                              > it seems not to be working with recent versions of thunderbird.
                              >
                              > So, I was pondering, "well, many vim users certainly use vim to write
                              > emails." If so, do you have any tips regarding this subject. What I
                              > have done so far is to write the email in vim, and then paste the
                              > message back into the email client. There must be a better, clever, or
                              > nicer way of doing this.
                              >
                              > I simply cannot stand any other editor anymore. There is no life after
                              > vim.
                              >
                              > Any thoughts and ideas are welcome.
                              >
                              i didn't catch whether you noted windows or linux -- i can state that
                              windows thunderbird 7.0 does work for me BUT only if the call to gvim
                              uses the '-f' parameter. The '--no-fork' parameter gives an error for
                              me. I have the full path declared
                              C:\MyPrograms\Vim\vim73\gvim.exe -f for the plugin.

                              --
                              You received this message from the "vim_use" maillist.
                              Do not top-post! Type your reply below the text you are replying to.
                              For more information, visit http://www.vim.org/maillist.php
                            • Fernando Basso
                              ... I m running linux (arch linux). I tried with gvim --nofork gvim -f /usr/bin/gvim -f (also: --nofork) xterm -e vim --nofork (also: -f) None of them worked.
                              Message 14 of 21 , Sep 29 4:55 AM
                              • 0 Attachment
                                On Sep 28, 8:31 pm, Reid Thompson <reid.thomp...@...> wrote:

                                > i didn't catch whether you noted windows or linux -- i can state that
                                > windows thunderbird 7.0 does work for me BUT only if the call to gvim
                                > uses the '-f' parameter.  The '--no-fork' parameter gives an error for
                                > me.    I have the full path declared    
                                > C:\MyPrograms\Vim\vim73\gvim.exe -f     for the plugin.

                                I'm running linux (arch linux). I tried with

                                gvim --nofork
                                gvim -f
                                /usr/bin/gvim -f (also: --nofork)
                                xterm -e vim --nofork (also: -f)

                                None of them worked. I even tried:

                                mv $HOME/.vimrc $HOME/dot_vimrc
                                mv $HOME/.vim/ $HOME/dot_vim

                                to see if any plugin or config was getting in the way, but
                                that didn't help either.

                                Thanks everybody for all the tips and suggestions on other
                                alternatives. I'm pondering and trying them all.




                                --
                                You received this message from the "vim_use" maillist.
                                Do not top-post! Type your reply below the text you are replying to.
                                For more information, visit http://www.vim.org/maillist.php
                              • Reid Thompson
                                ... you may have already tried this and or it may not help, but ... try running thunderbird from the command line and attempt to use the external editor and
                                Message 15 of 21 , Sep 29 5:46 AM
                                • 0 Attachment
                                  On Thu, 2011-09-29 at 04:55 -0700, Fernando Basso wrote:

                                  > I'm running linux (arch linux). I tried with

                                  you may have already tried this and or it may not help, but ...

                                  try running thunderbird from the command line and attempt to use the
                                  external editor and see if there are any valid error messages output to
                                  the terminal that point you to the issue


                                  --
                                  You received this message from the "vim_use" maillist.
                                  Do not top-post! Type your reply below the text you are replying to.
                                  For more information, visit http://www.vim.org/maillist.php
                                • Fernando Basso
                                  ... thunderbird --jsconsole Thunderbird s Error Console showed this when I tried to launch the external editor: Error:
                                  Message 16 of 21 , Sep 29 6:12 AM
                                  • 0 Attachment
                                    On Sep 29, 9:46 am, Reid Thompson <Reid.Thomp...@...> wrote:
                                    > On Thu, 2011-09-29 at 04:55 -0700, Fernando Basso wrote:
                                    > > I'm running linux (arch linux). I tried with
                                    >
                                    > you may have already tried this and or it may not help, but ...
                                    >
                                    > try running thunderbird from the command line and attempt to use the
                                    > external editor and see if there are any valid error messages output to
                                    > the terminal that point you to the issue

                                    thunderbird --jsconsole

                                    Thunderbird's Error Console showed this when I tried to launch
                                    the external editor:

                                    Error: document.getElementById("exteditor_editAsHtml") is null
                                    Source File: chrome://exteditor/content/exteditor.js
                                    Line: 442

                                    "thunderbird" alone in the terminal doesn't show anything, neither
                                    does "thunderbird --g-fatal-warinings".


                                    --
                                    You received this message from the "vim_use" maillist.
                                    Do not top-post! Type your reply below the text you are replying to.
                                    For more information, visit http://www.vim.org/maillist.php
                                  • Eric Weir
                                    ... Do you know about this? http://www.hogbaysoftware.com/products/quickcursor Or this? [Only for gmail, though. http://danielchoi.com/software/vmail.html ...
                                    Message 17 of 21 , Sep 29 5:37 PM
                                    • 0 Attachment
                                      On Sep 28, 2011, at 7:18 AM, Fernando Basso wrote:

                                      > I simply cannot stand any other editor anymore. There is no life after
                                      > vim.

                                      Do you know about this?
                                      http://www.hogbaysoftware.com/products/quickcursor

                                      Or this? [Only for gmail, though.
                                      http://danielchoi.com/software/vmail.html

                                      ------------------------------------------------------------------------------------------
                                      Eric Weir
                                      Decatur, GA
                                      eeweir@...

                                      "What is man without the beasts? If all the beasts were gone,
                                      men would die from a great loneliness of spirit."

                                      - Chief Seattle






                                      --
                                      You received this message from the "vim_use" maillist.
                                      Do not top-post! Type your reply below the text you are replying to.
                                      For more information, visit http://www.vim.org/maillist.php
                                    • Axel Bender
                                      Not working here (Windows 2003, Thunderbird 7.0, exteditor 1.0). Same error in JS Console. This seems to be an error in the plugin; even when using notepad
                                      Message 18 of 21 , Sep 30 12:46 AM
                                      • 0 Attachment
                                        Not working here (Windows 2003, Thunderbird 7.0, exteditor 1.0).

                                        Same error in JS Console.

                                        This seems to be an error in the plugin; even when using "notepad" as the text editor, it would not get called (verified with procmon).

                                        => Faulty plugin; nothing to do with GVim.

                                        This returns us to the original question: Is there any working combination of GVim with Thunderbird 7.0?

                                        --
                                        You received this message from the "vim_use" maillist.
                                        Do not top-post! Type your reply below the text you are replying to.
                                        For more information, visit http://www.vim.org/maillist.php
                                      • Calon
                                        Tried on Windows, got the same error message when press Ctrl+E. Then drag External Editor icon to the toolbar, and click the new icon, it just works fine. On
                                        Message 19 of 21 , Sep 30 1:43 AM
                                        • 0 Attachment
                                          Tried on Windows, got the same error message when press Ctrl+E.
                                          Then drag External Editor icon to the toolbar, and click the new icon, it just works fine.

                                          On Thu, Sep 29, 2011 at 9:12 PM, Fernando Basso <fernandobasso.br@...> wrote:


                                          On Sep 29, 9:46 am, Reid Thompson <Reid.Thomp...@...> wrote:
                                          > On Thu, 2011-09-29 at 04:55 -0700, Fernando Basso wrote:
                                          > > I'm running linux (arch linux). I tried with
                                          >
                                          > you may have already tried this and or it may not help, but ...
                                          >
                                          > try running thunderbird from the command line and attempt to use the
                                          > external editor and see if there are any valid error messages output to
                                          > the terminal that point you to the issue

                                             thunderbird --jsconsole

                                          Thunderbird's Error Console showed this when I tried to launch
                                          the external editor:

                                             Error: document.getElementById("exteditor_editAsHtml") is null
                                             Source File: chrome://exteditor/content/exteditor.js
                                             Line: 442

                                          "thunderbird" alone in the terminal doesn't show anything, neither
                                          does "thunderbird --g-fatal-warinings".


                                          --
                                          You received this message from the "vim_use" maillist.
                                          Do not top-post! Type your reply below the text you are replying to.
                                          For more information, visit http://www.vim.org/maillist.php

                                          --
                                          You received this message from the "vim_use" maillist.
                                          Do not top-post! Type your reply below the text you are replying to.
                                          For more information, visit http://www.vim.org/maillist.php
                                        • Axel Bender
                                          Thanks for your input, Calon. This in fact does the trick (still an error in the plugin); I would never have tried this myself... Have a nice weekend -- You
                                          Message 20 of 21 , Sep 30 7:08 AM
                                          • 0 Attachment
                                            Thanks for your input, Calon. This in fact does the trick (still an error in the plugin); I would never have tried this myself...

                                            Have a nice weekend

                                            --
                                            You received this message from the "vim_use" maillist.
                                            Do not top-post! Type your reply below the text you are replying to.
                                            For more information, visit http://www.vim.org/maillist.php
                                          • Fernando Basso
                                            ... Since I didn t see any Installation instructions in the page, I assumed I d just install it as any other add-on. I was going to post a comment the add-
                                            Message 21 of 21 , Sep 30 7:40 AM
                                            • 0 Attachment
                                              On Sep 30, 5:43 am, Calon <calon...@...> wrote:
                                              > Tried on Windows, got the same error message when press Ctrl+E.
                                              > Then drag External Editor icon to the toolbar, and click the new icon, it
                                              > just works fine.

                                              Since I didn't see any "Installation" instructions in the page, I
                                              assumed I'd just
                                              install it as any other add-on. I was going to post a comment the add-
                                              on page,
                                              where it says "react to this article", and just above the textarea
                                              there was
                                              this text:

                                              ====================================================================
                                              Installation
                                              The External Editor button is not visible by default; you must
                                              customize your composer toolbar:

                                              Open the compose window
                                              Select the menu View/Toolbars/Customize..., or right click on the
                                              toolbar and select Customize...
                                              Drag and Drop the new icon External Editor on your toolbar
                                              Click OK

                                              Then, open the extension option window and set your editor (without
                                              path or with an absolute path)
                                              ====================================================================

                                              It is working now, but I don't need to mouse-click the icon. Ctrl-E
                                              does it as well.

                                              SOLVED.

                                              Thanks everybody for all the tips. I liked vmail and and
                                              mutt, although I still need to get more skilled at them.

                                              --
                                              You received this message from the "vim_use" maillist.
                                              Do not top-post! Type your reply below the text you are replying to.
                                              For more information, visit http://www.vim.org/maillist.php
                                            Your message has been successfully submitted and would be delivered to recipients shortly.