Loading ...
Sorry, an error occurred while loading the content.

Enabling cursorline makes SpecialKey change colour

Expand Messages
  • Paul Giannaros
    Hi. I use a light background (set background=light). I like tab indicators with lower contrast, so I highlight them with light grey: hi SpecialKey
    Message 1 of 4 , Sep 1, 2011
    • 0 Attachment
      Hi. I use a light background (set background=light). I like tab
      indicators with lower contrast, so I highlight them with light grey:

      hi SpecialKey guifg=#dddddd

      I recently tried :set cursorline and really liked it. I've set the
      cursor line colour with:

      hi CursorLine guibg=#e5efff

      Normal line tab indicators are grey, but when I move my cursor over a
      line with cursorline enabled, the tab indicator goes black. I find
      this really distracting. Can I keep the tab indicator colour that I've
      set and still use cursorline? I tried hacking around to overwrite the
      cursorline's overwrite with a new match for /\t\+/ but still ran into
      the same problem.

      Thanks, Paul

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... After a little experimenting it seems to be not only the CursorLine highlight but also the Visual highlight: when I use V followed by up-down motion to
      Message 2 of 4 , Sep 1, 2011
      • 0 Attachment
        On 01/09/11 11:24, Paul Giannaros wrote:
        > Hi. I use a light background (set background=light). I like tab
        > indicators with lower contrast, so I highlight them with light grey:
        >
        > hi SpecialKey guifg=#dddddd
        >
        > I recently tried :set cursorline and really liked it. I've set the
        > cursor line colour with:
        >
        > hi CursorLine guibg=#e5efff
        >
        > Normal line tab indicators are grey, but when I move my cursor over a
        > line with cursorline enabled, the tab indicator goes black. I find
        > this really distracting. Can I keep the tab indicator colour that I've
        > set and still use cursorline? I tried hacking around to overwrite the
        > cursorline's overwrite with a new match for /\t\+/ but still ran into
        > the same problem.
        >
        > Thanks, Paul
        >

        After a little experimenting it seems to be not only the CursorLine
        highlight but also the Visual highlight: when I use V followed by
        up-down motion to highlight lines of text, with ":set list
        listchars=tab:\|_,eol:ś", all my hard tabs (SpecialKey highlight) and
        ends-of-lines (NonText highlight) become black everywhere in the Visual
        area.

        AFAIK there's nothing we can do about it. I don't know if it's
        documented (or where) but it might even be intentional.


        Best regards,
        Tony.
        --
        If you think last Tuesday was a drag, wait till you see what happens
        tomorrow!

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Paul Giannaros
        On Sep 1, 5:02 pm, Tony Mechelynck ... Thanks for looking into it. I ve googled around for any mention of this but with no
        Message 3 of 4 , Sep 2, 2011
        • 0 Attachment
          On Sep 1, 5:02 pm, Tony Mechelynck <antoine.mechely...@...>
          wrote:
          > On 01/09/11 11:24, Paul Giannaros wrote:
          >
          > > Hi. I use a light background (set background=light). I like tab
          > > indicators with lower contrast, so I highlight them with light grey:
          >
          > >      hi SpecialKey guifg=#dddddd
          >
          > > I recently tried :set cursorline and really liked it. I've set the
          > > cursor line colour with:
          >
          > >      hi CursorLine guibg=#e5efff
          >
          > > Normal line tab indicators are grey, but when I move my cursor over a
          > > line with cursorline enabled, the tab indicator goes black. I find
          > > this really distracting. Can I keep the tab indicator colour that I've
          > > set and still use cursorline? I tried hacking around to overwrite the
          > > cursorline's overwrite with a new match for /\t\+/ but still ran into
          > > the same problem.
          >
          > > Thanks, Paul
          >
          > AFAIK there's nothing we can do about it. I don't know if it's
          > documented (or where) but it might even be intentional.

          Thanks for looking into it. I've googled around for any mention of
          this but with no luck. Shall I report it as a bug to the vim dev list?

          >
          > Best regards,
          > Tony.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Ben Fritz
          On Sep 1, 11:02 am, Tony Mechelynck ... I ve seen something similar also for lines whose background is set via a :sign place
          Message 4 of 4 , Sep 2, 2011
          • 0 Attachment
            On Sep 1, 11:02 am, Tony Mechelynck <antoine.mechely...@...>
            wrote:
            >
            > After a little experimenting it seems to be not only the CursorLine
            > highlight but also the Visual highlight: when I use V followed by
            > up-down motion to highlight lines of text, with ":set list
            > listchars=tab:\|_,eol: ", all my hard tabs (SpecialKey highlight) and
            > ends-of-lines (NonText highlight) become black everywhere in the Visual
            > area.
            >
            > AFAIK there's nothing we can do about it. I don't know if it's
            > documented (or where) but it might even be intentional.
            >

            I've seen something similar also for lines whose background is set via
            a :sign place command. It was annoying enough to make me abandon my
            alternating lines in a different color script.

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.