Loading ...
Sorry, an error occurred while loading the content.
 

Re: netrw dir listing position

Expand Messages
  • Charles Campbell
    ... I should ve mentioned that I was using :Rex to return to the netrw window. I ve made a change to netrw (v143e); you may obtain it from my website:
    Message 1 of 11 , Aug 1, 2011
      Bram Moolenaar wrote:
      > Charles E Campbell Jr wrote:
      >
      >>>> Hi,
      >>>>
      >>>> Is there a way to make the netrw dir listing maintain
      >>>> the cursor position?
      >>>>
      >>>> For example if I do a dir listing on a big dir, scroll down, and
      >>>> press enter to edit a file, when I go back to the dir listing the
      >>>> cursor is no longer at the file where I left it. The cursor
      >>>> starts over at the top of the dir listing.
      >>>>
      >>>> This is a pain if I want to edit a handful of files chosen from
      >>>> the netrw listing.
      >>>>
      >>>> Is there a way to maintain the cursor position in the dir listing?
      >>>>
      >>>>
      >>>>
      >>> I'm afraid that I don't see this behavior using v143d of netrw. Please
      >>> try upgrading netrw and see if you still have this problem.
      >>>
      >>> You may get v143d from:
      >>> http://mysite.verizon.net/astronaut/vim/index.html#NETRW
      >>>
      >>>
      >> I should mention that I tried both the wide listing and the default thin
      >> listing when attempting to elicit this behavior. If the behavior
      >> persists, please let me know what netrw settings you may have and any
      >> more details that may be helpful.
      >>
      > I have the same problem, never took time to figure out how to fix it.
      >
      > Start Vim with: vim -u NORC -N
      >
      > Edit a directory with lots of files, move to halfway the list.
      > Press Enter, then :e #.
      > I end up at the top of the listing.
      > If after Enter I use CTRL-O I end up at the bottom of the listing.
      >
      > In both cases using '" takes me to where I wanted to be. Does netrw
      > jump to the '" mark when opening a directory?
      >
      >
      I should've mentioned that I was using :Rex to return to the netrw
      window. I've made a change to netrw (v143e); you may obtain it from my
      website:

      http://mysite.verizon.net/astronaut/vim/index.html#NETRW

      There may be side effects that I'm not currently aware of, however.

      Regards,
      Chip Campbell


      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.