Loading ...
Sorry, an error occurred while loading the content.

Re: Manu missing: Ubuntu 11.04

Expand Messages
  • John Little
    ... That sounds like you have some configuration or customization file that you can t read. I suggest checking the accessibility of everything in your home
    Message 1 of 7 , Aug 1, 2011
    • 0 Attachment
      > After installing afresh Ubuntu (version 11.04) gvim displays menus
      > only if I run it as root (superuser). If I run it as normal user I
      > find no way of displaying menus.

      That sounds like you have some configuration or customization file
      that you can't read. I suggest checking the accessibility of
      everything in your home directory, including hidden files and
      directories. Maybe

      ls -laR

      This easily happens if you run stuff with sudo.

      HTH, regards, John

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Guido Milanese
      ... Thanks for your suggestion! I checked the whole directory, but there is no hidden configuration file or similar stuff with wrong permissions. In fact, it
      Message 2 of 7 , Aug 1, 2011
      • 0 Attachment
        On 1 Aug, 12:55, John Little <john.b.lit...@...> wrote:
        > > After installing afresh Ubuntu (version 11.04) gvim displays menus
        > > only if I run it as root (superuser). If I run it as normal user I
        > > find no way of displaying menus.
        >
        > That sounds like you have some configuration or customization file
        > that you can't read.  I suggest checking the accessibility of
        > everything in your home directory, including hidden files and
        > directories.  Maybe
        >
        >     ls -laR
        >
        > This easily happens if you run stuff with sudo.

        Thanks for your suggestion! I checked the whole directory, but there
        is no hidden configuration file or similar stuff with wrong
        permissions. In fact, it is a new installation, with no personal
        customisation (I'll add vimlatex, which I use almost every day, after
        solving the problem). The funny thing is that "sometimes" the menu
        displays playing with "setguioptions+=m", but I can't find any rule to
        know when it happens. Maybe the notorious file gnome2/Vim, that sets
        menu and toolbar positions, but I deleted the file with no success --
        anyway it's written again next time.

        As root, everything is OK, and this suggests some problems of
        permissions, but of what?

        Best regards,
        Guido (Italy)

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • John Little
        Hi My son, a software engineering student, has 11.04 on his lap top, and so I had a look, and sure enough, he has the problem as you report it. But it s not
        Message 3 of 7 , Aug 2, 2011
        • 0 Attachment
          Hi

          My son, a software engineering student, has 11.04 on his lap top, and
          so I had a look, and sure enough, he has the problem as you report
          it. But it's not just gvim, *every* app I tried behaves like this.
          To get the menu, one has to mouse-over the title at the top of the
          screen, where it says "Gvim Text Editor", *not* the title of the gvim
          window. Yet, if one starts with sudo, the menu appears normally.

          I suspect it's a Unity thing, but my attempts to find out anything
          about Unity have failed so far.

          Regards, John

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • John Little
          ... Yes, it s a Unity thing. (I use KDE myself.) See
          Message 4 of 7 , Aug 2, 2011
          • 0 Attachment
            On Aug 2, 9:11 pm, John Little <john.b.lit...@...> wrote:

            > I suspect it's a Unity thing, but my attempts to find out anything
            > about Unity have failed so far.

            Yes, it's a Unity thing. (I use KDE myself.) See

            http://askubuntu.com/questions/6784/is-it-possible-to-make-indicator-appmenu-ignore-a-specific-application

            for some workarounds. For example, if I type in a terminal

            UBUNTU_MENUPROXY= gvim

            (note the exact placement of the space) gvim starts with the menu (or
            not if you've got no m in guioptions, as I normally do; I have an
            option in the pop up menu to toggle it).

            My brief experience with Unity today has not encouraged me to try it
            further. I find it very like the early days of KDE 4; lots of
            controls are missing.

            I suspect that there aren't many Unity users lurking here in vim_use.

            Regards, John

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Guido Milanese
            ... Than you. This solved the problem. In fact, i had previously tried to see whether the menu was behaving as standard programmes (Firefox and so on), but I
            Message 5 of 7 , Aug 3, 2011
            • 0 Attachment
              On 2 Ago, 12:47, John Little <john.b.lit...@...> wrote:
              > Yes, it's a Unity thing.  (I use KDE myself.)  See
              >
              > http://askubuntu.com/questions/6784/is-it-possible-to-make-indicator-...
              >
              > for some workarounds.  For example, if I type in a terminal
              >
              >     UBUNTU_MENUPROXY= gvim
              >
              > (note the exact placement of the space) gvim starts with the menu pop up menu to toggle it).
              Than you. This solved the problem. In fact, i had previously tried to
              see whether the menu was behaving as 'standard' programmes (Firefox
              and so on), but I could not see the menu in the usual Unity way. Since
              I usually start Gvim from the terminal, being a middle-aged user who
              still finds a terminal his normal environment, I adopted the system
              you suggest, and I did a minimal script, called it menuvim, put in
              the /home/mynameasuser/bin directory, so it wont'g go in an update,
              and made it executable:

              #! /bin/bash
              export UBUNTU_MENUPROXY=0
              gvim $1 $2 $3 $4

              variables enough for any use! No problem with vimlatex, by the way (in
              that case, menus are essential).

              > My brief experience with Unity today has not encouraged me to try it
              > further.  I find it very like the early days of KDE 4; lots of
              > controls are missing.
              Well, I do not dislike it, despite this problem with Gvim. I think it
              has not yet reached a completely mature development, but I had no
              crash in a week of use. Previously I used 'standard' Gnome. Anyway you
              can switch to classical Ubuntu or install kubuntu if you do not like
              Unity (that's what my daughter, 15 yrs, will probably do, she does not
              like Unity at all).

              Many thanks again!
              guido (Genoa, Italy)

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            Your message has been successfully submitted and would be delivered to recipients shortly.