Loading ...
Sorry, an error occurred while loading the content.

Re: Print function

Expand Messages
  • John Culleton
    On Wednesday, July 27, 2011 11:30:48 am Benjamin R. ... without ... up wtih Cups ... printers. ... lpr method ... use Cups as ... isn t using CUPS. ...
    Message 1 of 3 , Jul 27, 2011
    • 0 Attachment

      On Wednesday, July 27, 2011 11:30:48 am Benjamin R. Haskell wrote:

      > On Wed, 27 Jul 2011, John Culleton wrote:

      > > For some time now I have used Gvim on Linux Slackware without

      > > difficulty in printing. But my latest Slackware is set up wtih Cups

      > > and most programs give me a choice between my two printers.

      > >

      > > It appears that Gvim doesn't use Cups. And the older lpr method

      > > doesn't seem to work. Is there a way to cajole Gvim to use Cups as

      > > does Scribus, Gimp, Acrobat Reader, KMail etc.?

      >

      > It would surprise me (a lot) to learn that GVim truly isn't using CUPS.

      > On virtually every system I've used that has CUPS installed, `lpr` is

      > part of CUPS. (On OpenSUSE `lpr` is part of 'cups-client', under Gentoo

      > it's part of 'net-print/cups')

      >

      > If you're sure it's not using CUPS and need to finagle it, take a look

      >

      > in the help concerning the 'printexpr' option:

      > :help pexpr-option

      >

      > Otherwise, to send output to a different printer, use the 'printdevice'

      >

      > option:

      > :help 'pdev'

      >

      > AFAIK, GVim won't use a standard "Print" dialog (though some of the help

      > text seems to suggest otherwise... maybe only on Win32?).

      --

      Thanks

      I fixed it by copying the lpoptions file from an old partition and making sure that /usr/doc/cups belonged to root:root.

      John Culleton

      "Death Wore Black" Police procedural: http://www.deathworeblack.com/

      "Create Book Covers with Scribus"

      http://booklocker.com/books/4055.html

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.