Loading ...
Sorry, an error occurred while loading the content.
 

Re: Tag jumping problem

Expand Messages
  • Karol Samborski
    ... I have the same behavior when I turn off cscope feature. But it worked for me for the moment. I don t know what I did that it is not working now. I think
    Message 1 of 7 , Jun 30, 2011
      2011/6/30 Jürgen Krämer <jottkaerr@...>:
      >
      > Hi,
      >
      >
      > I don't use cscope, so I can't help much, but the last paragraph at
      >
      >  :help cscope-howtouse
      >
      > says
      >
      > | If the results return only one match, you will automatically be taken to it.
      > | If there is more than one match, you will be given a selection screen to pick
      > | the match you want to go to.  After you have jumped to the new location,
      > | simply hit Ctrl-T to get back to the previous one.
      >
      > I don't know if this is only true for explicit cscope commands or also
      > if 'cscopetag' is set.

      I have the same behavior when I turn off cscope feature. But it worked
      for me for the moment. I don't know what I did that it is not working
      now.

      I think that showing the list of places to jump is needless because it
      populates the quickfix list and it is much more powerful (for example
      I can search on this list and I can switch place at any time without
      jumping backwards). The behavior I want to achieve is that when I
      press C-] it will jump to the first place on the list and will
      automatically show the quickfix list.

      Any ideas?

      Regards,
      Karol

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.