Loading ...
Sorry, an error occurred while loading the content.

nocompatible always goes to insert mode

Expand Messages
  • Exiges
    I m tearing my hair out with this problem. When I try to edit a file, it immediately takes me into insert mode , and I have to hit escape before I can
    Message 1 of 5 , Mar 4, 2011
    • 0 Attachment
      I'm tearing my hair out with this problem.

      When I try to edit a file, it immediately takes me into "insert mode",
      and I have to hit escape before I can navigate.

      If I remove the line "set nocompatible" from my /etc/vimrc then the
      problem goes away, but I require compatiblity mode for my autocmd's
      (ie. remembering positions in files etc)

      I must be missing a setting which determines what the defaults for
      "nocompatiblity" does.

      But I thought the default mode for "nocompatible" was "Normal" ?

      If so, why is it always going into insert mode ? How do I change it
      back ?

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Exiges
      Note, I don t have a ~/.vimrc file, it s just picking up /etc/vimrc which has just that one line in it set nocompatible -- You received this message from the
      Message 2 of 5 , Mar 4, 2011
      • 0 Attachment
        Note, I don't have a ~/.vimrc file, it's just picking up /etc/vimrc
        which has just that one line in it

        set nocompatible

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Ben Fritz
        ... You wouldn t happen to be launching Vim with a -y option, or from an executable/command line named evim or eview? Check for an alias as well if you launch
        Message 3 of 5 , Mar 4, 2011
        • 0 Attachment
          On Mar 4, 5:59 am, Exiges <accou...@...> wrote:
          > I'm tearing my hair out with this problem.
          >
          > When I try to edit a file, it immediately takes me into "insert mode",
          > and I have to hit escape before I can navigate.
          >
          > If I remove the line "set nocompatible" from my /etc/vimrc then the
          > problem goes away, but I require compatiblity mode for my autocmd's
          > (ie. remembering positions in files etc)
          >
          > I must be missing a setting which determines what the defaults for
          > "nocompatiblity" does.
          >
          > But I thought the default mode for "nocompatible" was "Normal" ?
          >
          > If so, why is it always going into insert mode ? How do I change it
          > back ?

          You wouldn't happen to be launching Vim with a -y option, or from an
          executable/command line named evim or eview? Check for an alias as
          well if you launch from the command line. Also setting 'insertmode'
          anywhere in your config files could cause this, or using
          the :startinsert command, but you say it's only the one "set
          nocompatible" line.

          You can try

          :verbose set insertmode?

          once Vim is started (use CTRL-O or CTRL-L to get out of insert mode if
          <Esc> doesn't work), to see if it is set and where it was set.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Exiges
          Thankyou for taking the time to respond Ben, I ve found a workaround, but still find it perplexing. I only get the problem if my terminal type is xterm, if
          Message 4 of 5 , Mar 4, 2011
          • 0 Attachment
            Thankyou for taking the time to respond Ben, I've found a workaround,
            but still find it perplexing.

            I only get the problem if my terminal type is xterm, if it's vt100
            then it doesn't happen.

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Exiges
            To answer your question Ben, I tried ... and got back: noinsertmode -- You received this message from the vim_use maillist. Do not top-post! Type your reply
            Message 5 of 5 , Mar 4, 2011
            • 0 Attachment
              To answer your question Ben, I tried

              :verbose set insertmode?

              and got back:

              noinsertmode

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            Your message has been successfully submitted and would be delivered to recipients shortly.