Loading ...
Sorry, an error occurred while loading the content.

My GVIM7.3 on Win7 : Has started issuing E488 errors. Help

Expand Messages
  • Rostyk
    My default download and installation of the VIM suite on a Win 7 , 64 bit ultimate system was working fine, but has now begun issuing E488 trailing character
    Message 1 of 4 , Jan 2, 2011
    • 0 Attachment
      My default download and installation of the VIM suite on a Win 7 , 64
      bit ultimate system
      was working fine, but has now begun issuing E488 trailing character
      error messages,
      for most ex commands.
      Specific example: Editing "@Risk" a mail collection text file, .
      i.e. filetype=mail, syntax=mail,
      e @Risk
      scroll down some lines and set a mark mc
      scroll down some more and set ma
      scroll down some more and set mb
      Scroll a few more lines and now try some commands!
      'a or 'b or 'c work
      :a,bp to display the lines in the a,b range. throws an E488
      error
      :20,30p with an explicit numeric range works
      :20,30d with an explicit numeric range works
      :a,bd throws an E488
      :a,bmc throws an E488
      Also confusing is that if ma is at line 40 and mb is at line 50
      then for the command
      :40,bmc I am getting an error "Not an editor command" and
      for :40,bm20 I get an error that I am giving a backward range
      and is it (y/n) all right to switch?.

      HELP! What has gone bad? and what do I need to do to repair this?
      Please also reply to me by email to urjlew@... as well as
      posting any advice.
      I don't Google too well.
      Advance thanks.
      PS. I first posted this to comp.editors in Google groups on Jan 1,
      before finding this venue.
      --
      Rostyk


      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Michael Henry
      ... In ex commands, line ranges using marks cannot be specified by just naming the mark register like a ; instead, use a ... Because the is missing
      Message 2 of 4 , Jan 3, 2011
      • 0 Attachment
        On 01/02/2011 10:49 PM, Rostyk wrote:
        > 'a or 'b or 'c work
        > :a,bp to display the lines in the a,b range. throws an E488
        > error

        In "ex" commands, line ranges using marks cannot be specified
        by just naming the mark register like "a"; instead, use "'a"
        like this:

        :'a,'bp

        More detail is found here:

        :help range

        But you might start reading here:

        :help cmdline-ranges

        > :a,bd throws an E488

        Because the "'" is missing for mark "a", Vim sees this as the
        "ex" command ":a", which is short for ":append". The trailing
        characters ",bd" are not valid with ":append". See:

        :help :append

        The command should have been:

        :'a,'bd

        > Also confusing is that if ma is at line 40 and mb is at line 50
        > then for the command
        > :40,bmc I am getting an error "Not an editor command"

        The line range here is "40," (which means "40,.", or from line
        40 to the current line), followed by the (invalid) command "bmc".

        I imagine this was intended:

        :40,'bm'c

        The line number for mark "c" is provided by "'c".

        > and
        > for :40,bm20 I get an error that I am giving a backward range
        > and is it (y/n) all right to switch?.

        The line range here is "40,", followed by the command "bm"
        (short for ":bmodified") with argument "20". The range would
        appear to be backward if your cursor were on line 39 or earlier.

        Try this instead:

        :40,'bm20

        > Please also reply to me by email to urjlew@... as well as
        > posting any advice.

        Michael Henry

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • ZyX
        Reply to message «My GVIM7.3 on Win7 : Has started issuing E488 errors. Help», sent 06:49:19 03 January 2011, Monday ... Before trying this think a bit: if
        Message 3 of 4 , Jan 3, 2011
        • 0 Attachment
          Reply to message «My GVIM7.3 on Win7 : Has started issuing E488 errors. Help»,
          sent 06:49:19 03 January 2011, Monday
          by Rostyk:

          > :a,bp to display the lines in the a,b range. throws an E488
          Before trying this think a bit: if that was a correct syntax then how could vim
          distinguish between
          :a,pr l
          what means ``insert text from file «l» after position of mark «p» (read command
          uses only last line of the range, so `a,' is ignored)'' and
          :a,pr l
          what means ``print lines from mark «a» to current line (`.' may be omitted)
          displaying unprintable characters and tabs (or something else depending on
          `listchars' option)''.

          Correct syntax is
          :'a,'pread l
          and
          :'a,print l
          . See also :h cmdline-ranges.

          Original message:
          > My default download and installation of the VIM suite on a Win 7 , 64
          > bit ultimate system
          > was working fine, but has now begun issuing E488 trailing character
          > error messages,
          > for most ex commands.
          > Specific example: Editing "@Risk" a mail collection text file, .
          > i.e. filetype=mail, syntax=mail,
          > e @Risk
          > scroll down some lines and set a mark mc
          > scroll down some more and set ma
          > scroll down some more and set mb
          > Scroll a few more lines and now try some commands!
          > 'a or 'b or 'c work
          >
          > :a,bp to display the lines in the a,b range. throws an E488
          >
          > error
          >
          > :20,30p with an explicit numeric range works
          > :20,30d with an explicit numeric range works
          > :
          > :a,bd throws an E488
          > :a,bmc throws an E488
          >
          > Also confusing is that if ma is at line 40 and mb is at line 50
          > then for the command
          >
          > :40,bmc I am getting an error "Not an editor command" and
          >
          > for :40,bm20 I get an error that I am giving a backward range
          > and is it (y/n) all right to switch?.
          >
          > HELP! What has gone bad? and what do I need to do to repair this?
          > Please also reply to me by email to urjlew@... as well as
          > posting any advice.
          > I don't Google too well.
          > Advance thanks.
          > PS. I first posted this to comp.editors in Google groups on Jan 1,
          > before finding this venue.
          > --
          > Rostyk
        • Rostyslaw Lewyckyj
          ... Thank you very much for cluing me in to the requirements of the apostrophe i.e. a b etc. in specifying line ranges. -- Rostyk -- You received this
          Message 4 of 4 , Jan 3, 2011
          • 0 Attachment
            Michael Henry wrote:
            > On 01/02/2011 10:49 PM, Rostyk wrote:
            >
            >> 'a or 'b or 'c work
            >> :a,bp to display the lines in the a,b range. throws an E488
            >> error
            >>
            > In "ex" commands, line ranges using marks cannot be specified
            > by just naming the mark register like "a"; instead, use "'a"
            > like this:
            >
            > :'a,'bp
            >
            > More detail is found here:
            >
            > :help range
            >
            > But you might start reading here:
            >
            > :help cmdline-ranges
            >
            ------------------------------------
            > Michael Henry
            >
            >
            Thank you very much for cluing me in to the requirements of the
            apostrophe i.e. 'a 'b etc.
            in specifying line ranges.
            --
            Rostyk

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.