Loading ...
Sorry, an error occurred while loading the content.
 

Re: How to Map Alt Key

Expand Messages
  • lainme
    You may use or -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For
    Message 1 of 7 , Jan 2, 2011
      You may use <A-K> or  <M-K>

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Ajay Jain
      ... This does not work for me. -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to.
      Message 2 of 7 , Jan 11, 2011
        > Try "map <A-k> foo". Works for me on Gvim.

        This does not work for me.

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Ajay Jain
        ... This does not work either. -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to.
        Message 3 of 7 , Jan 11, 2011
          > You may use <A-K> or  <M-K>

          This does not work either.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • lainme
          I am not sure if xterm*eightBitInput: false and xterm*altSendsEscape: true is set in your machine. If set, you can disable it or put the following into your
          Message 4 of 7 , Jan 11, 2011
            I am not sure if  xterm*eightBitInput: false and xterm*altSendsEscape: true is set in your machine.

            If set, you can disable it or put the following into your .vimrc

                for i in range(97,122)
                    let c = nr2char(i)
                    exec "set <M-".c.">=\<Esc>".c
                endfor

            "encoding" and  "fileencodings"  should be set after this.



            On Tue, Jan 11, 2011 at 4:48 PM, Ajay Jain <ajay050@...> wrote:
            > You may use <A-K> or  <M-K>

            This does not work either.

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.