Loading ...
Sorry, an error occurred while loading the content.

Re: The 'default highlighting' after loading empty (each line commented) syntax file

Expand Messages
  • Ben Fritz
    ... Ah, perhaps it is defined somewhere in the menu runtime code as needed. I don t use the GUI menus. It appears that SetSyn takes a filetype, not a file
    Message 1 of 4 , Dec 3, 2010
    • 0 Attachment
      On Dec 1, 5:10 pm, Kamil Libich <kamil.lib...@...> wrote:
      > Hi Ben,
      >
      > When I go to the menu->syntax->show filetypes in menu at the bottom of vim
      > window the calling statement appears as :cal SetSyn("c"). That it was how I
      > worked out the 'enable syntax' statement. So, then I execute my statement
      > as  :cal SetSyn("test.vim") and I have no error.
      >

      Ah, perhaps it is defined somewhere in the menu runtime code as
      needed. I don't use the GUI menus.

      It appears that SetSyn takes a filetype, not a file name. So your
      SetSyn("test.vim") is actually setting up filetype test AND vim
      (see :help 'ft' for the dot syntax).

      > I thought the syntax is enabled (I had some highlighting effect). However,
      > having read your email I realised that the syntax is not enabled. I used
      > your syntax and everything is OK and works as expected! No default highlight
      > and problem with the new line anchor disappear!
      >

      Good! I'm glad you found a solution. Please bottom-post next time.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.