Loading ...
Sorry, an error occurred while loading the content.

Re: and set list problem

Expand Messages
  • lingkun
    2010/11/3 Tony Mechelynck ... er, i have just download and install gvim 7.3.047 and test, it s still the same. i found that
    Message 1 of 7 , Nov 3, 2010
    • 0 Attachment
      2010/11/3 Tony Mechelynck <antoine.mechelynck@...>
      On 03/11/10 05:39, lingkun wrote:

      sorry for that i forgot to list the settings when i do the test.
         :set ts=8
         :set sts=8
         :set noet
      er, I was using gvim 7.2( offical version ) on windowsXP . To get the
      settings of "t_kb" and "t_kD", i run vim in the windows console, and
      they all have the same symptoms.

      Best regards,

      Hm, 7.2 (and presumably 7.2.0) is already, shall we say, somewhat dated. You'll find a Windows installer for (as of this writing) 7.3.047 (the latest bugfixed version) at http://sourceforge.net/projects/cream/files/ (You can see the compilation options --the ":version" listing-- before downloading by viewing the "Release Notes" by clickjing the clipboard-like icon in the right column under "Newest files".)

      Can you try this, and let us know if you still have the problem?

      Best regards,
      When in doubt, use brute force.
                     -- Ken Thompson

      er, i have just download  and  install gvim 7.3.047  and test, it's  still the same.

       i found that when i set softtabstop to 0 (which is the default setting) ,it works properly
      in 7.2 and 7.3.047, but when sts was setted to a nonzero number , set list and don't change the default listchars,a <BS>seems to  delete softtabstop  number of the display characters(in both 7.2 and 7.3.047).

      i.e. when set softtabstop=8 ,"^I^I^I^I"(four hard stop ) was deleted by ONE <BS>, when  i set softtabstop=4 "^I^I^I^I"( four hard stop ) was deleted by TWO <BS>, when i set softtabstop=3 "^I^I^I"(three hard tab stop )was deleted by TWO <BS> ,etc. 

      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.