Loading ...
Sorry, an error occurred while loading the content.
 

Re: Digraphs displayed as funny characters

Expand Messages
  • Tony Mechelynck
    ... Console Vim or gvim? If gvim, it probably means your font doesn t have the glyphs for those characters: see
    Message 1 of 3 , Nov 1, 2010
      On 01/11/10 15:00, Tereno wrote:
      > Hi all,
      >
      > I'm trying to figure how I can get digraphs (as well as unicode
      > characters if possible) displayed properly. When I type :digraphs, I
      > get the list of digraphs but I have question marks instead of funny
      > symbols. I have both vim 7.3 and vim 7.2 on my system. Vim 7.2 seems
      > to display everything fine (installed with apt) but vim 7.3 gives me
      > question marks and weird symbols. Would anyone know how the digraphs
      > work?
      >
      > Thanks!
      >

      Console Vim or gvim?

      If gvim, it probably means your font doesn't have the glyphs for those
      characters: see http://vim.wikia.com/wiki/Setting_the_font_in_the_GUI

      If Console Vim, it could be _either_ the font (which is handled by the
      terminal, Vim has no action on that), _or_ a misunderstanding between
      Vim and the terminal about which charset (for which locale) to use for
      reading and writing. If the former, try setting a different font if yout
      terminal allows it. If the latter, and you change 'encoding' in your
      vimrc, try saving the _old_ 'encoding' value in 'termencoding', e.g. as
      follows:

      if has('multi_byte') " if not, bypass the whole multibyte rigmarole
      if &enc !~? '^u' " if not already Unicode
      if &tenc == "" " avoid f*ing up kb & terminal communications
      let &tenc = &enc
      endif
      set enc=utf-8
      endif
      set fencs=ucs-bom,utf-8,latin1 " for example
      " the following are optional
      " they mean: create new files in Latin1 by default;
      " create new Unicode files (if 'fileencoding' is manually set)
      " with a BOM by default.
      " warning: some fileypes (e.g. anything with #! in the first line)
      " should not have a BOM (and, in most cases, be in US-ASCII so
      " Latin1 should be OK for them).
      setglobal fenc=latin1 bomb
      else
      echomsg 'Warning: this Vim version has no multibyte support'
      " note: Vim versions with no expression evaluation (which usually
      " also have no multibyte) will treat the whole if...else...endif
      " block as a nestable comment (and give no message here).
      endif

      see http://vim.wikia.com/wiki/Working_with_Unicode (and the help topics
      mentioned there) for details about the above snippet.


      Best regards,
      Tony.
      --
      " ... I told my doctor I got all the exercise I needed being a
      pallbearer for all my friends who run and do exercises!"
      -- Winston Churchill

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.