Loading ...
Sorry, an error occurred while loading the content.
 

and set list problem

Expand Messages
  • itx
    when i set list and then type four tab in a newline like t t t t when i set list , i type backspce for juse one time this four tabs were delete ,
    Message 1 of 7 , Nov 1, 2010
      when i set list and then type four tab in a newline like

      \t\t\t\t
      when i "set list" , i type backspce for juse one time
      this four tabs were delete ,

      but when i "set nolist" ,i works well
      why…

      my settings

      set tabstop=8
      set noexpandtab
      set backspace=indent,eol,start

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... If you :set list , and listchars is unset, every hard tab you type should appeat as ^I If you :set list , and listchars has a properly set tab:
      Message 2 of 7 , Nov 1, 2010
        On 01/11/10 17:08, itx wrote:
        > when i set list and then type four tab in a newline like
        >
        > \t\t\t\t
        > when i "set list" , i type backspce for juse one time
        > this four tabs were delete ,
        >
        > but when i "set nolist" ,i works well
        > why…
        >
        > my settings
        >
        > set tabstop=8
        > set noexpandtab
        > set backspace=indent,eol,start
        >

        If you ":set list", and 'listchars' is unset, every hard tab you type
        should appeat as ^I

        If you ":set list", and 'listchars' has a properly set "tab:" subentry,
        then that should be used to display hard tabs. To display them as
        spasces, use for instance

        :set list listchars=tab:\ \ ,eol:$

        (two backslash-escaped spaces: see :help option-backslash ).

        In both cases, the backspace ought to work properly...

        What does Vim answer to

        :verbose set list? listchars? lazyredraw?
        :if !has('gui_running') | verbose set t_kb? t_kD? | endif

        and what appears if (in Insert or Command-line mode) you hit Ctrl-V (or
        Ctrl-Q if you use Ctrl-V to paste into Vim) followed by Backspace?


        Best regards,
        Tony.
        --
        Eternal nothingness is fine if you happen to be dressed for it.
        -- Woody Allen

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • itx
        thanks for help. What does Vim answer to ... and what appears if (in Insert or Command-line mode) you hit Ctrl- V (or Ctrl-Q if you use Ctrl-V to paste into
        Message 3 of 7 , Nov 2, 2010
          thanks for help.

          What does Vim answer to

          :verbose set list? listchars? lazyredraw?
          :if !has('gui_running') | verbose set t_kb? t_kD? | endif

          and what appears if (in Insert or Command-line mode) you hit Ctrl-
          V (or Ctrl-Q if you use Ctrl-V to paste into Vim) followed by
          Backspace?


          :verbose set list? listchars? lazyredraw?
          set list listchars=eol:$ nolazyredraw


          if !has('gui_running') | verbose set t_kb? t_kD? |endif
          t_kb? <BS> t_kD? <DEL>

          Ctrl-Q followed by Backspace <BS>

          :set backspace? backspace=indent,start,eol
          this seems that all these options were default ?



          but it seems that the backspace didn't work properly when i ": set
          list" (i didn't change "listchars")

          for instance
          i type FOUR hardtabs in a new line
          it appears as "^I^I^I^I" and then i just type ONE <BS>, these four
          tabs were deleted....

          but when i :set listchars=tab:\ \ or someothers or ":set nolist" it
          works properly just as i wanted,i.e. these tabs were deleted after i
          type FOUR <BS>

          o, i think that maybe <BS> just delete the display "tabstop"
          characters a time.
          thus it will delete 8 chars and "^I^I^I^I" is 8 chars,so it was
          deleted........
          or other reasons?

          Best regards
          itx

          On 11月2日, 上午3时34分, Tony Mechelynck <antoine.mechely...@...>
          wrote:
          > On 01/11/10 17:08, itx wrote:
          >
          > > when i set list and then type four tab in a newline like
          >
          > > \t\t\t\t
          > > when i "set list" , i type backspce for juse one time
          > > this four tabs were delete ,
          >
          > > but when i "set nolist" ,i works well
          > > why
          >
          > > my settings
          >
          > > set tabstop=8
          > > set noexpandtab
          > > set backspace=indent,eol,start
          >
          > If you ":set list", and 'listchars' is unset, every hard tab you type
          > should appeat as ^I
          >
          > If you ":set list", and 'listchars' has a properly set "tab:" subentry,
          > then that should be used to display hard tabs. To display them as
          > spasces, use for instance
          >
          > :set list listchars=tab:\ \ ,eol:$
          >
          > (two backslash-escaped spaces: see :help option-backslash ).
          >
          > In both cases, the backspace ought to work properly...
          >
          > What does Vim answer to
          >
          > :verbose set list? listchars? lazyredraw?
          > :if !has('gui_running') | verbose set t_kb? t_kD? | endif
          >
          > and what appears if (in Insert or Command-line mode) you hit Ctrl-V (or
          > Ctrl-Q if you use Ctrl-V to paste into Vim) followed by Backspace?
          >
          > Best regards,
          > Tony.
          > --
          > Eternal nothingness is fine if you happen to be dressed for it.
          > -- Woody Allen

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Tony Mechelynck
          ... I don t know: I couldn t reproduce your symptoms (in gvim with GTK2 GUI on Linux). - What platform are you using? Windows? Mac? Linux? Other(which)? - You
          Message 4 of 7 , Nov 2, 2010
            On 02/11/10 18:39, itx wrote:
            > thanks for help.
            >
            > What does Vim answer to
            >
            > :verbose set list? listchars? lazyredraw?
            > :if !has('gui_running') | verbose set t_kb? t_kD? | endif
            >
            > and what appears if (in Insert or Command-line mode) you hit Ctrl-
            > V (or Ctrl-Q if you use Ctrl-V to paste into Vim) followed by
            > Backspace?
            >
            >
            > :verbose set list? listchars? lazyredraw?
            > set list listchars=eol:$ nolazyredraw
            >
            >
            > if !has('gui_running') | verbose set t_kb? t_kD? |endif
            > t_kb?<BS> t_kD?<DEL>
            >
            > Ctrl-Q followed by Backspace<BS>
            >
            > :set backspace? backspace=indent,start,eol
            > this seems that all these options were default ?
            >
            >
            >
            > but it seems that the backspace didn't work properly when i ": set
            > list" (i didn't change "listchars")
            >
            > for instance
            > i type FOUR hardtabs in a new line
            > it appears as "^I^I^I^I" and then i just type ONE<BS>, these four
            > tabs were deleted....
            >
            > but when i :set listchars=tab:\ \ or someothers or ":set nolist" it
            > works properly just as i wanted,i.e. these tabs were deleted after i
            > type FOUR<BS>
            >
            > o, i think that maybe<BS> just delete the display "tabstop"
            > characters a time.
            > thus it will delete 8 chars and "^I^I^I^I" is 8 chars,so it was
            > deleted........
            > or other reasons?
            >
            > Best regards
            > itx

            I don't know: I couldn't reproduce your symptoms (in gvim with GTK2 GUI
            on Linux).
            - What platform are you using? Windows? Mac? Linux? Other(which)?
            - You seem to be using Console Vim: in which terminal? Windows console?
            Mac Terminal.app? Linux(text)? xterm? konsole? mlterm? gnome-terminal?
            other(which)?

            Best regards,
            Tony.
            --
            If you explain so clearly that nobody can misunderstand, somebody
            will.

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • lingkun
            2010/11/3 Tony Mechelynck ... sorry for that i forgot to list the settings when i do the test. ... er, I was using gvim 7.2(
            Message 5 of 7 , Nov 2, 2010
              2010/11/3 Tony Mechelynck <antoine.mechelynck@...>
              On 02/11/10 18:39, itx wrote:
              thanks for help.


                  What does Vim answer to

                         :verbose set list? listchars? lazyredraw?
                         :if !has('gui_running') | verbose set t_kb? t_kD? | endif

                  and what appears if (in Insert or Command-line mode) you hit Ctrl-
              V (or Ctrl-Q if you use Ctrl-V to paste into Vim) followed by
              Backspace?


              :verbose set list? listchars? lazyredraw?
              set list listchars=eol:$ nolazyredraw


              if !has('gui_running') | verbose set t_kb? t_kD? |endif
              t_kb?<BS>     t_kD?<DEL>

              Ctrl-Q followed by Backspace<BS>

              :set backspace? backspace=indent,start,eol
              this seems that all these options were default ?



              but it seems that the backspace didn't  work properly  when i  ": set

              list"  (i didn't change "listchars")

              for instance
              i type FOUR hardtabs in a new line
              it appears as "^I^I^I^I"  and  then i just type ONE<BS>, these four
              tabs were deleted....

              but when i :set listchars=tab:\ \ or someothers or ":set nolist"  it
              works properly just as i wanted,i.e. these tabs were deleted after i
              type FOUR<BS>

              o, i think that maybe<BS>  just delete the display "tabstop"
              characters a time.
              thus it will delete 8 chars and "^I^I^I^I" is 8 chars,so it was
              deleted........
              or other reasons?

              Best regards
              itx

              I don't know: I couldn't reproduce your symptoms (in gvim with GTK2 GUI on Linux).
              - What platform are you using? Windows? Mac? Linux? Other(which)?
              - You seem to be using Console Vim: in which terminal? Windows console? Mac Terminal.app? Linux(text)? xterm? konsole? mlterm? gnome-terminal? other(which)?

              Best regards,
              Tony.
              --
              If you explain so clearly that nobody can misunderstand, somebody
              will.
              sorry for that i forgot to list the settings when i do the test.
                 :set ts=8
                 :set sts=8
                 :set noet
              er, I was using gvim 7.2( offical version ) on windowsXP . To get the settings of "t_kb" and "t_kD", i run vim in the windows console, and they all have the same symptoms.

              Best regards,
              itx.

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • Tony Mechelynck
              On 03/11/10 05:39, lingkun wrote: [...] ... Hm, 7.2 (and presumably 7.2.0) is already, shall we say, somewhat dated. You ll find a Windows installer for (as of
              Message 6 of 7 , Nov 3, 2010
                On 03/11/10 05:39, lingkun wrote:
                [...]
                > sorry for that i forgot to list the settings when i do the test.
                > :set ts=8
                > :set sts=8
                > :set noet
                > er, I was using gvim 7.2( offical version ) on windowsXP . To get the
                > settings of "t_kb" and "t_kD", i run vim in the windows console, and
                > they all have the same symptoms.
                >
                > Best regards,
                > itx.
                >

                Hm, 7.2 (and presumably 7.2.0) is already, shall we say, somewhat dated.
                You'll find a Windows installer for (as of this writing) 7.3.047 (the
                latest bugfixed version) at http://sourceforge.net/projects/cream/files/
                (You can see the compilation options --the ":version" listing-- before
                downloading by viewing the "Release Notes" by clickjing the
                clipboard-like icon in the right column under "Newest files".)

                Can you try this, and let us know if you still have the problem?


                Best regards,
                Tony.
                --
                When in doubt, use brute force.
                -- Ken Thompson

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • lingkun
                2010/11/3 Tony Mechelynck ... er, i have just download and install gvim 7.3.047 and test, it s still the same. i found that
                Message 7 of 7 , Nov 3, 2010
                  2010/11/3 Tony Mechelynck <antoine.mechelynck@...>
                  On 03/11/10 05:39, lingkun wrote:
                  [...]

                  sorry for that i forgot to list the settings when i do the test.
                     :set ts=8
                     :set sts=8
                     :set noet
                  er, I was using gvim 7.2( offical version ) on windowsXP . To get the
                  settings of "t_kb" and "t_kD", i run vim in the windows console, and
                  they all have the same symptoms.

                  Best regards,
                  itx.


                  Hm, 7.2 (and presumably 7.2.0) is already, shall we say, somewhat dated. You'll find a Windows installer for (as of this writing) 7.3.047 (the latest bugfixed version) at http://sourceforge.net/projects/cream/files/ (You can see the compilation options --the ":version" listing-- before downloading by viewing the "Release Notes" by clickjing the clipboard-like icon in the right column under "Newest files".)

                  Can you try this, and let us know if you still have the problem?


                  Best regards,
                  Tony.
                  --
                  When in doubt, use brute force.
                                 -- Ken Thompson

                  er, i have just download  and  install gvim 7.3.047  and test, it's  still the same.


                   i found that when i set softtabstop to 0 (which is the default setting) ,it works properly
                  in 7.2 and 7.3.047, but when sts was setted to a nonzero number , set list and don't change the default listchars,a <BS>seems to  delete softtabstop  number of the display characters(in both 7.2 and 7.3.047).

                  i.e. when set softtabstop=8 ,"^I^I^I^I"(four hard stop ) was deleted by ONE <BS>, when  i set softtabstop=4 "^I^I^I^I"( four hard stop ) was deleted by TWO <BS>, when i set softtabstop=3 "^I^I^I"(three hard tab stop )was deleted by TWO <BS> ,etc. 

                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                Your message has been successfully submitted and would be delivered to recipients shortly.