Loading ...
Sorry, an error occurred while loading the content.
 

Re: vim 7.1 vs. vim 7.2 multi line commenting

Expand Messages
  • Gary Johnson
    ... My guess is that the formatoptions setting is different between the two installations of Vim. Try executing ... and see if that fixes the problem. If I
    Message 1 of 5 , Sep 1, 2010
      On 2010-08-31, Pavan Savoy wrote:
      > Hi,
      >
      > In vim 7.1 I remember there was this feature where as soon as I type
      > /* the next * on the next line was automatically printed, where is
      > this feature now?
      > I have all the same .vimrc from 7.1, and same packages, but it doesn't
      > seem to be working :(

      My guess is that the 'formatoptions' setting is different between
      the two installations of Vim. Try executing

      :set fo+=r

      and see if that fixes the problem.

      If I start vim as

      $ vim -N -u NONE -c 'fo+=r'

      it works for me.

      Regards,
      Gary

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Pavan Savoy
      ... Thanks Gary, That works for me... Cool, Now I have what I had in 7.1 does seem a strange difference ... -- You received this message from the vim_use
      Message 2 of 5 , Sep 1, 2010
        On Wed, Sep 1, 2010 at 11:07 AM, Gary Johnson <garyjohn@...> wrote:
        > On 2010-08-31, Pavan Savoy wrote:
        >> Hi,
        >>
        >> In vim 7.1 I remember there was this feature where as soon as I type
        >> /* the next * on the next line was automatically printed, where is
        >> this feature now?
        >> I have all the same .vimrc from 7.1, and same packages, but it doesn't
        >> seem to be working :(
        >
        > My guess is that the 'formatoptions' setting is different between
        > the two installations of Vim.  Try executing
        >
        >    :set fo+=r
        >
        > and see if that fixes the problem.
        >
        > If I start vim as
        >
        >    $ vim -N -u NONE -c 'fo+=r'
        >
        > it works for me.

        Thanks Gary,
        That works for me... Cool, Now I have what I had in 7.1

        does seem a strange difference

        > Regards,
        > Gary
        >
        > --
        > You received this message from the "vim_use" maillist.
        > Do not top-post! Type your reply below the text you are replying to.
        > For more information, visit http://www.vim.org/maillist.php
        >

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.