Loading ...
Sorry, an error occurred while loading the content.

Re: vim 7.1 vs. vim 7.2 multi line commenting

Expand Messages
  • Pavan Savoy
    On Tue, Aug 31, 2010 at 10:37 PM, Ivan S. Freitas ... vimrc on 7.1 where auto printing of * after 1st /* works... ... match Todo / s +$/ vimrc on 7.1 where it
    Message 1 of 5 , Sep 1, 2010
    • 0 Attachment
      On Tue, Aug 31, 2010 at 10:37 PM, Ivan S. Freitas
      <ivansichfreitas@...> wrote:
      > On Tue, Aug 31, 2010 at 4:34 PM, Pavan Savoy <pavan_savoy@...> wrote:
      >> Hi,
      >>
      >> In vim 7.1 I remember there was this feature where as soon as I type
      >> /* the next * on the next line was automatically printed, where is
      >> this feature now?
      >> I have all the same .vimrc from 7.1, and same packages, but it doesn't
      >> seem to be working :(
      >
      > Can you paste your .vimrc?
      > AFAIK this is enabled by cindent option (try "set cindent" on the
      > .vimrc). Also, verify if your vim was compiled with the indentation
      > features.

      vimrc on 7.1 where auto printing of * after 1st /* works...
      :syntax on
      :set smartindent
      match Todo /\s\+$/

      vimrc on 7.1 where it doesn't work,
      :syntax enable
      :set smartindent
      match Todo /\s\+$/
      :set background=dark
      :set hlsearch

      I don't have cindent in either of them, but it works on 7.1 beautifully....
      and this is annoying with vim7.2

      >>
      >> Please help.
      >>
      >> --
      >> You received this message from the "vim_use" maillist.
      >> Do not top-post! Type your reply below the text you are replying to.
      >> For more information, visit http://www.vim.org/maillist.php
      >>
      >
      >
      >
      > --
      > ==============================================
      > Ivan Sichmann Freitas
      > Engenharia de Computação 2009
      > UNICAMP
      > http://identi.ca/ivansichmann
      > Grupo Pró Software Livre UNICAMP - GPSL
      > ==============================================
      >
      > --
      > You received this message from the "vim_use" maillist.
      > Do not top-post! Type your reply below the text you are replying to.
      > For more information, visit http://www.vim.org/maillist.php
      >

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Gary Johnson
      ... My guess is that the formatoptions setting is different between the two installations of Vim. Try executing ... and see if that fixes the problem. If I
      Message 2 of 5 , Sep 1, 2010
      • 0 Attachment
        On 2010-08-31, Pavan Savoy wrote:
        > Hi,
        >
        > In vim 7.1 I remember there was this feature where as soon as I type
        > /* the next * on the next line was automatically printed, where is
        > this feature now?
        > I have all the same .vimrc from 7.1, and same packages, but it doesn't
        > seem to be working :(

        My guess is that the 'formatoptions' setting is different between
        the two installations of Vim. Try executing

        :set fo+=r

        and see if that fixes the problem.

        If I start vim as

        $ vim -N -u NONE -c 'fo+=r'

        it works for me.

        Regards,
        Gary

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Pavan Savoy
        ... Thanks Gary, That works for me... Cool, Now I have what I had in 7.1 does seem a strange difference ... -- You received this message from the vim_use
        Message 3 of 5 , Sep 1, 2010
        • 0 Attachment
          On Wed, Sep 1, 2010 at 11:07 AM, Gary Johnson <garyjohn@...> wrote:
          > On 2010-08-31, Pavan Savoy wrote:
          >> Hi,
          >>
          >> In vim 7.1 I remember there was this feature where as soon as I type
          >> /* the next * on the next line was automatically printed, where is
          >> this feature now?
          >> I have all the same .vimrc from 7.1, and same packages, but it doesn't
          >> seem to be working :(
          >
          > My guess is that the 'formatoptions' setting is different between
          > the two installations of Vim.  Try executing
          >
          >    :set fo+=r
          >
          > and see if that fixes the problem.
          >
          > If I start vim as
          >
          >    $ vim -N -u NONE -c 'fo+=r'
          >
          > it works for me.

          Thanks Gary,
          That works for me... Cool, Now I have what I had in 7.1

          does seem a strange difference

          > Regards,
          > Gary
          >
          > --
          > You received this message from the "vim_use" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.