Loading ...
Sorry, an error occurred while loading the content.

rubygems error in ruby 1.9 support for vim 7.3 (on Windows)

Expand Messages
  • talek
    Hi, I ve just downloaded vim 7.3 for windows (I m on Windows XP) which comes with ruby 1.9 support. I also have ruby 1.9.1-p430 installed. If I open an irb
    Message 1 of 1 , Aug 29, 2010
    • 0 Attachment
      Hi,

      I've just downloaded vim 7.3 for windows (I'm on Windows XP) which
      comes with ruby 1.9 support. I also have ruby 1.9.1-p430 installed. If
      I open an irb console and write:

      irb(main):001:0> require 'rubygems'
      => false

      I get false, which is fine because ruby 1.9 already comes with
      rubygems.

      However, if I try the same from vim, I get:

      :ruby require 'rubygems'
      NoMethodError: undefined method `synchronize` for #<Mutex:0x1da8480>

      I know the workaround is just not to require 'rubygems' anymore, but
      this looks strange to me. Any ideas why I get a different behavior
      from within vim? Does anybody have the same problem or is related to
      my configuration only?

      Many thanks.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.