Loading ...
Sorry, an error occurred while loading the content.

How could I show the line by indent as in notepad++?

Expand Messages
  • H Xu
    Hello everyone, In notepad++, when editing c/c++ or java source files, there are vertical lines clearly shows the indent of the file. How could I show the
    Message 1 of 7 , Jul 19 8:32 PM
    • 0 Attachment
      Hello everyone,

      In notepad++, when editing c/c++ or java source files, there are
      vertical lines clearly shows the indent of the file.



      How could I show the lines in vim?

      Regards,
      Hong Xu
      2010/7/20

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... Install Vim 7.3b and use the colorcolumn option. Or do it the hard way, see ... Best regards, Tony. -- You ve been leading a dog s life. Stay off the
      Message 2 of 7 , Jul 19 9:24 PM
      • 0 Attachment
        On 20/07/10 05:32, H Xu wrote:
        > Hello everyone,
        >
        > In notepad++, when editing c/c++ or java source files, there are
        > vertical lines clearly shows the indent of the file.
        >
        >
        >
        > How could I show the lines in vim?
        >
        > Regards,
        > Hong Xu
        > 2010/7/20
        >
        > --
        > You received this message from the "vim_use" maillist.
        > Do not top-post! Type your reply below the text you are replying to.
        > For more information, visit http://www.vim.org/maillist.php

        Install Vim 7.3b and use the 'colorcolumn' option. Or do it the hard
        way, see
        :help :match
        :help :2match
        :help matchadd()
        :help /ordinary-atom


        Best regards,
        Tony.
        --
        You've been leading a dog's life. Stay off the furniture.

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • H Xu
        ... Hello Tony Mechelynck, Thank you, I ll try it. Regards, Hong Xu 2010/7/20 -- You received this message from the vim_use maillist. Do not top-post! Type
        Message 3 of 7 , Jul 19 10:19 PM
        • 0 Attachment
          On 2010/7/20 12:24, Tony Mechelynck wrote:
          > On 20/07/10 05:32, H Xu wrote:
          >> Hello everyone,
          >>
          >> In notepad++, when editing c/c++ or java source files, there are
          >> vertical lines clearly shows the indent of the file.
          >>
          >>
          >>
          >> How could I show the lines in vim?
          >>
          >> Regards,
          >> Hong Xu
          >> 2010/7/20
          >>
          >> --
          >> You received this message from the "vim_use" maillist.
          >> Do not top-post! Type your reply below the text you are replying to.
          >> For more information, visit http://www.vim.org/maillist.php
          >
          > Install Vim 7.3b and use the 'colorcolumn' option. Or do it the hard
          > way, see
          > :help :match
          > :help :2match
          > :help matchadd()
          > :help /ordinary-atom
          >
          >
          > Best regards,
          > Tony.
          Hello Tony Mechelynck,

          Thank you, I'll try it.

          Regards,
          Hong Xu
          2010/7/20

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • H Xu
          ... Hello Tony Mechelynck, colorcolumn option depends on the value of textwidth, and can only highlight one column. Is there any other method? Thank you.
          Message 4 of 7 , Jul 31 11:23 AM
          • 0 Attachment
            On 07/20/2010 12:24 PM, Tony Mechelynck wrote:
            > On 20/07/10 05:32, H Xu wrote:
            >> Hello everyone,
            >>
            >> In notepad++, when editing c/c++ or java source files, there are
            >> vertical lines clearly shows the indent of the file.
            >>
            >>
            >>
            >> How could I show the lines in vim?
            >>
            >> Regards,
            >> Hong Xu
            >> 2010/7/20
            >>
            >> --
            >> You received this message from the "vim_use" maillist.
            >> Do not top-post! Type your reply below the text you are replying to.
            >> For more information, visit http://www.vim.org/maillist.php
            >
            > Install Vim 7.3b and use the 'colorcolumn' option. Or do it the hard
            > way, see
            > :help :match
            > :help :2match
            > :help matchadd()
            > :help /ordinary-atom
            >
            >
            > Best regards,
            > Tony.
            Hello Tony Mechelynck,

            'colorcolumn' option depends on the value of textwidth, and can only
            highlight one
            column. Is there any other method? Thank you.

            Regards,
            Hong Xu
            08/01/2010

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Maxim Kim
            ... try ... -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are replying to. For more
            Message 5 of 7 , Jul 31 1:54 PM
            • 0 Attachment
              > 'colorcolumn' option depends on the value of textwidth, and can only
              > highlight one
              > column. Is there any other method? Thank you.
              >
              try
              :set colorcolumn=4,8,12,16

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • H Xu
              ... Hello, However, this highlight a whole column not part of the column. Is that possible to highlight part of the column? Regards, H Xu 08/01/2010 -- You
              Message 6 of 7 , Jul 31 7:56 PM
              • 0 Attachment
                On 08/01/2010 04:54 AM, Maxim Kim wrote:
                >> 'colorcolumn' option depends on the value of textwidth, and can only
                >> highlight one
                >> column. Is there any other method? Thank you.
                >>
                > try
                > :set colorcolumn=4,8,12,16
                >
                Hello,

                However, this highlight a whole column not part of the column. Is that
                possible to
                highlight part of the column?

                Regards,
                H Xu
                08/01/2010

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Vlad Irnov
                ... See this thread http://groups.google.com/group/vim_use/browse_thread/thread/4781a71696eae6e8 The solution depends on whether you indent with tabs or
                Message 7 of 7 , Aug 1, 2010
                • 0 Attachment
                  On Jul 19, 11:32 pm, H Xu <xusu...@...> wrote:
                  > Hello everyone,
                  >
                  > In notepad++, when editing c/c++ or java source files, there are
                  > vertical lines clearly shows the indent of the file.
                  >
                  > How could I show the lines in vim?
                  >
                  > Regards,
                  > Hong Xu
                  > 2010/7/20

                  See this thread
                  http://groups.google.com/group/vim_use/browse_thread/thread/4781a71696eae6e8
                  The solution depends on whether you indent with tabs or spaces.

                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                Your message has been successfully submitted and would be delivered to recipients shortly.