Loading ...
Sorry, an error occurred while loading the content.

Re: include option

Expand Messages
  • surge
    That worked. To tell you the truth, Google s message format is a bit confusing to me. I never took the time to understand what they are doing. Gmail, though a
    Message 1 of 5 , Jul 1, 2010
    • 0 Attachment
      That worked.

      To tell you the truth, Google's message format is a bit confusing to
      me. I never took the time to understand what they are doing. Gmail,
      though a nice app, confuses the heck out of me. I hope I did the
      comments right. Let me know if not.

      Thanks for the tips -- bit time!

      On Jul 1, 3:05 pm, Gary Johnson <garyj...@...> wrote:
      > On 2010-07-01, surge wrote:
      > > On Jul 1, 12:40 pm, Gary Johnson <garyj...@...> wrote:
      > > > On 2010-07-01, surge wrote:
      > > > > I'm trying to make vim look inside php include files. A php include
      > > > > statement can be:
      >
      > > > > include 'file.php'
      >
      > > > > OR
      >
      > > > > include_once 'file.php'
      >
      > > > > It works if I do:
      >
      > > > > set include=^include
      >
      > > > > OR
      >
      > > > > include=^include_once
      >
      > > > > But I can't seem to do recognize both. This doesn't work:
      >
      > > > > set include=^\(include\|include_once\)
      >
      > > > > Thanks!
      >
      > > > :set include=^\(include\|include_once\)
      > > > :set include?
      > > > include=^(include|include_once)
      >
      > > > Note that your backslashes are no longer there, having been removed
      > > > when ":set include=^\(include\|include_once\)" was executed. Just
      > > > add another level of backslashes to protect those in the argument to
      > > > :set.
      >
      > > > :set include=^\\(include\\|include_once\\)
      > > Just tried it, no luck.
      >
      > > I did: set include=^\\(include_once\\|include\\)
      >
      > > Any idea now?
      >
      > Sorry.  I didn't have any PHP files to test that on.
      >
      > I grep'd through $VIMRUNTIME looking for examples of setting
      > 'include' and found this one in $VIMRUNTIME/ftplugin/php.vim:
      >
      >     setlocal include=\\\(require\\\|include\\\)\\\(_once\\\)\\\?
      >
      > Try that.  Alternatively, you could enable filetype plugins, which
      > would automatically give you that setting plus others you might find
      > useful.  See
      >
      >     :help filetype-plugin-on
      >
      > Also, the convention on this list is to add one's comments to the
      > bottom of a reply, not at the top.
      >
      > Regards,
      > Gary

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.