Loading ...
Sorry, an error occurred while loading the content.

Re: screen not updated after backspace

Expand Messages
  • Jürgen Krämer
    Hi, ... in addition to the compatible option you might want to look at the cpoptions option. If it includes a lower-case v Vim behaves the way you
    Message 1 of 7 , Jun 30, 2010
    • 0 Attachment
      Hi,

      Sven Eppler wrote:
      >
      > since about a week on my server vim behaves strange. The backspace-key
      > is working correctly beside the fact, that the deleted characters are
      > not removed from the screen. Only when leaving insert-mode or switch
      > lines the screen will get updated and the deleted characters will
      > vanish from the screen.
      >
      > e.g.: when backspacing 5 characters and typing 4 new, the newly typed
      > chars will be shown correctly, but the first backspaced char will stay
      > again until i leave the insert-mode or navigate into another line.

      in addition to the 'compatible' option you might want to look at the
      'cpoptions' option. If it includes a lower-case 'v' Vim behaves the
      way you noticed (:help cpo-v).

      Regards,
      Jürgen

      --
      Sometimes I think the surest sign that intelligent life exists elsewhere
      in the universe is that none of it has tried to contact us. (Calvin)

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Andrei Popescu
      ... Etch doesn t have security support anymore, you should upgrade to Lenny. ... If you stay on Etch and want to try a newer version there is a backport of
      Message 2 of 7 , Jul 1, 2010
      • 0 Attachment
        On Mi, 30 iun 10, 12:34:21, Sven Eppler wrote:

        > Debian Etch, 64bit

        Etch doesn't have security support anymore, you should upgrade to Lenny.

        > Vim 7.0.305

        If you stay on Etch and want to try a newer version there is a backport
        of 7.1.314 (the same version as in Lenny) at www.backports.org.

        Regards,
        Andrei
        --
        If you can't explain it simply, you don't understand it well enough.
        (Albert Einstein)
      • Sven Eppler
        Hi, ... cpoptions=aAbBcCdDeEfFgHiIjJkKlLmMnoOpPqrRsStuvwWxXyZ$!%*-+ I only get the hind, that /usr/share/vim/vim70/plugin/zipPlugin.vim last changed this
        Message 3 of 7 , Jul 1, 2010
        • 0 Attachment
          Hi,

          this looks like the Problem:

          :verbose set cpo?
          cpoptions=aAbBcCdDeEfFgHiIjJkKlLmMnoOpPqrRsStuvwWxXyZ$!%*-+<>

          I only get the hind, that '/usr/share/vim/vim70/plugin/zipPlugin.vim'
          last changed this setting. But is there a way to debug more precisly
          when all this stuff is comming into the variable? Temporaly i
          overwrite cpo with the Vim-Default in my .vimrc which works just fine
          now.

          Thanks,
          Sven

          On 1 Jul., 07:35, Jürgen Krämer <jottka...@...> wrote:
          > Hi,
          >
          > Sven Eppler wrote:
          >
          > > since about a week on my server vim behaves strange. The backspace-key
          > > is working correctly beside the fact, that the deleted characters are
          > > not removed from the screen. Only when leaving insert-mode or switch
          > > lines the screen will get updated and the deleted characters will
          > > vanish from the screen.
          >
          > > e.g.: when backspacing 5 characters and typing 4 new, the newly typed
          > > chars will be shown correctly, but the first backspaced char will stay
          > > again until i leave the insert-mode or navigate into another line.
          >
          > in addition to the 'compatible' option you might want to look at the
          > 'cpoptions' option. If it includes a lower-case 'v' Vim behaves the
          > way you noticed (:help cpo-v).
          >
          > Regards,
          > J rgen
          >
          > --
          > Sometimes I think the surest sign that intelligent life exists elsewhere
          > in the universe is that none of it has tried to contact us.     (Calvin)

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Sven Eppler
          I know, but it s an virtual server on which currently lenny isn t supported by the hoster. But i will have a look at the backports or try to build my own vim.
          Message 4 of 7 , Jul 1, 2010
          • 0 Attachment
            I know, but it's an virtual server on which currently lenny isn't
            supported by the hoster.

            But i will have a look at the backports or try to build my own vim. :)

            Bye,
            Sven

            On 1 Jul., 09:46, Andrei Popescu <andreimpope...@...> wrote:
            > On Mi, 30 iun 10, 12:34:21, Sven Eppler wrote:
            >
            > > Debian Etch, 64bit
            >
            > Etch doesn't have security support anymore, you should upgrade to Lenny.
            >
            > > Vim 7.0.305
            >
            > If you stay on Etch and want to try a newer version there is a backport
            > of 7.1.314 (the same version as in Lenny) atwww.backports.org.
            >
            > Regards,
            > Andrei
            > --
            > If you can't explain it simply, you don't understand it well enough.
            > (Albert Einstein)
            >
            >  signature.asc
            > < 1 KBAnzeigenHerunterladen

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • Tony Mechelynck
            ... It looks like you have (or had) compatible set. Are you sure your vimrc is named .vimrc, not .exrc and not $VIM/vimrc without dot? Or that you aren t
            Message 5 of 7 , Jul 7, 2010
            • 0 Attachment
              On 01/07/10 11:53, Sven Eppler wrote:
              > Hi,
              >
              > this looks like the Problem:
              >
              > :verbose set cpo?
              > cpoptions=aAbBcCdDeEfFgHiIjJkKlLmMnoOpPqrRsStuvwWxXyZ$!%*-+<>
              >
              > I only get the hind, that '/usr/share/vim/vim70/plugin/zipPlugin.vim'
              > last changed this setting. But is there a way to debug more precisly
              > when all this stuff is comming into the variable? Temporaly i
              > overwrite cpo with the Vim-Default in my .vimrc which works just fine
              > now.
              >
              > Thanks,
              > Sven
              >

              It looks like you have (or had) 'compatible' set. Are you sure your
              vimrc is named .vimrc, not .exrc and not $VIM/vimrc without dot? Or that
              you aren't loading your vimrc by means of a -u command-line argument? Or
              that you haven't got -C on the Vim command-line? Each of these would
              defeat Vim's custom of setting 'nocompatible' when a vimrc is found.

              The above setting is, I think, the 'compatible' default for the
              'cpoptions' options. Its 'nocompatible' setting is much shorter: aABceFs

              See
              :help compatible-default
              :help 'compatible'
              :help 'cpoptions'
              :help -C
              :help -N
              :help -u
              :help .vimrc


              Best regards,
              Tony.
              --
              TIM: That is not an ordinary rabbit ... 'tis the most foul cruel and
              bad-tempered thing you ever set eyes on.
              ROBIN: You tit. I soiled my armour I was so scared!
              "Monty Python and the Holy Grail" PYTHON (MONTY)
              PICTURES LTD

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            Your message has been successfully submitted and would be delivered to recipients shortly.