Loading ...
Sorry, an error occurred while loading the content.

what is the command to set the 'omnifunc' option.

Expand Messages
  • aleCodd
    how do i set the omnifunc, w/o manually writing an autocommand for filetype event etc. is there a built-in command for that? because it used to work
    Message 1 of 3 , Jun 21, 2010
    • 0 Attachment
      how do i set the omnifunc, w/o manually writing an autocommand for filetype
      event etc.

      is there a built-in command for that?
      because it used to work automatically, or so I remember.

      Thanks
      Alex
      --
      View this message in context: http://old.nabble.com/what-is-the-command-to-set-the-%27omnifunc%27-option.-tp28955321p28955321.html
      Sent from the Vim - General mailing list archive at Nabble.com.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • David Fishburn
      ... vim72 ftplugin sql.vim Line 369: ... setlocal omnifunc=sqlcomplete#Complete ... Those should be setup automatically via filetype plugins. Make sure you
      Message 2 of 3 , Jun 21, 2010
      • 0 Attachment
        On 21/06/2010 9:45 PM, aleCodd wrote:
        how do i set the omnifunc, w/o manually writing an autocommand for filetype
        event etc.
          

        vim72\ftplugin\sql.vim

        Line 369:
        ...
            setlocal omnifunc=sqlcomplete#Complete


        is there a built-in command for that?
        because it used to work automatically, or so I remember.
          
        Those should be setup automatically via filetype plugins.
        Make sure you have the following in your vimrc:
        filetype plugin on

        HTH,
        Dave

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • aleCodd
        ... yeah, that exactly was the problem. thanks so much Alex -- View this message in context:
        Message 3 of 3 , Jun 21, 2010
        • 0 Attachment
          David Fishburn-2 wrote:
          >
          > Make sure you have the following in your vimrc:
          > filetype plugin on
          >
          >
          yeah, that exactly was the problem.
          thanks so much
          Alex

          --
          View this message in context: http://old.nabble.com/what-is-the-command-to-set-the-%27omnifunc%27-option.-tp28955321p28955412.html
          Sent from the Vim - General mailing list archive at Nabble.com.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.