Loading ...
Sorry, an error occurred while loading the content.

minibufferexplorer: opening files

Expand Messages
  • Renato
    Hello, I m quite new to vim and still finding my way around... I installed the minibufferexplorer plugin and I can navigate through tabs, however: if I haven t
    Message 1 of 3 , Jun 9, 2010
    • 0 Attachment
      Hello, I'm quite new to vim and still finding my way around... I
      installed the minibufferexplorer plugin and I can navigate through
      tabs, however: if I haven't saved the current file and I give the
      command :o newfile or :edit newfile or :e newfile, it won't open
      newfile, because I haven't saved the current file. How can I open
      newfile without having to save the current one?

      my relevant section of .vimrc (I copied it from some tutorial
      sometime ago):

      "miniBufferExplorer
      map <Leader>t :TMiniBufExplorer<cr>
      let g:miniBufExplMapWindowNavVim = 1
      let g:miniBufExplMapWindowNavArrows = 1
      let g:miniBufExplMapCTabSwitchBufs = 1
      let g:miniBufExplModSelTarget = 1
      set showtabline=2 " always show the tab-line
      let g:miniBufExplUseSingleClick = 1

      thanks for any help
      renato

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • John Beckett
      ... Search for the hidden option at: http://vim.wikia.com/wiki/Easier_buffer_switching John -- You received this message from the vim_use maillist. Do not
      Message 2 of 3 , Jun 9, 2010
      • 0 Attachment
        Renato wrote:
        > Hello, I'm quite new to vim and still finding my way
        > around... I installed the minibufferexplorer plugin and I can
        > navigate through tabs, however: if I haven't saved the
        > current file and I give the command :o newfile or :edit
        > newfile or :e newfile, it won't open newfile, because I
        > haven't saved the current file. How can I open newfile
        > without having to save the current one?

        Search for the 'hidden' option at:
        http://vim.wikia.com/wiki/Easier_buffer_switching

        John

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • Renato
        On Wed, 9 Jun 2010 21:35:58 +1000 ... thanks man :) renato -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the
        Message 3 of 3 , Jun 9, 2010
        • 0 Attachment
          On Wed, 9 Jun 2010 21:35:58 +1000
          "John Beckett" <johnb.beckett@...> wrote:

          > Renato wrote:
          > > Hello, I'm quite new to vim and still finding my way
          > > around... I installed the minibufferexplorer plugin and I can
          > > navigate through tabs, however: if I haven't saved the
          > > current file and I give the command :o newfile or :edit
          > > newfile or :e newfile, it won't open newfile, because I
          > > haven't saved the current file. How can I open newfile
          > > without having to save the current one?
          >
          > Search for the 'hidden' option at:
          > http://vim.wikia.com/wiki/Easier_buffer_switching
          >
          > John
          >

          thanks man :)

          renato

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.