Loading ...
Sorry, an error occurred while loading the content.

Vim 7.2 for windows randomly switches between REPLACE and INSERT mode on minimize-restore Vim window

Expand Messages
  • baza
    Hello. The main idea is described in message subject. I m using Vim 7.2 with win xp. When I minimize Vim window to the task bar and then restore it - sometimes
    Message 1 of 4 , Jun 8, 2010
    • 0 Attachment
      Hello.

      The main idea is described in message subject.
      I'm using Vim 7.2 with win xp.
      When I minimize Vim window to the task bar and then restore it - sometimes
      it happents that modes switches between themselves. --INSERT-- to
      --REPLACE-- or vice versa.
      Interesting that it happens absolutely randomly. Maybe yes maybe no. And I
      never know which mode will be.

      I did not find any information regarding this issue.
      Thanks.
      --
      View this message in context: http://old.nabble.com/Vim-7.2-for-windows-randomly-switches-between-REPLACE-and-INSERT-mode-on-minimize-restore-Vim-window-tp28815686p28815686.html
      Sent from the Vim - General mailing list archive at Nabble.com.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Tony Mechelynck
      ... Toggling between Insert and Replace is the function of the key. Are you sure you don t hit it, maybe unintentionally, just before minimizing Vim,
      Message 2 of 4 , Jun 8, 2010
      • 0 Attachment
        On 08/06/10 11:36, baza wrote:
        >
        > Hello.
        >
        > The main idea is described in message subject.
        > I'm using Vim 7.2 with win xp.
        > When I minimize Vim window to the task bar and then restore it - sometimes
        > it happents that modes switches between themselves. --INSERT-- to
        > --REPLACE-- or vice versa.
        > Interesting that it happens absolutely randomly. Maybe yes maybe no. And I
        > never know which mode will be.
        >
        > I did not find any information regarding this issue.
        > Thanks.

        Toggling between Insert and Replace is the function of the <Insert> key.
        Are you sure you don't hit it, maybe unintentionally, just before
        minimizing Vim, or just after waking it up?

        You can disable the <Insert> key by adding the following to your vimrc:

        :map <Insert> <Nop>
        :map! <Insert> <Nop>

        or maybe you'll prefer to use :imap instead of :map! if you want to
        retain the ability to toggle between insert and overstrike on the Vim
        command-line.

        To minimize Vim, you can use :sus[pend], :st[op] or even Ctrl-Z (the
        latter, which requires no <Enter>, should be far enough from the
        <Insert> key).

        See
        :help <Insert>
        :help i_<Insert>
        :help c_<Insert>
        :help map.txt
        :help suspend


        Best regards,
        Tony.
        --
        Hatred, n.:
        A sentiment appropriate to the occasion of another's
        superiority.
        -- Ambrose Bierce, "The Devil's Dictionary"

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • baza
        Thanks for your answer. I can state :st :sus and restoring Vim window after them really do not chage mode. It switches between modes only if I use standart MS
        Message 3 of 4 , Jun 9, 2010
        • 0 Attachment
          Thanks for your answer.
          I can state :st :sus and restoring Vim window after them really do not chage
          mode.
          It switches between modes only if I use standart MS Windows minimization ui
          functions.



          Tony Mechelynck-2 wrote:
          >
          >
          > Toggling between Insert and Replace is the function of the <Insert> key.
          > Are you sure you don't hit it, maybe unintentionally, just before
          > minimizing Vim, or just after waking it up?
          >
          > You can disable the <Insert> key by adding the following to your vimrc:
          >
          > :map <Insert> <Nop>
          > :map! <Insert> <Nop>
          >
          > or maybe you'll prefer to use :imap instead of :map! if you want to
          > retain the ability to toggle between insert and overstrike on the Vim
          > command-line.
          >
          > To minimize Vim, you can use :sus[pend], :st[op] or even Ctrl-Z (the
          > latter, which requires no <Enter>, should be far enough from the
          > <Insert> key).
          >
          > See
          > :help <Insert>
          > :help i_<Insert>
          > :help c_<Insert>
          > :help map.txt
          > :help suspend
          >
          >
          > Best regards,
          > Tony.
          > --
          > Hatred, n.:
          > A sentiment appropriate to the occasion of another's
          > superiority.
          > -- Ambrose Bierce, "The Devil's Dictionary"
          >
          > --
          > You received this message from the "vim_use" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >
          >

          --
          View this message in context: http://old.nabble.com/Vim-7.2-for-windows-randomly-switches-between-REPLACE-and-INSERT-mode-on-minimize-restore-Vim-window-tp28815686p28826606.html
          Sent from the Vim - General mailing list archive at Nabble.com.

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Tony Mechelynck
          ... Well, I don t know wheree your problem comes from them (unless you really hit by mistake sometimes): I m on Linux now, and my gvim doesn t
          Message 4 of 4 , Jun 9, 2010
          • 0 Attachment
            On 09/06/10 09:28, baza wrote:
            >
            > Thanks for your answer.
            > I can state :st :sus and restoring Vim window after them really do not chage
            > mode.
            > It switches between modes only if I use standart MS Windows minimization ui
            > functions.

            Well, I don't know wheree your problem comes from them (unless you
            really hit <Insert> by mistake sometimes): I'm on Linux now, and my gvim
            doesn't spontaneously switch between --INSERT-- and --REPLACE--, even
            when I minimize it by mouse-clicking the _ icon near top right and
            maximize it back by clicking the <Vim> icon on the taskbar.

            Anyone else?


            Best regards,
            Tony.
            --
            "Irrationality is the square root of all evil"
            -- Douglas Hofstadter

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.