Loading ...
Sorry, an error occurred while loading the content.

Re: Formatting help files

Expand Messages
  • Stahlman Family
    Pablo Giménez wrote: ... Pablo, I think I understand what s going on... If I m correct, you are unable to hide the special characters because your terminal s
    Message 1 of 32 , Jun 1, 2010
    • 0 Attachment
      Pablo Giménez wrote:
      ...[snip]...

      >> Pablo,
      >> Thanks for the screenshot. I'll check into it tonight when I have
      >> access to a real terminal on my Linux system at home. Do you mind
      >> telling me what colorscheme and terminal you're using? Also, what type
      >> of region is being applied to the text with the grey background (e.g.,
      >> "TDVIM USER MANUAL")? (I'm guessing it's bold-italic, and you're using
      >> a color terminal that doesn't really support italic, but displays it
      >> as reverse video instead...)
      >>
      > Probably is this, because I was wondering why the italics doesn´t appear in
      > the terminal.
      > Yep it is trying to use bold italics.
      > The color scheme is CodeFactory:
      > http://www.vim.org/scripts/script.php?script_id=3079

      Pablo,
      I think I understand what's going on... If I'm correct, you are unable
      to hide the special characters because your terminal's default
      background color is black, but its "color palette" doesn't contain
      black. Note that in addition to the default "Text color" and "Background
      color", color terminals have what is known as a "Color palette". The
      colors in the color palette (also known as the color cube) are
      completely independent of the Text color and Background color. Vim's
      ctermfg/ctermbg mechanism works properly only for colors in the color
      palette: thus, setting ctermbg or ctermfg to the default Background
      color won't work unless the default Background color happens to be in
      the color palette. In other words, the workarounds will work only if the
      default background color is in the color palette.

      I don't know what color terminal you're using, but I was able to
      reproduce what you were seeing in gnome-terminal. I was able to fix it
      by changing to a color palette that contained black...

      On the gnome-terminal title bar...

      Edit->Profile Preferences...

      ...brings up a dialog with multiple tabs. On the "Colors" tab, you can
      define the default foreground and background colors with the "Text
      color" and "Background color" color pickers. Under "Palette", there's a
      combo box that allows you to select from a number of built-in schemes. I
      was originally using "Tango", which had a couple different shades of
      grey, but no black. The others (Linux console, XTerm and Rxvt) all had
      black as the first color in the palette. After I had switched to "Linux
      console", the workarounds were successful...

      Sincerely,
      Brett Stahlman

      >
      ...[snip]...

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Brett Stahlman
      ... No problem. Glad to hear it works for you. Looks like you ve come up with a good approach. Let me know if you have any other issues... Sincerely, Brett
      Message 32 of 32 , Jun 9, 2010
      • 0 Attachment
        On Jun 8, 9:33 am, Pablo Giménez <pablog...@...> wrote:
        > Perfecto working liek a  charm.
        > Thanks
        > I have put this in my after/ftplugin/txtfmt.vim
        >
        > " Disable txtfmt formating if we aren't in gui mode
        > if !has("gui_running")
        >     call tdvim#StripTxtfmtTokens("help")
        > endif
        >
        > " Enable refresh if coor scheme changes:
        > autocmd ColorScheme <buffer> :Refresh
        >
        > Which seems to work nice.
        > Thansk for your help!

        No problem. Glad to hear it works for you. Looks like you've come up
        with a good approach. Let me know if you have any other issues...

        Sincerely,
        Brett Stahlman

        ...[snip]...

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.