Loading ...
Sorry, an error occurred while loading the content.

making netrw buffers buflisted

Expand Messages
  • Britton Kerin
    I would like netrw buffers to be buflisted, so that they show up in the various buffer selecting interfaces. I ve tried to achieve this using autocommands like
    Message 1 of 2 , May 7, 2010
    • 0 Attachment

      I would like netrw buffers to be buflisted, so that they show up in the
      various buffer selecting interfaces.

      I've tried to achieve this using autocommands like this:

       au BufNew * if &ft == "netrw" | set buflisted | endif

      But without success.  This above autocommand doesn't go off,
      others that I've tried go off (verified by putting an echom instead of
      set buflisted command), but then buflisted still ends up turned off
      presumably because this happens later than the autocommand hook.

      Anyone have a correct event or other recipe to achieve this?

      Thanks,
      Britton

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Charles Campbell
      ... Hello! Try putting let g:netrw_bufsettings = noma nomod nonu nowrap ro into your .vimrc . (the default value has nobl, too) Regards, C Campbell -- --
      Message 2 of 2 , Apr 29, 2013
      • 0 Attachment
        Britton Kerin wrote:
        >
        > I would like netrw buffers to be buflisted, so that they show up in the
        > various buffer selecting interfaces.
        >
        > I've tried to achieve this using autocommands like this:
        >
        > au BufNew * if &ft == "netrw" | set buflisted | endif
        >
        > But without success. This above autocommand doesn't go off,
        > others that I've tried go off (verified by putting an echom instead of
        > set buflisted command), but then buflisted still ends up turned off
        > presumably because this happens later than the autocommand hook.
        >
        > Anyone have a correct event or other recipe to achieve this?
        Hello!

        Try putting

        let g:netrw_bufsettings = "noma nomod nonu nowrap ro"

        into your .vimrc . (the default value has nobl, too)

        Regards,
        C Campbell


        --
        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php

        ---
        You received this message because you are subscribed to the Google Groups "vim_use" group.
        To unsubscribe from this group and stop receiving emails from it, send an email to vim_use+unsubscribe@....
        For more options, visit https://groups.google.com/groups/opt_out.
      Your message has been successfully submitted and would be delivered to recipients shortly.