Loading ...
Sorry, an error occurred while loading the content.

Re: Backups not created

Expand Messages
  • Gary Johnson
    ... From within Vim, ... From the shell command line, vim --version :help backupskip says, {not available when compiled without the |+wildignore| feature}
    Message 1 of 7 , May 1, 2010
    • 0 Attachment
      On 2010-05-01, Ritmo2k wrote:
      > > On May 1, 3:10 pm, Ritmo2k <jcas...@...> wrote:
      > >
      > > > no backups are made in /tmp? How do you control this?
      > >
      > > The 'backupskip' option; the default value includes /tmp/*.
      > >
      > > Please excuse me if I'm wrong, but you seem unaware how good vim's
      > > help is.  Mucking around with the whatever option, it's a good idea to
      > > try
      > >
      > > :help 'whatever
      > >
      > > (that's a single quote).  :help 'backup tells about backupskip, and
      > > hyper-links to it.
      > >
      > > Regards, John
      >
      > You're right, but my :set _does not_ indicate this value set, so
      > when I looked through it to read up on the options, obviously I
      > didn't see this & never looked into it. Reading :help backup
      > suggests its activated by a pattern, but as its not defined in
      > :set or :let and neither my /etc/ vimrc or /etc/virc or ~/.vimrc
      > contain it, I am wondering how its getting set?
      > Are there ways to compile defaults into vim? If so how does one
      > display these build time options?

      From within Vim,

      :version

      From the shell command line,

      vim --version

      ":help backupskip" says,

      {not available when compiled without the |+wildignore| feature}

      Maybe one of your Vims was compiled without the +wildignore feature
      and the other was compiled with it.

      See also

      :help :version

      Regards,
      Gary

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Ritmo2k
      ... Ahh, so if not specified, it defaults to exclude the /tmp dirs. adding set backupskip= gets the behavior I wanted. Thanks guys! -- You received this
      Message 2 of 7 , May 1, 2010
      • 0 Attachment
        > ":help backupskip" says,
        >
        >     {not available when compiled without the |+wildignore| feature}

        Ahh, so if not specified, it defaults to exclude the /tmp dirs.
        adding 'set backupskip=' gets the behavior I wanted.

        Thanks guys!

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      Your message has been successfully submitted and would be delivered to recipients shortly.