Loading ...
Sorry, an error occurred while loading the content.
 

vim wired usage issue that need help

Expand Messages
  • C. Jiang
    Hi folks, I am running Windows 7. In it I run a VMware (Fedora linux) where my projects files are. I mapped the projects folder in windows 7. The Vim is
    Message 1 of 3 , Apr 30, 2010
      Hi folks,

      I am running Windows 7. In it I run a VMware (Fedora linux) where my
      projects files are. I mapped the projects folder in windows 7. The
      Vim is installed on windows 7 and I can use the mouse to point a file
      and right click mouse and in the popup menu, use 'Edit with Vim',
      'Edit with existing vim - myopenedfile.txt'.

      The issue is:

      If i open just one file, or open files one by one, ':pwd' in vim will
      show me the correct path where the current file is;

      But if I highlight 2 or more files and right click and open them with
      'open with a single vim', after I check ':pwd' in vim, it shows
      c:\windows\system32.

      Since my tags for the projects is in the top directory of the
      projects, vim won't find the tag file any more.

      Any suggestions is highly appreciated.

      Thanks,

      Ray

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • sc
      ... the simplest will be to ... in your _vimrc, although this setting has its detractors, and some plugins misbehave with it set, or did in the past -- i edit
      Message 2 of 3 , Apr 30, 2010
        On Friday 30 April 2010 10:13:26 am C. Jiang wrote:

        > I am running Windows 7. In it I run a VMware (Fedora linux)
        > where my projects files are. I mapped the projects folder in
        > windows 7. The Vim is installed on windows 7 and I can use
        > the mouse to point a file and right click mouse and in the
        > popup menu, use 'Edit with Vim', 'Edit with existing vim -
        > myopenedfile.txt'.
        >
        > The issue is:
        >
        > If i open just one file, or open files one by one, ':pwd' in
        > vim will show me the correct path where the current file is;
        >
        > But if I highlight 2 or more files and right click and open
        > them with 'open with a single vim', after I check ':pwd' in
        > vim, it shows c:\windows\system32.
        >
        > Since my tags for the projects is in the top directory of the
        > projects, vim won't find the tag file any more.

        the simplest will be to

        :set autochdir

        in your _vimrc, although this setting has its detractors, and
        some plugins misbehave with it set, or did in the past -- i edit
        files all over the place and have come to rely on the fact that
        no matter where i am, :pwd is always current to the file i am
        editing

        sc

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • C. Jiang
        Wow, thank you so much, sc! It works! Ray ... -- You received this message from the vim_use maillist. Do not top-post! Type your reply below the text you are
        Message 3 of 3 , May 1, 2010
          Wow, thank you so much, sc!
          It works!

          Ray

          On Fri, Apr 30, 2010 at 5:39 PM, sc <toothpik@...> wrote:
          > On Friday 30 April 2010 10:13:26 am C. Jiang wrote:
          >
          >> I am running Windows 7. In it I run a VMware (Fedora linux)
          >>  where my projects files are. I mapped the projects folder in
          >>  windows 7.  The Vim is installed on windows 7 and I can use
          >>  the mouse to point a file and right click mouse and in the
          >>  popup menu, use 'Edit with Vim', 'Edit with existing vim -
          >>  myopenedfile.txt'.
          >>
          >> The issue is:
          >>
          >> If i open just one file, or open files one by one, ':pwd' in
          >>  vim will show me the correct path where the current file is;
          >>
          >> But if I highlight 2 or more files and right click and open
          >>  them with 'open with a single vim', after I check ':pwd' in
          >>  vim, it shows c:\windows\system32.
          >>
          >> Since my tags for the projects is in the top directory of the
          >> projects, vim won't find the tag file any more.
          >
          > the simplest will be to
          >
          >    :set autochdir
          >
          > in your _vimrc, although this setting has its detractors, and
          > some plugins misbehave with it set, or did in the past -- i edit
          > files all over the place and have come to rely on the fact that
          > no matter where i am, :pwd is always current to the file i am
          > editing
          >
          > sc
          >
          > --
          > You received this message from the "vim_use" maillist.
          > Do not top-post! Type your reply below the text you are replying to.
          > For more information, visit http://www.vim.org/maillist.php
          >

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        Your message has been successfully submitted and would be delivered to recipients shortly.