Loading ...
Sorry, an error occurred while loading the content.
 

Re: $HOME variable not set properly in XP - showing "test"

Expand Messages
  • Tony Mechelynck
    ... Do you by any chance have a system vimrc ? Its default location is $VIM/vimrc (without any initial . or _ before the filename) but that location depends
    Message 1 of 4 , Apr 29, 2010
      On 29/04/10 04:41, kp wrote:
      > Thanks J├╝rgen.
      >
      > 1. The :vimgrep didn't return any results.
      > 2. Outside vim, %HOME% is not set
      > 3. Before loading the .vimrc, the %HOME% is refering to 'test'
      >
      > But your help, gave me hint. I added this line in the end of .vimrc and
      > it worked
      > let $HOME = $HOMEDRIVE.$HOMEPATH
      >
      > Thanks,
      > Krishna

      Do you by any chance have a "system vimrc"? Its default location is
      $VIM/vimrc (without any initial . or _ before the filename) but that
      location depends on a compile-time setting. The actual location for each
      Vim executable is displayed near the middle of the ":version" output.

      If the file exists, it will be sourced in 'nocompatible' mode, before
      looking for your [._]vimrc.


      Best regards,
      Tony.
      --
      The gods gave man fire and he invented fire engines. They gave him
      love and he invented marriage.

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.