Loading ...
Sorry, an error occurred while loading the content.

Re: :make! delays for several seconds before returning

Expand Messages
  • James Beck
    ... Yep! Found it! Good call. The problem is wineserver. Wine apparently spawns this creature to load the Windows registry and other such things when Windows
    Message 1 of 7 , Mar 8, 2010
    • 0 Attachment
      > The tiny example program I came up with to test the paludis problem also
      > seems to cause a ':make!' hang (but not a ':!make' hang). So,
      > long-story-short, maybe something that's being run in your Makefile is
      > spawning a background process of some sort? (Vim waits for it; the
      > shell [even within Vim] doesn't.)

      Yep! Found it! Good call. The problem is wineserver. Wine apparently
      spawns this creature to load the Windows registry and other such things
      when Windows programs are running. After they finish, the winserver
      typically stays active for 3 seconds (by default) just in case another
      windows process might want to start up. If I start the wineserver manually
      with zero wait time (wineserver -f -p0), :make! exits with a much quicker
      delay (about a second, down from about 4).

      And that solves the case of the slow Vim :make!

      Thanks for your help!

      James

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    Your message has been successfully submitted and would be delivered to recipients shortly.