Loading ...
Sorry, an error occurred while loading the content.
 

Netrw: File modified by just changing the listing style

Expand Messages
  • Jean Johner
    Hello, This concerns netrw v137e with Linux operating system. Please do the following: gvim . (to browse the current directory) Type i 8 times (to change the
    Message 1 of 10 , Mar 5, 2010
      Hello,
      This concerns netrw v137e with Linux operating system.
      Please do the following:
      gvim . (to browse the current directory)
      Type i 8 times (to change the listing style 8 times)
      :q (to quit)
      You get
      E37: No write since last change ...
      E162: No write since last change ...

      What change?

      This does not occur with the Windows 7.2.0 version.

      Best regards

      Jean Johner

      --
      You received this message from the "vim_use" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Charles Campbell
      ... I m afraid that I don t see that: vim -u NONE ... [hit i 8 times] ... There was no No write since last change messages issued. Now, I used netrw
      Message 2 of 10 , Mar 5, 2010
        Jean Johner wrote:
        > Hello,
        > This concerns netrw v137e with Linux operating system.
        > Please do the following:
        > gvim . (to browse the current directory)
        > Type i 8 times (to change the listing style 8 times)
        > :q (to quit)
        > You get
        > E37: No write since last change ...
        > E162: No write since last change ...
        >
        > What change?
        >
        > This does not occur with the Windows 7.2.0 version.
        >
        I'm afraid that I don't see that:

        vim -u NONE
        :set nocp
        :so ~/.vim/plugin/netrwPlugin.vim
        [hit i 8 times]
        :q

        There was no "No write since last change" messages issued. Now, I used
        netrw v137f...

        Regards,
        Chip Campbell

        --
        You received this message from the "vim_use" maillist.
        Do not top-post! Type your reply below the text you are replying to.
        For more information, visit http://www.vim.org/maillist.php
      • sc
        ... for me this shows up a little differently -- when i press i the eighth time i get a Save changes to NetrwTreeListing 1 ? dialog -- after i select No it
        Message 3 of 10 , Mar 5, 2010
          On Friday 05 March 2010 08:10:41 am Jean Johner wrote:

          > Hello,
          > This concerns netrw v137e with Linux operating system.
          > Please do the following:
          > gvim . (to browse the current directory)
          > Type i 8 times (to change the listing style 8 times)
          >
          > :q (to quit)
          >
          > You get
          > E37: No write since last change ...
          > E162: No write since last change ...
          >
          > What change?
          >
          > This does not occur with the Windows 7.2.0 version.

          for me this shows up a little differently -- when i press 'i' the
          eighth time i get a Save changes to "NetrwTreeListing 1"? dialog
          -- after i select No it shows the next format, from which i am
          able to quit without errors

          i am using netrw v137g

          sc

          --
          You received this message from the "vim_use" maillist.
          Do not top-post! Type your reply below the text you are replying to.
          For more information, visit http://www.vim.org/maillist.php
        • Charles E Campbell Jr
          ... Well, I was finally able to get a related anomaly (I got a NetrwTreeListing 1.swp file) by using vim -u NONE ... and hitting i several times (until I got
          Message 4 of 10 , Mar 6, 2010
            sc wrote:
            > On Friday 05 March 2010 08:10:41 am Jean Johner wrote:
            >
            >
            >> Hello,
            >> This concerns netrw v137e with Linux operating system.
            >> Please do the following:
            >> gvim . (to browse the current directory)
            >> Type i 8 times (to change the listing style 8 times)
            >>
            >> :q (to quit)
            >>
            >> You get
            >> E37: No write since last change ...
            >> E162: No write since last change ...
            >>
            >> What change?
            >>
            >> This does not occur with the Windows 7.2.0 version.
            >>
            >
            > for me this shows up a little differently -- when i press 'i' the
            > eighth time i get a Save changes to "NetrwTreeListing 1"? dialog
            > -- after i select No it shows the next format, from which i am
            > able to quit without errors
            >
            > i am using netrw v137g
            >
            Well, I was finally able to get a related anomaly (I got a
            NetrwTreeListing 1.swp file) by using
            vim -u NONE
            :set nocp
            :filetype plugin on
            :so ~/.vim/plugin/netrwPlugin.vim

            and hitting "i" several times (until I got a tree listing). I believe
            v137h now fixes this problem.
            (http://mysite.verizon.net/astronaut/vim/index.html#NETRW)

            Regards,
            Chip Campbell

            --
            You received this message from the "vim_use" maillist.
            Do not top-post! Type your reply below the text you are replying to.
            For more information, visit http://www.vim.org/maillist.php
          • sc
            On Saturday 06 March 2010 12:45:54 pm Charles E Campbell Jr ... i m not sure how big a problem it is -- i ve never hit i eight times in a row before seeing
            Message 5 of 10 , Mar 6, 2010
              On Saturday 06 March 2010 12:45:54 pm Charles E Campbell Jr
              wrote:

              > and hitting "i" several times (until I got a tree
              > listing). I believe v137h now fixes this problem.
              > (http://mysite.verizon.net/astronaut/vim/index.html#NETRW)
              >

              i'm not sure how big a problem it is -- i've never hit 'i' eight
              times in a row before seeing this thread

              i do still get the Save changes to "NetrwTreeListing 1"? dialog
              on the eighth 'i' with v137h, but i do hope you're not spending a
              lot of time chasing it down -- i rarely change the listing
              format, and when i do, it's to get dates and sizes with one press
              of 'i'

              sc

              --
              You received this message from the "vim_use" maillist.
              Do not top-post! Type your reply below the text you are replying to.
              For more information, visit http://www.vim.org/maillist.php
            • François Ingelrest
              ... Well, that s one manifestation of a bug, there may be other ones. -- You received this message from the vim_use maillist. Do not top-post! Type your
              Message 6 of 10 , Mar 6, 2010
                On Sat, Mar 6, 2010 at 20:21, sc <toothpik@...> wrote:
                > i'm not sure how big a problem it is -- i've never hit 'i' eight
                > times in a row before seeing this thread

                Well, that's one manifestation of a bug, there may be other ones.

                --
                You received this message from the "vim_use" maillist.
                Do not top-post! Type your reply below the text you are replying to.
                For more information, visit http://www.vim.org/maillist.php
              • Jean Johner
                On Mar 6, 7:45 pm, Charles E Campbell Jr ... Hi Chip, Using the Linux 7.2 distribution with the default compiling options, copying
                Message 7 of 10 , Mar 7, 2010
                  On Mar 6, 7:45 pm, Charles E Campbell Jr <drc...@...>
                  wrote:
                  > vim -u NONE
                  > :set nocp
                  > :filetype plugin on
                  > :so ~/.vim/plugin/netrwPlugin.vim
                  >
                  > and hitting "i" several times (until I got a tree listing).   I believe
                  > v137h now fixes this problem.
                  >   (http://mysite.verizon.net/astronaut/vim/index.html#NETRW)

                  Hi Chip,
                  Using the Linux 7.2 distribution with the default compiling options,
                  copying the vim72/runtime/vimrc_example.vim to ~/.vimrc and using
                  netrw v137h gives no error message when typing "i" 8 times and
                  quitting.

                  However, just adding
                  set hidden
                  in .vimrc (this allows opening a new buffer without saving the current
                  one)
                  results in the error message to show again.

                  Thank you for trying again with that option set.

                  Thank you for your incredibly quick reactivity to netrw problems.

                  Regards,

                  Jean Johner

                  --
                  You received this message from the "vim_use" maillist.
                  Do not top-post! Type your reply below the text you are replying to.
                  For more information, visit http://www.vim.org/maillist.php
                • Jean Johner
                  ... It seems that version netrw v137j solves the above problem. Thank you Chip. Best regards Jean Johner -- You received this message from the vim_use
                  Message 8 of 10 , Mar 17, 2010
                    On Mar 7, 6:45 pm, Jean Johner <jean.joh...@...> wrote:
                    > Thank you for trying again with that option set.

                    It seems that version netrw v137j solves the above problem.
                    Thank you Chip.

                    Best regards

                    Jean Johner

                    --
                    You received this message from the "vim_use" maillist.
                    Do not top-post! Type your reply below the text you are replying to.
                    For more information, visit http://www.vim.org/maillist.php
                  • Jean Johner
                    Hello Chip, I just installed netrw v137k. With only set hidden in the .vimrc and typing gvim . i 8 times q: The error appears again. I noted above that the
                    Message 9 of 10 , Mar 27, 2010
                      Hello Chip,

                      I just installed netrw v137k.

                      With only "set hidden" in the .vimrc and typing
                      gvim .
                      i 8 times
                      q:

                      The error appears again.
                      I noted above that the error had been fixed with v137j.
                      Did you change something?

                      Best regards
                      Jean

                      --
                      You received this message from the "vim_use" maillist.
                      Do not top-post! Type your reply below the text you are replying to.
                      For more information, visit http://www.vim.org/maillist.php

                      To unsubscribe from this group, send email to vim_use+unsubscribegooglegroups.com or reply to this email with the words "REMOVE ME" as the subject.
                    • Jean Johner
                      ... Hello Chip, I installed v137m, this time the error has gone away. Thank you. Best regards Jean Johner -- You received this message from the vim_use
                      Message 10 of 10 , Apr 1, 2010
                        On Mar 30, 9:28 pm, Charles Campbell wrote:

                        > I'm not sure why that error went away -- but 137m has a "setlocal nomod"
                        > inserted, hopefully at the right place, just to handle this problem.

                        Hello Chip,
                        I installed v137m, this time the error has gone away.
                        Thank you.

                        Best regards
                        Jean Johner

                        --
                        You received this message from the "vim_use" maillist.
                        Do not top-post! Type your reply below the text you are replying to.
                        For more information, visit http://www.vim.org/maillist.php

                        To unsubscribe, reply using "remove me" as the subject.
                      Your message has been successfully submitted and would be delivered to recipients shortly.