Loading ...
Sorry, an error occurred while loading the content.

taglist and exuberant ctags

Expand Messages
  • Roald de Vries
    Dear all, I want to use the taglist plugin, but have the following problem: the old ctags is installed into the /usr/bin/ directory; exuberant ctags is
    Message 1 of 4 , Dec 3, 2009
    • 0 Attachment
      Dear all,

      I want to use the taglist plugin, but have the following problem: the
      old ctags is installed into the /usr/bin/ directory; exuberant ctags
      is installed into /opt/local/bin/; in my PATH env var, /opt/local/bin/
      precedes /usr/bin/; in bash, `type ctags` gives /opt/local/bin/, but
      in vim ':!type ctags' gives /usr/bin/ (even though /opt/local/bin/
      precedes /usr/bin/ in ':!echo $PATH'). Is this an error in vim? Or do
      I miss something?

      Regards, Roald

      --
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
    • Nat Williams
      ... This doesn t really address the cause of your problem, but putting the following line in .vimrc should fix it: let Tlist_Ctags_Cmd= /opt/local/bin/ctags
      Message 2 of 4 , Dec 3, 2009
      • 0 Attachment
        On Thu, Dec 3, 2009 at 10:13 AM, Roald de Vries <downaold@...> wrote:
        >
        > Dear all,
        >
        > I want to use the taglist plugin, but have the following problem: the
        > old ctags is installed into the /usr/bin/ directory; exuberant ctags
        > is installed into /opt/local/bin/; in my PATH env var, /opt/local/bin/
        > precedes /usr/bin/; in bash, `type ctags` gives /opt/local/bin/, but
        > in vim ':!type ctags' gives /usr/bin/ (even though /opt/local/bin/
        > precedes /usr/bin/ in ':!echo $PATH'). Is this an error in vim? Or do
        > I miss something?
        >
        > Regards, Roald
        >

        This doesn't really address the cause of your problem, but putting the
        following line in .vimrc should fix it:

        let Tlist_Ctags_Cmd='/opt/local/bin/ctags'

        Nat

        --
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
      • Dennis Benzinger
        Hello Roald! ... Is the correct path set when you start Vim? The :! command executes a new shell which probably sets the correct path. HTH, Dennis Benzinger --
        Message 3 of 4 , Dec 3, 2009
        • 0 Attachment
          Hello Roald!

          -------- Original-Nachricht --------
          > Datum: Thu, 3 Dec 2009 17:13:41 +0100
          > Von: Roald de Vries <downaold@...>
          > An: vim_use@...
          > Betreff: taglist and exuberant ctags

          > Dear all,
          >
          > I want to use the taglist plugin, but have the following problem: the
          > old ctags is installed into the /usr/bin/ directory; exuberant ctags
          > is installed into /opt/local/bin/; in my PATH env var, /opt/local/bin/
          > precedes /usr/bin/; in bash, `type ctags` gives /opt/local/bin/, but
          > in vim ':!type ctags' gives /usr/bin/ (even though /opt/local/bin/
          > precedes /usr/bin/ in ':!echo $PATH'). Is this an error in vim? Or do
          > I miss something?
          > [...]

          Is the correct path set when you start Vim? The :! command executes a new
          shell which probably sets the correct path.


          HTH,
          Dennis Benzinger

          --
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
        • Roald de Vries
          Hi Dennis, ... It appeared that I missed something; I had put the correct path in my .bash_login, but my .bashrc stripped away duplicates --- in my case the
          Message 4 of 4 , Dec 3, 2009
          • 0 Attachment
            Hi Dennis,

            On Dec 3, 2009, at 5:29 PM, Dennis Benzinger wrote:

            > Hello Roald!
            >
            > -------- Original-Nachricht --------
            >> Datum: Thu, 3 Dec 2009 17:13:41 +0100
            >> Von: Roald de Vries <downaold@...>
            >> An: vim_use@...
            >> Betreff: taglist and exuberant ctags
            >
            >> Dear all,
            >>
            >> I want to use the taglist plugin, but have the following problem: the
            >> old ctags is installed into the /usr/bin/ directory; exuberant ctags
            >> is installed into /opt/local/bin/; in my PATH env var, /opt/local/
            >> bin/
            >> precedes /usr/bin/; in bash, `type ctags` gives /opt/local/bin/, but
            >> in vim ':!type ctags' gives /usr/bin/ (even though /opt/local/bin/
            >> precedes /usr/bin/ in ':!echo $PATH'). Is this an error in vim? Or do
            >> I miss something?
            >> [...]
            >
            > Is the correct path set when you start Vim? The :! command executes
            > a new
            > shell which probably sets the correct path.

            It appeared that I missed something; I had put the correct path in
            my .bash_login, but my .bashrc stripped away duplicates --- in my case
            the first occurrance of /opt/local/bin. Thanks for your help.

            --
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
          Your message has been successfully submitted and would be delivered to recipients shortly.