Loading ...
Sorry, an error occurred while loading the content.
 

Re: some option settings have to be at about bottom of vimrc file.

Expand Messages
  • Tony Mechelynck
    On 11/10/09 14:06, Tim Chase wrote: [Dewr wrote] ... In fact, if (like me) you source the vimrc_example.vim (the real name of that file), there are very _few_
    Message 1 of 5 , Nov 7, 2009
      On 11/10/09 14:06, Tim Chase wrote:
      [Dewr wrote]
      >> Thank you very much! these codes were in example_vimrc.
      >
      > Then all you have to do is either
      >
      > 1) move the "source example_vimrc" to the top of your vimrc (my
      > preferred solution because it will help prevent similar issues if
      > they would normally appear later) or
      >
      > 2) make sure that your "set nobackup" comes after the "source
      > example_vimrc" regardless of where they are in the file
      >
      > -tim

      In fact, if (like me) you source the vimrc_example.vim (the real name of
      that file), there are very _few_ settings which need to be before it, so
      it can be near the top of your vimrc (and it should, so, like Tim said,
      any option you set yourself in your vimrc will override the example
      vimrc's setting and not vice-versa).

      One of the very few settings which need to be before sourcing the
      example vimrc rather than after it is setting the menu and messages
      language, because that must happen before defining the menus, and the
      example vimrc sets them up (implicitly, via "filetype plugin indent on"
      and "syntax on").


      Best regards,
      Tony.
      --
      Although the moon is smaller than the earth, it is farther away.

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.