Loading ...
Sorry, an error occurred while loading the content.

vimgrep: not jump to finding result

Expand Messages
  • Steven Woody
    Hi, After vimgrep finished searching, it put findings in a quickfix buffer and open and jump to the first entry in the finding list. But since I like to run
    Message 1 of 3 , Oct 31, 2009
    • 0 Attachment
      Hi,

      After vimgrep finished searching, it put findings in a quickfix buffer
      and open and jump to the first entry in the finding list. But since
      I like to run vimgrep with a 'noauto' prefix to gain some performance
      improvements, so I if vimgrep open a found file for me, this file
      will not get processed by auto-commands in variety of plugins (for
      example, if a file is opened in that, i won't get syntax
      highlighting). But, if I manually open found files from the
      quicklist, I think the auto-commands get chance to run.

      Any idea? Thanks.

      --
      Life is the only flaw in an otherwise perfect nonexistence
      -- Schopenhauer

      narke
      public key at http://subkeys.pgp.net:11371 (narkewoody@...)

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Ben Fritz
      ... If you read :help :vimgrep or the nice tip we have on the topic ( http://vim.wikia.com/wiki/Find_in_files_within_Vim ) you ll see that you can simply add
      Message 2 of 3 , Nov 3, 2009
      • 0 Attachment
        On Nov 1, 12:25 am, Steven Woody <narkewo...@...> wrote:
        >
        > After vimgrep finished searching, it put findings in a quickfix buffer
        > and open and jump to the first entry in the finding list.

        If you read :help :vimgrep or the nice tip we have on the topic
        ( http://vim.wikia.com/wiki/Find_in_files_within_Vim ) you'll see that
        you can simply add the 'j' flag to the end of the vimgrep pattern to
        avoid jumping to the first match.
        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Steven Woody
        ... Thanks for the hint. -- Life is the only flaw in an otherwise perfect nonexistence -- Schopenhauer narke public key at http://subkeys.pgp.net:11371
        Message 3 of 3 , Nov 25, 2009
        • 0 Attachment
          On Wed, Nov 4, 2009 at 12:01 AM, Ben Fritz <fritzophrenic@...> wrote:
          >
          >
          >
          > On Nov 1, 12:25 am, Steven Woody <narkewo...@...> wrote:
          >>
          >> After vimgrep finished searching, it put findings in a quickfix buffer
          >> and open and jump to the first entry in the finding list.
          >
          > If you read :help :vimgrep or the nice tip we have on the topic
          > ( http://vim.wikia.com/wiki/Find_in_files_within_Vim ) you'll see that
          > you can simply add the 'j' flag to the end of the vimgrep pattern to
          > avoid jumping to the first match.
          > >
          >

          Thanks for the hint.

          --
          Life is the only flaw in an otherwise perfect nonexistence
          -- Schopenhauer

          narke
          public key at http://subkeys.pgp.net:11371 (narkewoody@...)

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        Your message has been successfully submitted and would be delivered to recipients shortly.