Loading ...
Sorry, an error occurred while loading the content.

Re: encoding

Expand Messages
  • Doris Wagner
    hi list, ... I changed this and now it seems to work; ... how can I find out what kind of encoding my terminal uses? many thanx doris
    Message 1 of 5 , Oct 1, 2009
    • 0 Attachment
      hi list,




      > let &termencoding = &encoding
      > set encoding=utf-8
      >

      I changed this and now it seems to work;

      > I would suggest, however, that you use an utf-8 locale, because then
      > you don't have to change encoding settings at all (as long as you work
      > with utf-8 files.)


      how can I find out what kind of encoding my terminal uses?

      many thanx
      doris





      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Tony Mechelynck
      ... Ox9A is not an o-umlaut in Latin1 or UTF-8: in Latin1 it is the control character SCI (Single Character Introducer), and in UTF-8, the _codepoint_ U+009A
      Message 2 of 5 , Oct 31, 2009
      • 0 Attachment
        On 30/09/09 17:07, Doris Wagner wrote:
        >
        > hi list,
        >
        > I am using vim from the terminal (mac os 10.5); I often use german
        > umlauts;
        >
        > now, when I write the umlaut ö with another editor, in my case with
        > texshop, and open the file with vim, there ist no ö displayed, but
        > <9a>;
        > apparently, something with the encoding is wrong;
        >
        > my .vimrc-settings are as in
        >
        > http://hoepfl.de/articles/2007/01/vimderbar.html
        >
        > recommended, that is:
        >
        > set encoding=utf-8
        > set fileencoding=
        > setglobal fileencoding=utf-8
        > set fileencodings=ucs-bom,utf-8,latin1 set termencoding=latin1
        >
        >
        > so can anyone help me?
        >
        > tia
        > doris

        Ox9A is not an o-umlaut in Latin1 or UTF-8: in Latin1 it is the control
        character SCI (Single Character Introducer), and in UTF-8, the
        _codepoint_ U+009A (encoded on disk as 0xC2 0x9A) is the same control
        character, while the _byte_ 0x9A can only be the second or further byte
        of a multibyte sequence.

        I suspect that Texshop is using macroman as its encoding, but only you
        can ascertain that, by trial and error, as follows (in Vim):

        (in the vimrc)
        ...
        if has('multi_byte')
        if &enc !~? '^u'
        if &tenc == ""
        let &tenc = &enc
        endif
        set enc=utf-8
        endif
        if 0
        " the following is optional
        " (check the help before uncommenting)
        set fencs=ucs-bom,utf-8,latin1
        setg bomb fenc=latin1
        endif
        endif
        ...

        (at the keyboard)
        :e ++enc=macroman filename.enc

        replacing "filename.enc" by the filename, of course. (You may want to
        have pre-recorded, using Texshop, a "test file" containing as many
        non-ASCII different characters as you can dream of.)

        If it still isn't that, you'll have to try other charsets (Windows-1252,
        maybe?) as the argument of the ++enc modifier.

        See ":help ++opt"


        Best regards,
        Tony.
        --
        Rule of the Great:
        When people you greatly admire appear to be thinking deep
        thoughts, they probably are thinking about lunch.

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      Your message has been successfully submitted and would be delivered to recipients shortly.